Results 1 to 9 of 9

Thread: Importing tgz file back into Zimbra

Hybrid View

  1. #1
    Join Date
    Jan 2009
    Posts
    6
    Rep Power
    6

    Default Importing tgz file back into Zimbra

    Hi all,

    I'm having an issue with importing a tgz file back into Zimbra. When I select which file to import and clicked on the 'Import' button, nothing happens. There is no error msg or anything. I tried to click several times. The file was exported with a filename name All-2009.tgz
    It's about 8GB. Is that too large of a file? Are any of you having the same issue?

    How long will the import take?

    OS: Windows Server 2003
    Zimbra version: 0.92 build 1433

    Any help appreciated. Thank you

  2. #2
    Join Date
    Oct 2008
    Posts
    29
    Rep Power
    6

    Default

    There is a problem with lack of UI feedback in the current beta and some other usability issues that are resolved in the next release.

    The imports should have eventually completed but an 8GB file will take a very long (possibly an hour or more) to complete. However, the default configuration will do duplicate detection so if you are importing back into a full mailbox, then you would not notice any changes. The current UI would eventually present a completion msg, but that could be easily missed

  3. #3
    Join Date
    Jan 2009
    Posts
    6
    Rep Power
    6

    Default Importing tgz file back into Zimbra

    tfr,

    Thank you for responding.

    It seems like the additional info I added to the post did not register. I would like to add the following:

    At first, I was using version 0.91 build 1344 to import into a clean install of zimbra desktop. This is where I got the 'processing' msg. I left it to run overnight. No 'complete' message was displayed. I then shutdown zimbra and relaunched it, but nothing was in my inbox. I tried killing the process and also restarted the server a few times; still the same issue.

    I tried the import again with the newer version 0.92 build 1433 but that didn't even give me a 'processing' message. I tried this after uninstalling the 0.91 version and reset up the account.

    Is there a command line to import rather than using the UI?
    When is the next release due?

  4. #4
    Join Date
    Oct 2008
    Posts
    29
    Rep Power
    6

    Default

    the completion msg is just a transient green msg at the top of the screen that lasts a few seconds so it would be easily missed.

    There are two things you can verify

    1) check the zimbra desktop log file for errors. If the import is aborting before adding any items to your mailbox, there should be a logged message

    2) do a "tar tfz All-2009.tgz" on any Unix, Mac or windows (if tar is available, otherwise winrar should work) system to verify that your tar file is not corrupt. Some of the earlier betas had issues with large exports so f tar exits abnormally, then the source is the problem

  5. #5
    Join Date
    Jan 2009
    Posts
    6
    Rep Power
    6

    Default Importing tgz file back in Zimbra

    trf,

    I did manage to use winrar to uncompress without errors.

    As for the 'green message', with the version 0.91, "processing" just remains there.

    I edited my email username and servername for security purposes.

    This is what shows in the zdesktop.log file.

    2009-01-11 23:19:40,078 DEBUG [main] [] offline - Loading 6 folder mappings for service 'yahoo.com'
    2009-01-11 23:19:40,078 DEBUG [main] [] offline - Loading 2 attrs for service 'yahoo.com'
    2009-01-11 23:19:40,078 DEBUG [main] [] offline - Loading 19 folder mappings for service 'gmail.com'
    2009-01-11 23:19:40,078 DEBUG [main] [] offline - Loading 2 attrs for service 'gmail.com'
    2009-01-11 23:19:40,078 DEBUG [main] [] offline - Loading 5 folder mappings for service 'aol.com'
    2009-01-11 23:19:40,078 DEBUG [main] [] offline - Loading 8 folder mappings for service '.m***change'
    2009-01-11 23:19:40,078 DEBUG [main] [] offline - Loading 9 folder mappings for service 'hotmail.com'
    2009-01-11 23:19:45,484 INFO [main] [] log - No Transaction manager found - if your webapp requires one, please configure one.
    2009-01-11 23:19:45,687 INFO [main] [] log - Opened D:\Zimbra\zdesktop\jetty\logs\access_log.2009-01-11
    2009-01-11 23:19:45,703 INFO [main] [] log - Started SelectChannelConnector@localhost:7633
    2009-01-11 23:21:27,921 INFO [btpool0-2] [] datasource - Testing: DataSource: { id=d7e3f2eb-0110-4f8f-bdcf-eda872e05c35, type=pop3, isEnabled=true, name=mail name, host=mailserver.com, port=995, connectionType=ssl, username=mailname.com, folderId=2 }
    2009-01-11 23:21:28,765 INFO [btpool0-2] [] datasource - Test succeeded: DataSource: { id=d7e3f2eb-0110-4f8f-bdcf-eda872e05c35, type=pop3, isEnabled=true, name=mail name, host=mailserver.com, port=995, connectionType=ssl, username=mailname.com, folderId=2 }
    2009-01-11 23:21:28,765 INFO [btpool0-2] [] offline - SMTP Testing: DataSource: { id=d7e3f2eb-0110-4f8f-bdcf-eda872e05c35, type=pop3, isEnabled=true, name=mail name, host=mailserver.com, port=995, connectionType=ssl, username=mailname.com, folderId=2 }
    2009-01-11 23:21:29,734 INFO [btpool0-2] [] offline - SMTP Test Succeeded: DataSource: { id=d7e3f2eb-0110-4f8f-bdcf-eda872e05c35, type=pop3, isEnabled=true, name=mail name, host=mailserver.com, port=995, connectionType=ssl, username=mailname.com, folderId=2 }
    2009-01-11 23:21:29,828 WARN [btpool0-2] [] misc - checkValue: no attribute info for: zimbraDataSourceAccountSetup
    2009-01-11 23:22:49,062 INFO [Shutdown] [] log - Shutdown hook executing
    2009-01-11 23:22:51,796 INFO [Shutdown] [] log - Shutdown hook complete
    2009-01-11 23:30:14,500 DEBUG [main] [] offline - Loading 6 folder mappings for service 'yahoo.com'
    2009-01-11 23:30:14,500 DEBUG [main] [] offline - Loading 2 attrs for service 'yahoo.com'
    2009-01-11 23:30:14,500 DEBUG [main] [] offline - Loading 19 folder mappings for service 'gmail.com'
    2009-01-11 23:30:14,500 DEBUG [main] [] offline - Loading 2 attrs for service 'gmail.com'
    2009-01-11 23:30:14,500 DEBUG [main] [] offline - Loading 5 folder mappings for service 'aol.com'
    2009-01-11 23:30:14,500 DEBUG [main] [] offline - Loading 8 folder mappings for service '.m***change'
    2009-01-11 23:30:14,500 DEBUG [main] [] offline - Loading 9 folder mappings for service 'hotmail.com'
    2009-01-11 23:30:16,687 INFO [main] [] log - No Transaction manager found - if your webapp requires one, please configure one.
    2009-01-11 23:30:16,906 INFO [main] [] log - Opened D:\Zimbra\zdesktop\jetty\logs\access_log.2009-01-11
    2009-01-11 23:30:16,906 INFO [main] [] log - Started SelectChannelConnector@localhost:7633
    2009-01-11 23:37:08,843 INFO [Shutdown] [] log - Shutdown hook executing
    2009-01-11 23:37:09,671 INFO [Shutdown] [] log - Shutdown hook complete

  6. #6
    Join Date
    Jan 2009
    Posts
    6
    Rep Power
    6

    Default Import .tgz file

    Zimbra Support,

    I'm still not able to import the .tgz file. I did try the latest release ver 1.0 but still no luck. I also tried to just copy the entire 'store' folder which I also saved back after the new installation, but nothing appears in my inbox.
    What is the specific location to copy back into or how should this be done?
    In the new version, is the issue of having the incorrect date/time stamp on the messages fixed?

    Thank you

  7. #7
    Join Date
    Oct 2008
    Posts
    29
    Rep Power
    6

    Default

    There are a few things we can do to try to debug this

    1) enable debug logging on the account setup page

    2) check your temp directory (/tmp on unix/osx or possibly C:\Users\userid\AppData\Local\Temp or the TEMP environment var on vista for a file *upload*. Zimbra Desktop spools all uploaded files to the temp directory and wait for them to complete before processing. Because this is such a large file, it will continue growing for quite a while

    3) try exporting and then importing a single folder to verify that small uploads work.

    By the way, what type of account (zimbra, imap, ymail, gmail...) is this synced from? If it is a source that maintains data remotely (unlike POP), then you definitely do NOT want to import the entire tgz to a new account created during a reinstall. If you export and reimport directly to the EXACT same instance of desktop/account combination, then import will check for duplicate data. However, if you are importing to a different mailbox (or even a mailbox that has had a "reset data" done to it", then you will ADD everything bak as duplicates - not what you probably expected or wanted. Import is normally an additive feature where all items in the tgz are added to the local account as if you had created them offline and then are synced back to the original server on the next sync interval

  8. #8
    Join Date
    Jan 2009
    Posts
    6
    Rep Power
    6

    Default Import tgz back into Zimbra

    tfr,

    1) I did enable the debug but wasn't able to find the 'upload' file.
    2) I installed the zimbra client on my D: drive; if that makes any difference
    3) Right now, there aren't any emails in that account. I saved the .msg files
    before I did the reinstall to ver1.0.
    4) This is a PoP account from other email provider, not ymail, gmail, etc.

    If the import doesn't work, how can I put the .msg files back into where I can see them in my inbox again? I tried to copy them back to the 'store' folder location but nothing appears.

    (I tried the quick reply but my message didn't appear)

  9. #9
    Join Date
    Oct 2008
    Posts
    29
    Rep Power
    6

    Default

    You cannot copy eml files back to the application tree - there is a full database that manages msg files and all other account data.

    However, in the next RC version (might already be out on the "fasttrack" builds because I checked in @ the end of last week), I added a new feature to allow you to import eml files through the import/export wizard if you create a tar-gz (.tgz) file out of them. If you are just trying to re-import the POP msgs, that is probably your best solution. You can create a tgz file with winrar-like util or UNIX command line. VCard and ICS files can also be imported this way which makes transferring data from other systems easier

    The only current limitation is that you cannot set the "read" flag on msgs this way. I will be allowing that via setting the "read-only" flag on the .eml soon. Also, the msg date is derived from the date of the eml files, not the Date header, but that should not be a problem for you because the dates in your old tgz were set correctly

Similar Threads

  1. [SOLVED] parts_decode_ext error
    By jsabater in forum Administrators
    Replies: 7
    Last Post: 10-13-2008, 07:24 AM
  2. Replies: 12
    Last Post: 02-25-2008, 06:28 PM
  3. Replies: 22
    Last Post: 12-02-2007, 04:05 PM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  5. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 12:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •