Results 1 to 6 of 6

Thread: Help in Message Encoding in Zimbra Desktop

  1. #1
    Join Date
    Feb 2009
    Posts
    3
    Rep Power
    6

    Default Help in Message Encoding in Zimbra Desktop

    I found that there is a problem in charset encoding for the subject header.
    The subject header should be in Traditional Chinese, however it turned to garbage string.
    I wonder if there are any ways to solve this problem.

    Thanks.
    Attached Images Attached Images

  2. #2
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    Please right click on the message, then "Show Original". Copy and Paste all the text into a file, and attach the text file here.

    We are only interested in email headers. You may scrub any private info in the email body before attaching the file.

  3. #3
    Join Date
    Feb 2009
    Posts
    3
    Rep Power
    6

    Default

    Thanks for your help

    I have attached 2 text files (in Unicode)
    The first file is for the first highlighted email subject which displayed properly in Chinese.
    The second file is for the second highlighted email subject which displayed incorrectly.

    My email address was altered to "xxxxxxxxx@xxxxxxx.com"
    Attached Files Attached Files

  4. #4
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    It looks like the second message has an invalid Subject header.

    Subject header should be encoded according to RFC 2047. The first one was encoded properly; but the second message's Subject header was not encoded at all.

  5. #5
    Join Date
    Feb 2009
    Posts
    3
    Rep Power
    6

    Default

    So, would there be any solutions for this issue?
    It is because thee Windows (Live) Mail / Opera Mail can display it without any problems

  6. #6
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    Can you check the "original" on live mail and opera, to see whether the Subject is the same as the one in your second text file?

    Maybe those clients are supporting non-standard stuff. I don't think zimbra will do that.

    Do you get this kind of messages a lot? Do you know what client created these malformed emailed?

Similar Threads

  1. [SOLVED] parts_decode_ext error
    By jsabater in forum Administrators
    Replies: 7
    Last Post: 10-13-2008, 07:24 AM
  2. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 01:00 AM
  3. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  4. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 02:30 PM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •