Results 1 to 5 of 5

Thread: Deploying Zimlets in ZD2 Beta1

  1. #1
    Join Date
    Nov 2007
    Posts
    9
    Rep Power
    7

    Default Deploying Zimlets in ZD2 Beta1

    I have looked at the Wiki and various threads related to deploying zimlets in ZD, but none of the solutions have worked for me, and I am wondering if the correct procedure for doing so has been changed in ZD2, or is this even possible at this stage of the products development.

    Otherwise it looks very promising and is a vast improvement over ZD1, which I basically stopped using after upgrading to ZCS FOSS 6.01.

  2. #2
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    Deploying zimlets on zd2 is easier, but it is still a manual step. We are working on installing zimlets via UI - hopefully it will make to the final release of zd2.

    Here is how:

    1) Copy your zimlet bundle (should be a zip file) under the "zimlets" folder in "user data home". This link tells you where to find user data location on different platforms: Zimbra Desktop 2 FAQ - Zimbra :: Wiki

    2) Shutdown ZD backend service: Zimbra Desktop 2 FAQ - Zimbra :: Wiki

    3) Start ZD. The new zimlet(s) will be deployed during startup. And new zimlets will also survive future upgrades of ZD.



    Quote Originally Posted by Somertech View Post
    I have looked at the Wiki and various threads related to deploying zimlets in ZD, but none of the solutions have worked for me, and I am wondering if the correct procedure for doing so has been changed in ZD2, or is this even possible at this stage of the products development.

    Otherwise it looks very promising and is a vast improvement over ZD1, which I basically stopped using after upgrading to ZCS FOSS 6.01.

  3. #3
    Join Date
    Nov 2007
    Posts
    9
    Rep Power
    7

    Default

    Awesome! Thanks. This worked Perfectly.

    For any others out there, I am running Windows Vista 64 bit.

  4. #4
    Join Date
    May 2006
    Location
    London, UK
    Posts
    181
    Rep Power
    9

    Default

    I am unable to install zimlets using this method. I have had to resort to creating '_dev' folder in '~/.zdesktop/zimlets-deployed/' - and copied the unzipped zimlet folders there. That worked, but is only intended as a development technique.

    I am using ZD2 beta1 on Linux - Kubuntu 10.4 (running KDE SC 4.4), 64 bit.

  5. #5
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    Deploying zimlets on zd2 is easier, but it is still a manual step. We are working on installing zimlets via UI - hopefully it will make to the final release of zd2.

    Here is how:

    1) Copy your zimlet bundle (should be a zip file) under the "zimlets" folder in "user data home". This link tells you where to find user data location on different platforms: Zimbra Desktop 2 FAQ - Zimbra :: Wiki

    2) Shutdown ZD backend service: Zimbra Desktop 2 FAQ - Zimbra :: Wiki

    3) Start ZD. The new zimlet(s) will be deployed during startup. And new zimlets will also survive future upgrades of ZD.
    I've followed these steps and it appears that the zimlets I'm trying to use are being deployed correctly because they show up on the Zimlets preferences page. But something isn't working right. When I'm on the "Mail" tab I don't see the "Zimlets" section in the left-hand panel. What's kind of strange is if I change to one of the other tabs (Address Book, Calendar, Tasks, etc.) I do see the Zimlets in the left-hand panel. Unfortunately these zimlets that I'm trying to use really need to be visible when I'm viewing email messages. I'm running into this issue on both a Linux desktop (F12) and a Windows 7 system.

    Any help would be appreciated.

    Thanks,
    John

    Edit: Sorry, just found out that a bug 42575 has already been opened for this issue.
    Last edited by soxfan; 02-11-2010 at 05:42 AM. Reason: Found issue in bugzilla

Similar Threads

  1. Replies: 0
    Last Post: 04-24-2009, 09:37 AM
  2. Deploying Zimlets
    By krdell in forum Zimlets
    Replies: 1
    Last Post: 04-08-2008, 12:43 PM
  3. where are my zimlets ?
    By santo in forum Zimlets
    Replies: 21
    Last Post: 06-05-2007, 07:30 AM
  4. Does Upgrading always require deploying zimlets again
    By nfear24 in forum Administrators
    Replies: 2
    Last Post: 04-25-2007, 11:46 AM
  5. Deploying Zimlets
    By darwinian in forum Zimlets
    Replies: 8
    Last Post: 03-01-2006, 09:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •