Page 1 of 2 12 LastLast
Results 1 to 10 of 23

Thread: Setting Zimbra Desktop as default mail client in XP/Vista/Win 7

Hybrid View

  1. #1
    Join Date
    Jan 2008
    Posts
    70
    Rep Power
    7

    Default Setting Zimbra Desktop as default mail client in XP/Vista/Win 7

    Can Zimbra Desktop be registered as the default mail client in XP/Vista/Win 7 so that commands such as "start mailto" work? We are migrating from Outlook Express. I have an application that uses quite a few instances of the "start mailto <email address>". All those links will break if I can't set the default email client to ZD. I am running the latest version.

    Thanks.

  2. #2
    Join Date
    Nov 2010
    Posts
    2
    Rep Power
    4

    Default

    Yes it can. Just tick the check box "Use Zimbra Desktop as default mail application" on tab Preferences.

  3. #3
    Join Date
    Oct 2008
    Location
    Toronto
    Posts
    46
    Rep Power
    7

    Default

    Except in Windows 7 Pro 64bit. IT DOESN'T WORK! And it still doesn't work in 2.01 either. Get "unable to load configuration file" error.
    Last edited by myriad; 12-12-2010 at 07:01 AM.

  4. #4
    Join Date
    Dec 2010
    Posts
    1
    Rep Power
    4

    Default

    Not working for me in Win7 Enterprise 64bit. "Use Zimbra Desktop as default mail app" is grayed out.

  5. #5
    Join Date
    Nov 2010
    Posts
    17
    Rep Power
    4

    Default

    Anyone get this resolved?

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by craftedpacket View Post
    Anyone get this resolved?
    Have you tried the solution posted above and does it work for you?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Apr 2006
    Posts
    29
    Rep Power
    9

    Default

    I have it working with a modified version of these instructions. ZD was already set as the default mail application under ZD preferences but it wasn't working. In the Win7 control panel default it also never appeared as a program option and was never associated to mail.

    What I did was clear out all the values in the first section (registry mailto), closed the registry editor, then went into ZD and set it as the default mail application (the checkbox had unchecked itself). I then checked the registry and the registry mailto section now had Zimbra values populated. Also the Win7 CP defaults now have ZimbraDesktop listed.

    Without restarting, Firefox is opening ZD correctly. This is Win7 64bit.

    BTW in craftedpacket's solution he just missed out "Software" in the registry but I didn't need to touch this. HKEY_LOCAL_MACHINE>Software>Clients>Mail

  8. #8
    Join Date
    Mar 2012
    Posts
    3
    Rep Power
    3

    Default

    Quote Originally Posted by markpr View Post
    I have it working with a modified version of these instructions. ZD was already set as the default mail application under ZD preferences but it wasn't working. In the Win7 control panel default it also never appeared as a program option and was never associated to mail.

    What I did was clear out all the values in the first section (registry mailto), closed the registry editor, then went into ZD and set it as the default mail application (the checkbox had unchecked itself). I then checked the registry and the registry mailto section now had Zimbra values populated. Also the Win7 CP defaults now have ZimbraDesktop listed.

    Without restarting, Firefox is opening ZD correctly. This is Win7 64bit.

    BTW in craftedpacket's solution he just missed out "Software" in the registry but I didn't need to touch this. HKEY_LOCAL_MACHINE>Software>Clients>Mail
    This worked perfectly for me! Thanks Mark!

  9. #9
    Join Date
    May 2006
    Location
    New York, NY
    Posts
    13
    Rep Power
    9

    Default Resolution for broken Win7ers?

    Sorry for updating a long dead thread, however in my experience with mailto: urls failing to open in Zimbra Desktop, I was able to fix the problem by updating

    HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell \Associations\UrlAssociations\mailto\UserChoice
    From:
    "Progid"="Thunderbird.Url.mailto"
    To:
    "Progid"="ZimbraDesktop.Url.mailto"
    Originally, even after setting Zimbra Desktop as the default through the preferences, this stayed as Thunderbird.Url.mailto.

    Manually updating it resolved my issues.

  10. #10
    Join Date
    Jan 2012
    Posts
    7
    Rep Power
    3

    Default

    Quote Originally Posted by bens750 View Post
    Sorry for updating a long dead thread, however in my experience with mailto: urls failing to open in Zimbra Desktop, I was able to fix the problem by updating


    From:
    To:

    Originally, even after setting Zimbra Desktop as the default through the preferences, this stayed as Thunderbird.Url.mailto.

    Manually updating it resolved my issues.
    +1 Worked for me as well (Win7 64)

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 01:55 PM
  2. Did I miss something? (Zimbra GA 6.0.8 on Ubuntu 10.04)
    By vpetersson in forum Installation
    Replies: 2
    Last Post: 10-26-2010, 06:29 AM
  3. Big Fubar on 5 FOSS GA Upgrade
    By uxbod in forum Administrators
    Replies: 24
    Last Post: 01-21-2008, 02:37 AM
  4. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 08:56 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 03:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •