Results 1 to 7 of 7

Thread: Zimbra Desktop Exchange 2007 login problem.

Hybrid View

  1. #1
    Join Date
    Dec 2010
    Posts
    1
    Rep Power
    5

    Default Zimbra Desktop Exchange 2007 login problem.

    Hi,

    I have issues when sync zdesktop 2_0_b10580_linux_i686 with the Exchange 2007 server.

    I faced with following message during login:
    User account authentication failed. Please check username and password.

    Here is log:
    2010-12-03 20:04:13,368 INFO [btpool0-4] [] datasource - Testing: DataSource: { id=640323ee-723f-457e-9166-305b0480e310, type=imap, isEnabled=true, name=<name>, host=<serverName.com>, port=143, connectionType=cleartext, username=<domain>\<user>, folderId=1 }
    2010-12-03 20:04:13,369 DEBUG [btpool0-4] [] datasource - Connect timeout = 60, read timeout = 60
    2010-12-03 20:04:13,389 DEBUG [btpool0-4] [] imap - S: * OK Microsoft Exchange Server 2007 IMAP4 service ready
    2010-12-03 20:04:13,390 DEBUG [btpool0-4] [] imap - C: C01 CAPABILITY
    2010-12-03 20:04:13,391 DEBUG [btpool0-4] [] imap - S: * CAPABILITY IMAP4 IMAP4rev1 LOGINDISABLED IDLE NAMESPACE LITERAL+
    2010-12-03 20:04:13,391 DEBUG [btpool0-4] [] imap - S: C01 OK CAPABILITY completed.
    2010-12-03 20:04:13,392 DEBUG [btpool0-4] [] imap - C: C02 LOGIN "<domain>\\<user>" <password>
    2010-12-03 20:04:13,392 DEBUG [btpool0-4] [] imap - S: C02 BAD Command received in Invalid state.
    2010-12-03 20:04:13,393 WARN [btpool0-4] [] datasource - Test failed: DataSource: { id=640323ee-723f-457e-9166-305b0480e310, type=imap, isEnabled=true, name=<name>, host=<serverName.com>, port=143, connectionType=cleartext, username=<domain>\<user>, folderId=1 }
    com.zimbra.common.service.ServiceException: system failure: Unable to connect to IMAP server: DataSource: { id=640323ee-723f-457e-9166-305b0480e310, type=imap, isEnabled=true, name=<name>, host=<serverName.com>, port=143, connectionType=cleartext, username=<domain>\<user>, folderId=1 }
    ExceptionId:btpool0-4:1291399453393:10e192aab33b5749
    Code:service.FAILURE

    I have no problems using davmail, evolution with these settings.
    I tried other combinations of domain name and user name such as <domain>\\<user> or <domain>\<user>@<serverName.com> no luck

    Thanks for any information on this.

  2. #2
    Join Date
    Jan 2011
    Posts
    5
    Rep Power
    4

    Default

    Has anyone answered this? I am having the same exact problem.

  3. #3
    Join Date
    Jan 2011
    Posts
    5
    Rep Power
    4

    Default

    I have the follow error;

    Cannot connect to "mercury.kokaram.org:143". Please check host/port and network connectivity. I am running Ubuntu Desktop 11.4 and I have crossover installed running Outlook 2007 which works fine. I am using the Exchange MAPI connector, it does say it is a beta.

  4. #4
    Join Date
    Jan 2011
    Posts
    5
    Rep Power
    4

    Default

    Below is the log output;

    2011-01-17 08:04:23,553 DEBUG [main] [] offline - DB migration check started...
    2011-01-17 08:04:23,626 DEBUG [main] [] offline - DB migration done
    2011-01-17 08:04:23,626 DEBUG [main] [] offline - zimbra db optimize started...
    2011-01-17 08:04:23,839 DEBUG [main] [] offline - zimbra db optimize done
    2011-01-17 08:04:25,074 INFO [main] [] extensions - Loading extensions from /opt/zimbra/zdesktop/lib/ext
    2011-01-17 08:04:25,075 INFO [main] [] extensions - Initializing extensions
    2011-01-17 08:04:25,228 DEBUG [main] [] offline - Deploying new zimlets...
    2011-01-17 08:04:25,229 DEBUG [main] [] offline - Zimlets deployment done.
    2011-01-17 08:04:25,412 INFO [main] [] extensions - Post-Initializing extensions
    2011-01-17 08:04:25,606 INFO [main] [] mailbox - Servlet UserServlet starting up
    2011-01-17 08:04:25,733 DEBUG [main] [] offline - Loaded 6 folder mappings for service 'yahoo.com'
    2011-01-17 08:04:25,733 DEBUG [main] [] offline - Loaded 16 folder mappings for service 'gmail.com'
    2011-01-17 08:04:25,733 DEBUG [main] [] offline - Loaded 3 folder mappings for service 'aol.com'
    2011-01-17 08:04:25,733 DEBUG [main] [] offline - Loaded 13 folder mappings for service '.msexchange'
    2011-01-17 08:04:25,733 DEBUG [main] [] offline - Loaded 5 folder mappings for service 'me.com'
    2011-01-17 08:04:25,734 INFO [main] [] offline - Loaded datasource configuration from '/home/vkokaram/zdesktop/conf/datasource.xml'
    2011-01-17 08:04:26,338 INFO [main] [] log - No Transaction manager found - if your webapp requires one, please configure one.
    2011-01-17 08:04:26,686 INFO [main] [] log - No Transaction manager found - if your webapp requires one, please configure one.
    2011-01-17 08:04:26,778 INFO [main] [] log - Started SelectChannelConnector@127.0.0.1:50705
    2011-01-17 08:04:26,965 INFO [sync-manager-init] [] offline - service port is ready.
    2011-01-17 08:04:27,436 INFO [sync-manager-init] [] mailbox - "Error Reports": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:2
    2011-01-17 08:04:27,436 INFO [sync-manager-init] [] mailbox - "Tags": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,436 INFO [sync-manager-init] [] mailbox - "ROOT": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,436 INFO [sync-manager-init] [] mailbox - "Trash": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,436 INFO [sync-manager-init] [] mailbox - "Chats": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,437 INFO [sync-manager-init] [] mailbox - "Notebook": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,437 INFO [sync-manager-init] [] mailbox - "Junk": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,437 INFO [sync-manager-init] [] mailbox - "Notification Mountpoints": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,437 INFO [sync-manager-init] [] mailbox - "Tasks": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,437 INFO [sync-manager-init] [] mailbox - "Calendar": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,437 INFO [sync-manager-init] [] mailbox - "Emailed Contacts": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,438 INFO [sync-manager-init] [] mailbox - "Inbox": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,438 INFO [sync-manager-init] [] mailbox - "Briefcase": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,438 INFO [sync-manager-init] [] mailbox - "Sent": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,439 INFO [sync-manager-init] [] mailbox - "ffffffff-ffff-ffff-ffff-ffffffffffff": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:0
    2011-01-17 08:04:27,439 INFO [sync-manager-init] [] mailbox - "Conversations": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,439 INFO [sync-manager-init] [] mailbox - "USER_ROOT": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,439 INFO [sync-manager-init] [] mailbox - "Contacts": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,439 INFO [sync-manager-init] [] mailbox - "Drafts": Decoded metadata folder counts (c0/d0/u0/du0/s0) i4ms:1
    2011-01-17 08:04:27,837 INFO [btpool0-2] [] extensions - Loading extensions from /opt/zimbra/zdesktop/lib/ext
    2011-01-17 08:05:24,220 INFO [btpool0-2] [] datasource - Testing: DataSource: { id=06e4db4f-3bad-43b8-8b79-7a505bb3e82d, type=imap, isEnabled=true, name=Home, host=mercury.kokaram.org, port=143, connectionType=cleartext, username=vkokaram, folderId=1 }
    2011-01-17 08:05:24,240 DEBUG [btpool0-2] [] datasource - Connect timeout = 60, read timeout = 60
    2011-01-17 08:05:45,300 WARN [btpool0-2] [] datasource - Test failed: DataSource: { id=06e4db4f-3bad-43b8-8b79-7a505bb3e82d, type=imap, isEnabled=true, name=Home, host=mercury.kokaram.org, port=143, connectionType=cleartext, username=vkokaram, folderId=1 }
    com.zimbra.common.service.ServiceException: system failure: Unable to connect to IMAP server: DataSource: { id=06e4db4f-3bad-43b8-8b79-7a505bb3e82d, type=imap, isEnabled=true, name=Home, host=mercury.kokaram.org, port=143, connectionType=cleartext, username=vkokaram, folderId=1 }
    ExceptionId:btpool0-2:1295269545298:9153544c7221f0f8
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:248)
    at com.zimbra.cs.datasource.imap.ConnectionManager.ne wConnection(ConnectionManager.java:161)
    at com.zimbra.cs.datasource.imap.ConnectionManager.op enConnection(ConnectionManager.java:83)
    at com.zimbra.cs.datasource.imap.ImapSync.connect(Ima pSync.java:109)
    at com.zimbra.cs.datasource.imap.ImapSync.test(ImapSy nc.java:71)
    at com.zimbra.cs.offline.OfflineImport.test(OfflineIm port.java:89)
    at com.zimbra.cs.datasource.DataSourceManager.test(Da taSourceManager.java:176)
    at com.zimbra.cs.account.offline.OfflineProvisioning. testDataSource(OfflineProvisioning.java:555)
    at com.zimbra.cs.account.offline.OfflineProvisioning. createDataSourceAccount(OfflineProvisioning.java:6 27)
    at com.zimbra.cs.account.offline.OfflineProvisioning. createAccount(OfflineProvisioning.java:450)
    at com.zimbra.cs.service.admin.CreateAccount.handle(C reateAccount.java:64)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:420)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:274)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:158)
    at com.zimbra.soap.SoapServlet.doWork(SoapServlet.jav a:291)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:212)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:181)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:511)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:390)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:182)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:765)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:418)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:230)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:230)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.Server.handle(Server.java:326)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:543)
    at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:939)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:755)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:212)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:405)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:413)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:451)
    Caused by: java.net.ConnectException: Connection timed out
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(Unknown Source)
    at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
    at java.net.PlainSocketImpl.connect(Unknown Source)
    at java.net.SocksSocketImpl.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at com.zimbra.cs.mailclient.MailConnection.newSocket( MailConnection.java:443)
    at com.zimbra.cs.mailclient.MailConnection.connect(Ma ilConnection.java:83)
    at com.zimbra.cs.datasource.imap.ConnectionManager.ne wConnection(ConnectionManager.java:142)
    ... 36 more
    2011-01-17 08:09:08,459 INFO [Shutdown] [] log - Shutdown hook executing
    2011-01-17 08:09:08,460 INFO [Shutdown] [] log - Graceful shutdown SelectChannelConnector@127.0.0.1:50705
    2011-01-17 08:09:08,479 INFO [Shutdown] [] log - Graceful shutdown org.mortbay.jetty.webapp.WebAppContext@1d2b01b{/service,/opt/zimbra/zdesktop/jetty/webapps/service}
    2011-01-17 08:09:08,479 INFO [Shutdown] [] log - Graceful shutdown org.mortbay.jetty.webapp.WebAppContext@8809ce{/zimbra,/opt/zimbra/zdesktop/jetty/webapps/zimbra}
    2011-01-17 08:09:08,479 INFO [Shutdown] [] log - Graceful shutdown org.mortbay.jetty.webapp.WebAppContext@1f6d2e3{/zimlet,/opt/zimbra/zdesktop/jetty/webapps/zimlet}
    2011-01-17 08:09:10,494 INFO [Shutdown] [] mailbox - Servlet UserServlet shutting down
    2011-01-17 08:09:10,751 WARN [Shutdown] [] ZimbraHttpConnectionManager - shutting down http client idle connection reaper thread
    2011-01-17 08:09:10,856 INFO [Shutdown] [] log - Shutdown hook complete
    vkokaram@LAP-D630:~/zdesktop/log$

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by vkokaram View Post
    com.zimbra.common.service.ServiceException: system failure: Unable to connect to IMAP server: DataSource: { id=06e4db4f-3bad-43b8-8b79-7a505bb3e82d, type=imap, isEnabled=true, name=Home, host=mercury.kokaram.org, port=143,connectionType=cleartext, username=vkokaram, folderId=1 }
    If you read the error you'd see the reason is that you can't connect to the server, are you using the correct port? You also should not be using a cleartext connection to a mail server, your data and password/username can be sniffed when you're using that type of connection.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Jan 2011
    Posts
    5
    Rep Power
    4

    Default

    Thank you for the reply, but it can access the server, I have left the default ports as specified by th edefault config. I am just trying to connect to an internal MS Exchange 2007 server and whiel it is trying to connect I notice it is using the loopback address of 127.0.0.1 even though I have specified the server.

Similar Threads

  1. ZCS7 Beta only Listens on IPv6
    By tobru in forum Installation
    Replies: 2
    Last Post: 03-25-2011, 04:31 AM
  2. Old Backup stay in TO_DELETE status and no clearing..
    By bartounet in forum Administrators
    Replies: 0
    Last Post: 10-05-2010, 08:40 AM
  3. admin consol blank after 5.0.3 upgarde
    By maumar in forum Administrators
    Replies: 6
    Last Post: 03-21-2008, 06:16 AM
  4. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 02:00 AM
  5. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 01:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •