Results 1 to 3 of 3

Thread: Can't open mail from Firefox, but IE OK: Unable to load config file

Hybrid View

  1. #1
    Join Date
    Aug 2011
    Rep Power

    Default Can't open mail from Firefox, but IE OK: Unable to load config file


    I had zimbra installed and everything was working fine. Then I installed Outlook, but I could not get Zimbra to open from Firefox. I then uninstalled Outlook, and had the same problem. I uninstalled Zimbra, downloaded a fresh copy, installed it again and it still will not open mail from my Firefox. Zimbra opens fine from within Internet Explorer.

    I have selected "Use Zimbra Desktop as default mail application" under Preferences.

    When I tried to set the default mail within Firefox (Tools/Options/Applications), it only allowed me to select an exe file. So I have selected zdesktop.exe. However, when I zdesktop.exe, I get the error message "Unable to load config file".

    I have spent hours on this and am unable to get Zimbra to open from within Firefox. Does anyone have a suggestion?


  2. #2
    Join Date
    Sep 2009
    Rep Power


    I'm having the same obnoxious problem with FF 16. No answer to this question in over a year. That's pathetic. Guess I'll just have to resolve the problem myself as always... I tried adding C:\Program Files\Internet\email\Zimbra Desktop\win32\prism\zdclient.exe to the Action list. It opens the existing client when double-clicked in Explorer but does nothing in FF. Because ZD is a messy java app, there is no normal executable to access it, so you can't just add it to the Action list and expect it to work. And because FF is a stone-soup open source project and is maintained by careless coders, who don't bother testing their frequent releases, every update breaks something, guaranteed. Usually it's an add-on that you can't live without. Sometimes it is a vital feature like accessing the default mail client. The only reason I use FF at all is because of all the add-ons that no other browser even comes close to having. It's gotten so I don't update for literally years because of the poor backward-compatibility issues.
    Last edited by foobaz; 11-10-2012 at 10:31 AM.

  3. #3
    Join Date
    Sep 2009
    Rep Power

    Default Solution that worked for me

    OK I got it. Here's what I did, for the sake of others having this same problem:

    1. Deleted the mimeTypes.rdf file from the FF profile folder.
    2. Closed ZD and FF, and restarted FF only.
    3. I went to Tools->Options->Applications->mailto->Use other..., clicked OK without adding anything, and then selected another Content Type. This is important in order to make the change stick. I noticed that now the mailto Action is Use (default).

    Now when I selected File->Email Link..., FF opened ZD with the email ready to send. Great except for one problem. It only worked when ZD was closed. Once it is open it no longer works.

    So, I remembered that I had created a shortcut that opens FF with a particular profile, PLUS, I added -no-remote to the shortcut so I could have multiple instances of FF with different profiles. I removed -no-remote from this shortcut and added it to the other one and now File->Email Link... works as it should. Problem solved.
    Last edited by foobaz; 11-10-2012 at 11:44 AM.

Similar Threads

  1. smtp auth failing 'auth_zimbra: not initialized'
    By kkg039 in forum Administrators
    Replies: 7
    Last Post: 09-05-2013, 11:10 AM
  2. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 06:07 PM
  4. My Zimbra server down ... please help :)
    By frankb in forum Administrators
    Replies: 2
    Last Post: 12-12-2007, 10:29 AM
  5. Mail not getting to mail boxes
    By ehults in forum Installation
    Replies: 5
    Last Post: 10-31-2005, 08:24 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts