Results 1 to 4 of 4

Thread: Lost Everything after Upgrade to 7.1.4

  1. #1
    Join Date
    Jul 2008
    Posts
    5
    Rep Power
    7

    Angry Lost Everything after Upgrade to 7.1.4

    I had Z-desktop working well and got a notice of upgrade. After running the upgrade, I lost my contacts, documents, and briefcase items. Can these be restored?

  2. #2
    Join Date
    Mar 2012
    Posts
    1
    Rep Power
    3

    Thumbs down You should not roll out this 7.1.4 release!

    zdesktop was running fine, however auto-update informed me about a newer release which I should urgently install.
    So I started auto-update.
    The installation failed.

    So I downloaded the tgz and started the installation manually as root.
    It went fine.
    I started the user-script as user.
    It went fine, however -still- complained about not being able to create the program icon.

    I started zdesktop.
    FINE!
    HOWEVER - All DATA is GONE!!!

    No information during installation that all existing user content will be deleted!!!

    YOU ARE ABSOLUTE BEGINNERS TO ROLL OUT SUCH CRAP!!!

    Luckily I did a backup before - so I reinstalled 7.1.2 and copied the zdesktop folder from my backup.

    Where is your howto for manually updating zdesktop if auto-update is not working?
    Where is the hint of how to avoid loosing all data?

    Zdesktop itself is not too bad as a program but this installation bug is not
    acceptable!

    ...
    Edit 1:

    cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=11.10
    DISTRIB_CODENAME=oneiric
    DISTRIB_DESCRIPTION="Ubuntu 11.10"

    md5sum zdesktop_7_1_4_ga_b11273_linux_i686.tgz
    76ad0c6ea4af706d033030c5820eab61 zdesktop_7_1_4_ga_b11273_linux_i686.tgz

    upgrading from
    md5sum zdesktop_7_1_2_ga_b10978_linux_i686.tgz
    2add86bf0469e9e0b3f1e66d2507e064 zdesktop_7_1_2_ga_b10978_linux_i686.tgz

    ...
    Edit 2:
    I got an email notification about an answer from phoenix, however it is not displayed in this thread:


    phoenix replied to a thread you have subscribed to entitled "Lost Everything after Upgrade to 7.1.4" in the General Questions section of Zimbra :: Forums.
    ***************

    ---Quote (Originally by wwwolf)---
    No information during installation that all existing user content will be deleted!!!
    ---End Quote---
    That's because it doesn't do that (although I do believe you've lost yours), it worked fine for me.


    ---Quote (Originally by wwwolf)---
    YOU ARE ABSOLUTE BEGINNERS TO ROLL OUT SUCH CRAP!!!
    ---End Quote---
    I do believe you downloaded that from the Beta page, you do know what beta software is don't you?

    wwwolf answer: I know what beta software is. Please look at the Edit 1. Maybe you copied beta software to release?

    ---Quote (Originally by wwwolf)---
    Luckily I did a backup before - so I reinstalled 7.1.2 and copied the zdesktop folder from my backup.
    ---End Quote---
    How did you do the backup? You should have been able to import that into ZD 7.1.4.

    wwwolf answer: cp zdesktop zdesktop_bu

    ---Quote (Originally by wwwolf)---
    Where is your howto for manually updating zdesktop if auto-update is not working?
    ---End Quote---
    It's in the FAQ that's located in the wiki, didn't you read that first?

    wwwolf answer: URL, please. I read a lot, but did not find an upgrade guide.

    ---Quote (Originally by wwwolf)---
    Where is the hint of how to avoid loosing all data?
    ---End Quote---
    It's called 'good practice' to take a backup first.

    wwwolf answer: Of course it is. But you intend to release business software, so what is your quality level?

    ---Quote (Originally by wwwolf)---
    Zdesktop itself is not too bad as a program but this installation bug is not acceptable!
    ---End Quote---
    It didn't have that 'bug' for me, downloading/extracting the beta and installing it over an older version of ZD worked fine for me.

    wwwolf answer: Good for you, but for release testing I would suggest you take some common linux distributions and work through some use cases in different environments.

    ***************
    ...
    Edit 3:

    Regarding phoenix hint to read the FAQ - of course I did.
    Quite a lot stuff...

    <snip>
    I have older versions of Zimbra Desktop installed. Can I upgrade to the latest version of Zimbra Desktop?

    Current installations of Zimbra Desktop 2.0.x can be upgraded to 7.1 directly. To upgrade, just simply run the latest installer. All user settings and data are preserved during the upgrade.
    </snap>

    "are preserved during the upgrade" contradicts with "It's called 'good practice' to take a backup first.".
    Last edited by wwwolf; 03-20-2012 at 04:00 AM. Reason: additional information

  3. #3
    Join Date
    Aug 2011
    Posts
    39
    Rep Power
    4

    Default

    Quote Originally Posted by wwwolf View Post
    zdesktop was running fine, however auto-update informed me about a newer release which I should urgently install.
    So I started auto-update.
    The installation failed.

    What version 7.1.4 and Build number did it update you to?

    I too learned the very hard way but that was when I upgraded from version 7.0 to 7.1.2. However, just like yourself, I checked and ran auto-update and it told me there is a new ZD 7.1.4 Build. It downloaded the 146MB (?) file but auto-update failed to install (as always for some reason on my case) it. So, I manually went to Zimbra site and downloaded ZD 7.1.4 Build 11273 tgz file for Linux.

    So I downloaded the tgz and started the installation manually as root.
    It went fine.
    I started the user-script as user.
    It went fine, however -still- complained about not being able to create the program icon.

    I started zdesktop.
    FINE!
    HOWEVER - All DATA is GONE!!!
    Ouch!! My case is a little different, mine worked! I thought ZD already fixed this issue with the installer script obliterating the existing /home/<username>/zdesktop folder from version 7.1.2 Build 10978 and up. After going through the superuser install script and the enduser install script my ZD started up perfectly fine and intact with all my mailboxes, all my calendar, all my email profiles, all my contacts, etc etc.

    # cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=11.10
    DISTRIB_CODENAME=oneiric
    DISTRIB_DESCRIPTION="Ubuntu 11.10"

    ZD 7.1.4 Build 11273.
    -----------
    was: ZD 7.1.2 Build 10978 on Ubuntu 11.10 32-bit
    then upgraded to: 7.1.4 Build 11273 on Ubuntu 11.10 (03/19/2012)
    then upgraded to: 7.1.4 GA Build 11299 on Ubuntu 11.10 (04/16/2012)
    Now officially migrated from ZD 7.1.4 GA Build 11299 to Thunderbird 11.0.1

  4. #4
    Join Date
    Mar 2012
    Posts
    2
    Rep Power
    3

    Default

    I had the same problem (and in fact posted about it below). I had an idea today, though I haven't tried it. I'm not sure whether the e-mails are actually all lost, or whether I just can't find where they are on my computer. When I get a chance, I'm going to do a system restore to before when I updated. I'll post whether or not it works once I get a chance to try it. If anyone else wants to try it, though, you'd be more than welcome.

Similar Threads

  1. Replies: 5
    Last Post: 05-11-2012, 02:16 PM
  2. Upgrade from 6.0.10 to 7 beta4
    By alex70 in forum Installation
    Replies: 14
    Last Post: 05-11-2012, 02:02 PM
  3. Replies: 6
    Last Post: 03-14-2011, 04:21 AM
  4. [SOLVED] New zcs 7 install : database errors founds
    By dkbk in forum Administrators
    Replies: 4
    Last Post: 03-01-2011, 05:49 AM
  5. Replies: 2
    Last Post: 02-12-2008, 10:55 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •