I work for a small Library. I am trying to setup the libraries Facebook account to the Social Tab in the Zimbra Desktop client.

Basically when I try to add an account, a new browser window opens up (it takes me to the browser from the desktop client)
and I have to sign-in to the facebook account (if I'm not already signed in) and then I have to add the app, set its options etc..

That all works. When I close the window (as it tells me to) and return to the desktop client. There is no facebook account there.
The social plugin is enabled in preferences (double checked) I checked the facebook account, it has the app installed and turned on in the apps section of settings.

Basically the Desktop client says there are no accounts added. (All I want is Facebook, not Twitter etc..)
I restarted Zimbras desktop client and even the computer after that.
Same Problem.
The Libraries Facebook account is a business page, so I tried to connect it to my personal Facebook account.
Same problem.
I uninstalled the social plug in, download the new one, installed it.
Same problem.

I then moved to the web browser version of Zimbra. I tried adding acocunts and they still wouldn't add.
But THIS time when I close the window after attempting to add an account, I see a small message appear and then fade out on the top of the web versions page
It says "Could not load Facebook account"

So that's it. Facebook says they are connected, but Zimbra can not load it.

I'm running the latest version of Zimbra (I made sure)
and I downloaded and installed the latest social zimlet

So... What's up? What could be the problem?
It seems more like a bug then a specific problem with this computer since the web version of Zimbra is effected.

Any advice would be greatly appreciated.

Thank you!