Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Can't get Zimbra Desktop (7.2.1) to Open on MAC OSX 10.8.2

  1. #11
    Join Date
    Apr 2008
    Posts
    35
    Rep Power
    7

    Default

    Well, those actually look ok. Could we please see the last 10 lines of zdesktop.log? You can obfuscate anything you might be concerned about, email addresses or whatever:

    $ tail zdesktop.log

  2. #12
    Join Date
    May 2007
    Location
    Menlo Park, CA
    Posts
    13
    Rep Power
    8

    Default

    Thom: These are the last 10 lines from a try to use ZD Desktop yesterday. To me they show a shutdown after sitting on the "Loading..." screen for so long. I can certainly go back further...

    Steven-MBPro:log steveneichler$ tail zdesktop.log
    2013-03-07 16:26:38,001 DEBUG [sync-timer-gal] [] offline - Offline GAL sync retry bypassed, no retry items
    2013-03-07 16:29:37,007 INFO [Shutdown] [] log - Shutdown hook executing
    2013-03-07 16:29:37,007 INFO [Shutdown] [] log - Graceful shutdown SelectChannelConnector@127.0.0.1:49861
    2013-03-07 16:29:37,011 INFO [Shutdown] [] log - Graceful shutdown org.mortbay.jetty.webapp.WebAppContext@19d75ee{/service,/Applications/Zimbra Desktop/jetty/webapps/service}
    2013-03-07 16:29:37,011 INFO [Shutdown] [] log - Graceful shutdown org.mortbay.jetty.webapp.WebAppContext@1db52c8{/zimbra,/Applications/Zimbra Desktop/jetty/webapps/zimbra}
    2013-03-07 16:29:37,011 INFO [Shutdown] [] log - Graceful shutdown org.mortbay.jetty.webapp.WebAppContext@11bda67{/zimlet,/Applications/Zimbra Desktop/jetty/webapps/zimlet}
    2013-03-07 16:29:39,012 INFO [Shutdown] [] log - Stopped SelectChannelConnector@127.0.0.1:0
    2013-03-07 16:29:39,271 WARN [Thread-9] [] CachedThreadPool - Sweeper thread interrupted
    2013-03-07 16:29:39,271 WARN [Thread-9] [] CachedThreadPool - Shutdown has been received by sweeper thread
    2013-03-07 16:29:39,377 INFO [Shutdown] [] log - Shutdown hook complete

  3. #13
    Join Date
    Apr 2008
    Posts
    35
    Rep Power
    7

    Default

    Okay, we want the app to be running. Please start it up, wait a minute or so, and go through these steps again:

    $ tail -20 zdesktop.out
    $ grep ERR zdesktop.log
    $ tail zdesktop.log

  4. #14
    Join Date
    May 2007
    Location
    Menlo Park, CA
    Posts
    13
    Rep Power
    8

    Default

    I did the last command 3x just to provide as much information as possible. Here you go....

    Last login: Fri Mar 8 08:48:29 on ttys000
    Steven-MBPro:~ steveneichler$ cd ~/Library/Zimbra\ Desktop/log
    Steven-MBPro:log steveneichler$ tail -20 zdesktop.out
    JETTY_CONSOLE = /Users/steveneichler/Library/Zimbra Desktop/log/zdesktop.out
    JETTY_ARGS =
    CONFIGS = /Users/steveneichler/Library/Zimbra Desktop/jetty/etc/jetty.xml
    JAVA_OPTIONS = -client -d32 -Djava.awt.headless=true -Xms128m -Xmx512m -Xss150k -XX:MinHeapFreeRatio=20 -XX:MaxHeapFreeRatio=40 -XX:NewRatio=4 -XX:TargetSurvivorRatio=70 -XX:+UseConcMarkSweepGC -DSTART='/Applications/Zimbra Desktop/jetty/etc/start.config' -Dzimbra.home='/Users/steveneichler/Library/Zimbra Desktop' -Dzimbra.config='/Users/steveneichler/Library/Zimbra Desktop/conf/localconfig.xml' -Djava.library.path='/Applications/Zimbra Desktop/jetty/../lib' -Djava.awt.headless=true -Djava.io.tmpdir='/Users/steveneichler/Library/Zimbra Desktop/data/tmp/java' -Djava.net.useSystemProxies=true -Dsun.net.inetaddr.ttl=10 -XX:HeapDumpPath='/Users/steveneichler/Library/Zimbra Desktop/heapdump/' -XX:+HeapDumpOnOutOfMemoryError -Djetty.home='/Applications/Zimbra Desktop/jetty'
    JAVA = /usr/bin/java
    Starting Jetty:
    Stale pid file removed: /Users/steveneichler/Library/Zimbra Desktop/log/zdesktop.pid
    STARTED Jetty Fri Mar 8 15:36:55 PST 2013
    Jetty running pid=28919
    0 INFO [main] log - Logging to org.slf4j.impl.Log4jLoggerAdapter(org.mortbay.log) via org.mortbay.log.Slf4jLog
    782 INFO [main] log - jetty-6.1.22.z6
    1041 INFO [main] log - No Transaction manager found - if your webapp requires one, please configure one.
    Zimbra server process is running as uid=502 euid=502 gid=502 egid=502
    2226 INFO [main] security - keystore not present
    Unable to determine platform because /Users/steveneichler/Library/Zimbra Desktop/.platform does not exist.
    Found SQLite NativeDb from Mac/i386
    SQLite library version: 3.7.5
    oldDbVersion=65 newDbVersion=65
    oldOfflineDbVersion=5 newOfflineDbVersion=5
    Unable to determine platform because /Users/steveneichler/Library/Zimbra Desktop/.platform does not exist.
    Steven-MBPro:log steveneichler$ grep ERR zdesktop.log
    Steven-MBPro:log steveneichler$ tail zdesktop.log
    2013-03-08 15:43:06,653 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - message id=179049 streamed to memory
    2013-03-08 15:43:06,670 WARN [sync-mbox-steven@eichlerdesigns.com] [mid=7;] index - Unable to index: message-id:13ba8d981layfovciac
    2013-03-08 15:43:06,681 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - initial: created message (179049): Remember to Use Your Co-Pay Card This Month
    2013-03-08 15:43:06,682 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - message id=179048 streamed to memory
    2013-03-08 15:43:06,688 WARN [sync-mbox-steven@eichlerdesigns.com] [mid=7;] index - Unable to index: dkim-signature:b=uhlbcmkx8kct5
    2013-03-08 15:43:06,691 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - initial: created message (179048): Design with Autokitchen PRO
    2013-03-08 15:43:06,692 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - message id=179095 streamed to memory
    2013-03-08 15:43:06,696 WARN [sync-mbox-steven@eichlerdesigns.com] [mid=7;] index - Unable to index: list-unsubscribe:http://list.m
    2013-03-08 15:43:06,696 WARN [sync-mbox-steven@eichlerdesigns.com] [mid=7;] index - Unable to index: x-dynectemail-msg-hash:vc56v7j
    2013-03-08 15:43:06,700 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - initial: created message (179095): OWC March Clearance/GarageSale On Now
    Steven-MBPro:log steveneichler$ tail zdesktop.log
    2013-03-08 15:43:48,643 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - ending delta sync [token 405140]
    2013-03-08 15:43:48,643 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - starting change push
    2013-03-08 15:43:48,643 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - ending change push
    2013-03-08 15:43:48,790 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - starting delta sync [token 405140]
    2013-03-08 15:43:48,949 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - message id=179189 streamed to memory
    2013-03-08 15:43:48,952 WARN [sync-mbox-steven@eichlerdesigns.com] [mid=7;] index - Unable to index: x-original-messageid:urn.corre
    2013-03-08 15:43:48,955 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - initial: created message (179189): Steven J. Eichler, will you rate your transaction at Amazon.com?
    2013-03-08 15:43:48,955 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - ending delta sync [token 405141]
    2013-03-08 15:43:48,960 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - starting change push
    2013-03-08 15:43:48,960 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - ending change push
    Steven-MBPro:log steveneichler$ tail zdesktop.log
    2013-03-08 15:43:48,643 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - ending delta sync [token 405140]
    2013-03-08 15:43:48,643 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - starting change push
    2013-03-08 15:43:48,643 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - ending change push
    2013-03-08 15:43:48,790 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - starting delta sync [token 405140]
    2013-03-08 15:43:48,949 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - message id=179189 streamed to memory
    2013-03-08 15:43:48,952 WARN [sync-mbox-steven@eichlerdesigns.com] [mid=7;] index - Unable to index: x-original-messageid:urn.corre
    2013-03-08 15:43:48,955 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - initial: created message (179189): Steven J. Eichler, will you rate your transaction at Amazon.com?
    2013-03-08 15:43:48,955 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - ending delta sync [token 405141]
    2013-03-08 15:43:48,960 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - starting change push
    2013-03-08 15:43:48,960 DEBUG [sync-mbox-steven@eichlerdesigns.com] [mid=7;] offline - ending change push
    Steven-MBPro:log steveneichler$

  5. #15
    Join Date
    Apr 2008
    Posts
    35
    Rep Power
    7

    Default

    Hmmmm, well it looks like the server is running correctly here. Typically, a problem like you describe would probably be a problem with the java server or damaged/corrupted database. However, the java server (backend) is actually running and actively downloading messages.

    A couple thoughts then:
    1. Perhaps the Prism/frontend application files were removed or damaged - have you tried just reinstalling the current version? https://www.zimbra.com/downloads/zd-downloads.html
    This shouldn't touch your data, and would just replace the existing application files.

    2. Is there a firewall or security app that might be blocking certain processes or sockets? This could cause something similar, since the frontend/Prism must communicate with the java server over a network socket. You might be able to check this a few ways:

    a. Determine the listening socket:
    # lsof | grep '^java' | grep LISTEN
    example output:
    java 7974 username 30u IPv6 0xa24dc1bc57db3215 0t0 TCP localhost:61847 (LISTEN)

    b. Identify if you have ESTABLISHED connections to the resulting port (61847 in the above example):

    # netstat -an | grep 61847
    example output:
    tcp4 0 0 127.0.0.1.61847 127.0.0.1.61889 ESTABLISHED
    tcp4 0 0 127.0.0.1.61889 127.0.0.1.61847 ESTABLISHED
    tcp4 0 0 127.0.0.1.61847 127.0.0.1.61888 ESTABLISHED
    tcp4 0 0 127.0.0.1.61888 127.0.0.1.61847 ESTABLISHED
    tcp4 0 0 127.0.0.1.61847 127.0.0.1.61887 ESTABLISHED
    tcp4 0 0 127.0.0.1.61887 127.0.0.1.61847 ESTABLISHED
    tcp4 0 0 127.0.0.1.61847 127.0.0.1.61886 ESTABLISHED
    tcp4 0 0 127.0.0.1.61886 127.0.0.1.61847 ESTABLISHED
    tcp4 0 0 127.0.0.1.61885 127.0.0.1.61847 CLOSE_WAIT
    tcp4 0 0 127.0.0.1.61884 127.0.0.1.61847 CLOSE_WAIT
    tcp4 0 0 127.0.0.1.61847 127.0.0.1.61883 ESTABLISHED
    tcp4 0 0 127.0.0.1.61883 127.0.0.1.61847 ESTABLISHED
    tcp4 0 0 127.0.0.1.61847 *.* LISTEN

    c. If you are running a firewall, check the firewall monitor/log if it is reporting any blocked connections on the above port.

    d. Check /var/log/messages for any related warnings or errors:
    # egrep -i 'java|desktop|prism' /var/log/system.log
    # egrep -i 'java|desktop|prism' /var/log/secure.log

  6. #16
    Join Date
    May 2007
    Location
    Menlo Park, CA
    Posts
    13
    Rep Power
    8

    Default

    Thanks, Thom. I will go through the steps that you suggest over the weekend and report back. On the EOL issue, you pointed me to another Forum, but this is largely a discussion of people who have no direct input from "Zimbra" or VMWare, and therein lies the rub. There is nothing official, that I or anyone, can find about the path for upgrading Zimbra Desktop or allowing 3rd Party Clients such as Outlook to work seamlessly with Zimbra Server. Outlook and Apple Mail used to be able to work seamlessly with ZCS, but no longer does. Certainly if ZD did the trick (which for me now isn't working at all), then perhaps there would be less to complain about. But with no information forthcoming from Zimbra/VMWare, the number of dissatisfied customers continues to grow and grow. Why can't Zimbra/VMWare do a better job of keeping us informed about ZD and/or allowing 3rd Party Clients to play nice with ZCS?

  7. #17
    Join Date
    Apr 2008
    Posts
    35
    Rep Power
    7

    Default

    Good, thank you.. Please be sure to run a backup before making any further changes. If this doesn't work, it may be required to either (a) roll back to your most recent backup where it was working properly, or (b) wipe ZD, reinstall, and re-sync all your data.

  8. #18
    Join Date
    May 2007
    Location
    Menlo Park, CA
    Posts
    13
    Rep Power
    8

    Default

    Hi Thom: Per your last email, I decided to dispense with the time consuming forensics and skip write to the clean re-install. After all the data is on the ZCS so it wasn't like I was going to lose anything other than my accounts set-up and other configuration that I may have customized. That seems to have worked, for now. I did get the Script error several times while the ZD synched-up to ZCS, but the application at least opens again. In the meantime, though it is not the all-in-one solution, I revisited both Outlook & Apple Mail, for mail handling, and Apple Calendar as separate applications and found them to be very useful, and in several respects a better user interface than ZD, Frankly, this is not that different than how it is handled on i devices. There appears to be more and more conflicts with ZD and Mac OS Mountain Lion noted on the internet. Therefore, until a better ZD or better solution arrives, Apple Mail & Calendar may just be the best solution for this Mac User. If this becomes true, it may render ZCS not as useful as it once was. As a loyal Zimbra user (through their three (3) owners), this would be sad, but then I have already seen many applications become stars and then fail all too many times. I really do appreciate your efforts....it's the best I have seen from the Zimbra team in quite some time! Regards, Steven

  9. #19
    Join Date
    Apr 2008
    Posts
    35
    Rep Power
    7

    Default

    Very glad to hear that this is now working, though sorry to see that it did require a full reload. Clearly, that shouldn't happen under normal circumstances. Please keep us updated if any future issues. Best wishes ~

Similar Threads

  1. Zimbra Desktop: Always open in the browser
    By Vivek456 in forum General Questions
    Replies: 2
    Last Post: 10-31-2012, 12:40 PM
  2. Zimbra Desktop 7.1.4 won't open on my Mac
    By Kirkus in forum General Questions
    Replies: 1
    Last Post: 06-11-2012, 05:48 PM
  3. Zimbra Desktop 7.1.4 won't open on my Mac
    By Kirkus in forum Installation Help
    Replies: 0
    Last Post: 06-07-2012, 01:50 PM
  4. Unable to open my Zimbra Desktop
    By Yann in forum Error Reports
    Replies: 0
    Last Post: 04-18-2011, 07:29 PM
  5. Zimbra Desktop not open in XP SP3
    By aelbaz in forum Error Reports
    Replies: 1
    Last Post: 03-15-2011, 01:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •