Results 1 to 4 of 4

Thread: Please finish Yahoo! OAuth process at account setup page.

  1. #1
    Join Date
    Apr 2009
    Posts
    15
    Rep Power
    6

    Default Please finish Yahoo! OAuth process at account setup page.

    Just upgraded from 7.2.1 to 7.2.2 and got the following;
    "Please finish Yahoo! OAuth process at account setup page."
    I go to Setup and my Yahoo mail account has "Please finish Yahoo! OAuth process at account setup page."
    I click on Edit and there is no place to enter the Yahoo OAuth code.
    I click on Validate and Save and it says Processing then Account Settings Updated.
    I launch Desktop and the Red X is still there


    What do I do now??

  2. #2
    Join Date
    Apr 2009
    Posts
    15
    Rep Power
    6

    Default

    If I click on the red X, I get the following;
    Please finish Yahoo! OAuth process at account setup page.

    Debug message: must grant access to yahoo contact API

    Exception:

    com.zimbra.cs.mailbox.OfflineServiceException: must grant access to yahoo contact API
    ExceptionId:btpool0-34:1364735247696:6ee818627366855f
    Codeffline.YCONTACT_NEED_VERIFY
    at com.zimbra.cs.mailbox.OfflineServiceException.YCON TACT_NEED_VERIFY(OfflineServiceException.java:100)
    at com.zimbra.cs.offline.ab.yc.YContactImport.importD ata(YContactImport.java:67)
    at com.zimbra.cs.offline.OfflineImport.importData(Off lineImport.java:100)
    at com.zimbra.cs.offline.YMailImport.importData(YMail Import.java:60)
    at com.zimbra.cs.datasource.DataSourceManager.importD ata(DataSourceManager.java:317)
    at com.zimbra.cs.datasource.DataSourceManager.importD ata(DataSourceManager.java:277)
    at com.zimbra.cs.mailbox.DataSourceMailbox.syncAllLoc alDataSources(DataSourceMailbox.java:439)
    at com.zimbra.cs.mailbox.DataSourceMailbox.sync(DataS ourceMailbox.java:478)
    at com.zimbra.cs.service.offline.OfflineSync.handle(O fflineSync.java:55)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:412)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:287)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:158)
    at com.zimbra.soap.SoapServlet.doWork(SoapServlet.jav a:303)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:217)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:725)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:206)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:814)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:511)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:390)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:218)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:182)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:765)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:422)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:230)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:230)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.Server.handle(Server.java:326)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:585)
    at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:988)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:756)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:218)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:415)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:429)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:451)

    If issue persists please post description and debug information here.

  3. #3
    Join Date
    Apr 2009
    Posts
    15
    Rep Power
    6

    Default

    Never mind!
    Fixed it myself.
    Deleted my Yahoo account from Account Setup in ZD and then set it up again.
    This time the OAuth Verify box appeared, took me to Yahoo and gave me a Verify code to enter into ZD.
    The synch is painful (over 2 hours with a slow satellite connection), but, eventually the account synched and the red X went away.

  4. #4
    Join Date
    May 2011
    Posts
    72
    Rep Power
    4

    Default

    you have updated to 7.2.2. and no issue? which os..

Similar Threads

  1. Setup Yahoo business email account
    By muscles614 in forum General Questions
    Replies: 9
    Last Post: 11-20-2012, 03:10 PM
  2. Replies: 4
    Last Post: 11-09-2011, 08:03 AM
  3. Replies: 1
    Last Post: 11-09-2011, 12:10 AM
  4. process for custom setup of posfix
    By drewsta in forum Installation
    Replies: 3
    Last Post: 05-10-2008, 09:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •