Results 1 to 3 of 3

Thread: install error on ubuntu hardy heron alpha 5

  1. #1
    Join Date
    Apr 2007
    Posts
    17
    Rep Power
    8

    Default install error on ubuntu hardy heron alpha 5

    jens@jens-laptop:~$ cd Desktop/
    jens@jens-laptop:~/Desktop$ ./zdesktop_beta_build_1083_linux_i686.sh
    Unpacking JRE ...
    Preparing JRE ...
    Starting Installer ...
    Locking assertion failure. Backtrace:
    #0 /usr/lib/libxcb-xlib.so.0 [0xb75f5767]
    #1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb75f58b1]
    #2 /usr/lib/libX11.so.6(_XReply+0xfd) [0xaa14a29d]
    #3 /home/jens/Desktop/zdesktop_beta_build_1083_linux_i686.sh.5960.dir/jre/lib/i386/xawt/libmawt.so [0xaa244d3e]
    #4 /home/jens/Desktop/zdesktop_beta_build_1083_linux_i686.sh.5960.dir/jre/lib/i386/xawt/libmawt.so [0xaa22ed47]
    #5 /home/jens/Desktop/zdesktop_beta_build_1083_linux_i686.sh.5960.dir/jre/lib/i386/xawt/libmawt.so [0xaa22eec3]
    #6 /home/jens/Desktop/zdesktop_beta_build_1083_linux_i686.sh.5960.dir/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_ini tDisplay+0x26) [0xaa22f106]
    #7 [0xb2a3bc2a]
    #8 [0xb2a35b3b]
    #9 [0xb2a35b3b]
    #10 [0xb2a33217]
    #11 /home/jens/Desktop/zdesktop_beta_build_1083_linux_i686.sh.5960.dir/jre/lib/i386/client/libjvm.so [0xb77add8c]
    #12 /home/jens/Desktop/zdesktop_beta_build_1083_linux_i686.sh.5960.dir/jre/lib/i386/client/libjvm.so [0xb78c1fd8]
    #13 /home/jens/Desktop/zdesktop_beta_build_1083_linux_i686.sh.5960.dir/jre/lib/i386/client/libjvm.so [0xb77adbbf]
    #14 /home/jens/Desktop/zdesktop_beta_build_1083_linux_i686.sh.5960.dir/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x32d) [0xb780b34d]
    #15 /home/jens/Desktop/zdesktop_beta_build_1083_linux_i686.sh.5960.dir/jre/lib/i386/libjava.so(Java_java_security_AccessController_doP rivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xb75ae2cd]
    #16 [0xb2a3b4db]
    #17 [0xb2a35a64]
    #18 [0xb2a33217]
    #19 /home/jens/Desktop/zdesktop_beta_build_1083_linux_i686.sh.5960.dir/jre/lib/i386/client/libjvm.so [0xb77add8c]
    java: xcb_xlib.c:82: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
    Aborted (core dumped)
    jens@jens-laptop:~/Desktop$

  2. #2
    Join Date
    Feb 2008
    Posts
    4
    Rep Power
    7

    Default

    There is a fix for this but when I tried to implement it the install file becomes corrupted.

    Here is a link to the bug:

    https://bugs.launchpad.net/xorg-server/+bug/185311

    I had the same problem with the Spark IM client but I was able to fix the line of offending code (not sure who is offending who). Most likely the easiest way to fix the problem with Zimbra is to change your local JRE located in /usr/lib/jvm/java-6-sun.

    Do the following:

    Code:
    sudo sed -i s/XINERAMA/FAKEEXTN/g /usr/lib/jvm/java-6-sun/jre/lib/i386/xawt/libmawt.so
    To fix the Zimbra installation you would need to uncomment the line at the beginning of the install script and put your jre installation after it:

    Code:
    INSTALL4J_JAVA_HOME_OVERRIDE=/usr/lib/jvm/java-6-sun
    The problem I ran into is that the script thinks it is corrupted if you change anything. If anyone could give insight into this issue I would greatly appreciate it.

    --
    Chris Christensen
    Geek Department Blog
    http://www.geekdept.com

  3. #3
    Join Date
    Feb 2008
    Posts
    4
    Rep Power
    7

    Default

    I was able to change the line in the code using TextPad which is a windows program that I ran through Crossover.

    Unfortunately it didn't work.

    It looks like it didn't override the jre that comes with the package.

Similar Threads

  1. I got Ubuntu and Zimbra working
    By pacsteel in forum Installation
    Replies: 73
    Last Post: 06-23-2008, 11:41 AM
  2. evolution connector for ubuntu hardy heron .deb
    By spirit in forum Evolution Connector
    Replies: 4
    Last Post: 06-23-2008, 11:07 AM
  3. Unable to install on Ubuntu 7.04 64 bit
    By geekneck in forum Installation
    Replies: 5
    Last Post: 07-16-2007, 07:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •