i have a desktop and a laptop, both with Ubuntu 8.04, the desktop is _x86_64 and the laptop is 32 bits.

the error were very similar. During the installation i get:

$ ./zdesktop_0_90_build_1251_linux_i686.sh 2>&1 | tee install.out
Unpacking JRE ...
Preparing JRE ...
Starting Installer ...
Locking assertion failure. Backtrace:
#0 /usr/lib32/libxcb-xlib.so.0 [0xf7f44767]
#1 /usr/lib32/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xf7f448b1]
#2 /usr/lib32/libX11.so.6(_XReply+0xfd) [0xae1ee1bd]
#3 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/xawt/libmawt.so [0xaef6edce]
#4 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/xawt/libmawt.so [0xaef58d77]
#5 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/xawt/libmawt.so [0xaef58ef3]
#6 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_ini tDisplay+0x26) [0xaef59136]
#7 [0xf17e1008]
#8 [0xf17dab6b]
#9 [0xf17dab6b]
#10 [0xf17d8236]
#11 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/server/libjvm.so [0xf765eeac]
#12 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/server/libjvm.so [0xf782eaa8]
#13 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/server/libjvm.so [0xf765ecdf]
#14 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/server/libjvm.so(JVM_DoPrivileged+0x32d) [0xf76bc7ed]
#15 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/libjava.so(Java_java_security_AccessController_doP rivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xf73b830d]
#16 [0xf17e0898]
#17 [0xf17daa94]
#18 [0xf17d8236]
#19 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/server/libjvm.so [0xf765eeac]
Locking assertion failure. Backtrace:
#0 /usr/lib32/libxcb-xlib.so.0 [0xf7f44767]
#1 /usr/lib32/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xf7f4481e]
#2 /usr/lib32/libX11.so.6 [0xae1ed518]
#3 /usr/lib32/libX11.so.6(XGetVisualInfo+0x26) [0xae1e40a6]
#4 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/xawt/libmawt.so [0xaef580b9]
#5 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/xawt/libmawt.so [0xaef58303]
#6 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/xawt/libmawt.so [0xaef58fa1]
#7 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_ini tDisplay+0x26) [0xaef59136]
#8 [0xf17e1008]
#9 [0xf17dab6b]
#10 [0xf17dab6b]
#11 [0xf17d8236]
#12 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/server/libjvm.so [0xf765eeac]
#13 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/server/libjvm.so [0xf782eaa8]
#14 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/server/libjvm.so [0xf765ecdf]
#15 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/server/libjvm.so(JVM_DoPrivileged+0x32d) [0xf76bc7ed]
#16 /home/janpf/src/zimbra/zdesktop_0_90_build_1251_linux_i686.sh.27590.dir/jre/lib/i386/libjava.so(Java_java_security_AccessController_doP rivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xf73b830d]
#17 [0xf17e0898]
#18 [0xf17daa94]
#19 [0xf17d8236]
/usr/share/themes/Clearlooks/gtk-2.0/gtkrc:41: error: lexical error or unexpected token, expected valid token
ij version 10.3
ij> CONNECT 'jdbc:derby:/home/janpf/lib/zimbra/zdesktop/./derby;create=true';
ij> RUN '/home/janpf/lib/zimbra/zdesktop/./db/db.sql';
ij> --

... (SQL COMMANDS HERE) ...

by the end of the installation i get a dialog box with the message:

"Failed to inject zimlets. Some features may be missing"

the desktop icon is installed ok, but when i run it, it loops over 3 red icons on a white background ... and after a min or so it displays another dialog window saying:

"Couldn't start Yahoo! Zimbra Desktop server, giving up"

any suggestions,

thanks!

ps.: i saw some similar postings, but they were not exactly the same ( -- there was a similar error related to an older version of Ubuntu, without a solution though), so i decided to post again.