Results 1 to 5 of 5

Thread: IMAP Courier SSL routines:SSL3_GET_RECORD:wrong version number Error

  1. #1
    Join Date
    Sep 2008
    Posts
    1
    Rep Power
    7

    Default IMAP Courier SSL routines:SSL3_GET_RECORD:wrong version number Error

    Hi,
    On the first set up page of Zimbra Desktop I am trying to connect to my own IMAP account on our server which uses Courier MTA (Courier-IMAP 4.2.1/i386-sun-solaris2).

    I receive an error from Zimbra Desktop:

    Service error. Please check your server settings; verify your email address, password or IMAP access (if required).

    When I check the courier log on the server where the email is stored I can see the error message:

    couriertls: accept: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

    Looks like our mail server is not compatable in some way with Zimbra desktop software. I don't use SSL for any of the connections and just connect via standard ports 143 and 25.

    The account works fine with Mozilla Thunderbird and I am positive I have entered the setting corretly.

    Anyone have any ideas?

    Many thanks.

  2. #2
    Join Date
    Aug 2008
    Posts
    1
    Rep Power
    7

    Default couriertls: accept: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

    I'm having this same issue..... I'm migrating mail servers and moving from Cpanel on CentOS 4.5 to RHEL5 and I can connect fine on the old cpanel with OpenSSL 0.9.7a Feb 19 2003 but get this same error on RedHat and OpenSSL 0.9.8b 04 May 2006.

    Any Zimbra Developers have ideas?

  3. #3
    Join Date
    Dec 2008
    Posts
    2
    Rep Power
    7

    Default

    Same problem here. Anyone?

  4. #4
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Probably because your server doesn't support SSL3, which is the SSL version zdesktop requires.

  5. #5
    Join Date
    Dec 2008
    Posts
    2
    Rep Power
    7

    Default

    Thank you for your reply.

    Changing Courier's setting "TLS_STARTTLS_PROTOCOL" from imapd-ssl -configuration file to "TLS_STARTTLS_PROTOCOL=SSL3" seemed to fix this problem for me.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  2. Problems - post 5.0.4 upgrade
    By bradb21 in forum Administrators
    Replies: 12
    Last Post: 04-06-2008, 09:40 PM
  3. Replies: 14
    Last Post: 12-22-2005, 04:59 PM
  4. Building native libraries on MacOS X
    By ajmas in forum Developers
    Replies: 3
    Last Post: 10-15-2005, 12:00 AM
  5. system failure: getDirectContext
    By avisser in forum Installation
    Replies: 3
    Last Post: 10-12-2005, 06:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •