In the past, I was able to install the ZD backend, and the user account in my /home directory. For Beta 4, this option does not seem to be available because the installer requires the user space to not be a parent directory of the backend. Even if my

So I installed ZD client to opt/zimbra/zdesktop as root, and installed the user account (as a normal user) in my /home directory.

When I execute ZD, the ZD screen displays with the spinning circle, but never gets past that.

I have restarted Fedora 13, and still no dice.

I tried installing to /opt/zimbra/zdesktop as a normal user, but the same problem occurs.

Using the shortcut string, and executing it from the command line, I get the following output:

[jmorgan@dhcp-1-169 ~]$ "/home/jmorgan/zimbra/zdesktop/linux/prism/zdclient" -webapp "/home/jmorgan/zdesktop/zdesktop.webapp" -override "/home/jmorgan/zdesktop/zdesktop.webapp/override.ini" -profile "/home/jmorgan/zdesktop/profile"
*** UpdateService: canUpdate? testing /home/jmorgan/zimbra/zdesktop/linux/prism/update.test
*** UpdateService: canUpdate? testing /home/jmorgan/zimbra/zdesktop/linux/prism/updates/0/update.test
*** UpdateService: can update
*** General: Reading Status File: /home/jmorgan/zimbra/zdesktop/linux/prism/updates/0/update.status
*** UpdateService: _postUpdateProcessing: No Status, No Update
*** UpdateManager: _loadXMLFileIntoArray: XML File does not exist
JETTY_HOME = /home/jmorgan/zimbra/zdesktop/jetty
JETTY_RUN = /home/jmorgan/zdesktop/log
JETTY_PID = /home/jmorgan/zdesktop/log/zdesktop.pid
JETTY_CONSOLE = /home/jmorgan/zdesktop/log/zdesktop.out
JETTY_ARGS =
CONFIGS = /home/jmorgan/zdesktop/jetty/etc/jetty.xml
JAVA_OPTIONS = -client -d32 -Djava.awt.headless=true -Xms32m -Xmx100m -Xss150k -XX:MinHeapFreeRatio=20 -XX:MaxHeapFreeRatio=40 -XX:NewRatio=4 -XX:TargetSurvivorRatio=70 -XX:+UseConcMarkSweepGC -DSTART='/home/jmorgan/zimbra/zdesktop/jetty/etc/start.config' -Dzimbra.home='/home/jmorgan/zdesktop' -Dzimbra.config='/home/jmorgan/zdesktop/conf/localconfig.xml' -Djava.library.path='/home/jmorgan/zimbra/zdesktop/jetty/../lib' -Djava.awt.headless=true -Djava.io.tmpdir='/home/jmorgan/zdesktop/data/tmp/java' -Djava.net.useSystemProxies=true -Dsun.net.inetaddr.ttl=10 -Djetty.home='/home/jmorgan/zimbra/zdesktop/jetty'
JAVA = /home/jmorgan/zimbra/zdesktop/linux/jre/bin/java
Starting Jetty:
nohup: redirecting stderr to stdout
Jetty running pid=4127


^^ this is where it stops

I still had a tarball of Beta2, so I chmod 777 the install.pl script, and began installation as a normal user. I attempted to install to the default /opt directory. The script displayed a permissions error.

------------------------------
Choose the folder where you would like to install Zimbra Desktop's application files [/opt/zimbra/zdesktop]:


Installing application files...mkdir: cannot create directory `/opt/zimbra': Permission denied
------------------------------

The Beta4 script *DID NOT* display an error when attempting to install as a normal user.

I think there might be a bug in the Beta4 install script? When I installed Beta2 to /opt as root, the program correctly started.