Results 1 to 10 of 10

Thread: /opt/zimbra/zdesktop/linux/prism/zdclient: No such file or directory

Hybrid View

  1. #1
    Join Date
    Sep 2009
    Posts
    26
    Rep Power
    6

    Default /opt/zimbra/zdesktop/linux/prism/zdclient: No such file or directory

    I did install Zimbra Desktop 2.0.1 on a fresh installation of Ubuntu 10.10 amd64.

    When I try to start after an successful installation I get the following error:
    Code:
    /opt/zimbra/zdesktop/linux/prism/zdclient: No such file or directory
    Installation procedure:
    Code:
    sudo tar xvzf zdesktop_2_0_1_b10659_linux_i686.tgz
    cd zdesktop_2_0_1_b10659_linux_i686/
    sudo perl install.pl
    /opt/zimbra/zdesktop/linux/user-install.pl
    The zdclient-file does exist:
    Code:
    drwxrwxr-x  8 503 503  4096 2010-12-10 17:37 .
    drwxrwxr-x  4 503 503  4096 2010-12-10 17:37 ..
    -rw-rw-r--  1 503 503   164 2010-11-01 12:33 application.ini
    drwxrwxr-x 23 503 503  4096 2010-12-10 17:37 chrome
    drwxrwxr-x  2 503 503  4096 2010-12-10 17:37 components
    drwxrwxr-x  3 503 503  4096 2010-12-10 17:37 defaults
    drwxrwxr-x  2 503 503  4096 2010-12-10 17:37 extensions
    -rw-rw-r--  1 503 503  9765 2010-07-07 18:17 fix-linux-stack.pl
    drwxrwxr-x  2 503 503  4096 2010-12-10 17:37 modules
    drwxrwxr-x 11 503 503  4096 2010-12-10 17:37 xulrunner
    -rwxrwxr-x  1 503 503 28896 2010-11-01 13:59 zdclient
    The beta 7 has the same issues.

    I already installed Zimbra Desktop 2 numerous Linux systems never running into any error. Even on an 32bit Ubuntu 10.10 it appears to run fine. 10.04 LTS amd64, also no errors.

    Anyone got an idea?

    Cheers,
    Mike

  2. #2
    Join Date
    Oct 2006
    Location
    UK
    Posts
    75
    Rep Power
    9

    Default

    I've just found the same problem.
    I just build my machine using Linux Mint 10 from a DVD and everything worked, until I spotted I was using the 32bit system. So I started again using the 64bit system, only to find that Zimbra reports this error.
    I will check and add to Bugzilla if not already there.

  3. #3
    Join Date
    Sep 2009
    Posts
    26
    Rep Power
    6

    Default

    Good to know I am not the only one.
    Have you found anything at Bugzilla?

  4. #4
    Join Date
    Oct 2006
    Location
    UK
    Posts
    75
    Rep Power
    9

    Default

    Not found anything on bugzilla, but after installing lots of system updates, my error messages changed to reporting a sound library problem. This then lead me to http://www.zimbra.com/forums/install...nd-so-2-a.html and that lead me to:

    apt-get install ia32-libs

    This has (almost) solved it all, as Zimbra Desktop 7 now works for me. I say almost as I'm missing some animations, and get lots of strange errors reported in the console.

    Tomorrow, when I'm back in work, and remembered my Bugzilla password, I will report what I have found.

    Hope this helps.
    -Si-

  5. #5
    Join Date
    Sep 2009
    Posts
    26
    Rep Power
    6

    Default

    Quote Originally Posted by Cringer View Post
    apt-get install ia32-libs
    I still don't get why, but that solved the problems for ZD 2.0.1.
    A pity that ZD will not give back a better error message.

    Thanks for your help/hint.

  6. #6
    Join Date
    Apr 2011
    Posts
    117
    Rep Power
    4

    Default

    me i got these errors after creating a user profile
    Code:
    Installing user data files...done
    Initializing user data...done
    Creating desktop icon...done
    mv: cannot stat `/home/malayo/zdesktop.tmp/index/*': No such file or directory
    mv: cannot stat `/home/malayo/zdesktop.tmp/store/*': No such file or directory
    mv: cannot stat `/home/malayo/zdesktop.tmp/sqlite/*': No such file or directory
    mv: cannot stat `/home/malayo/zdesktop.tmp/log/*': No such file or directory
    mv: cannot stat `/home/malayo/zdesktop.tmp/zimlets-deployed/*': No such file or directory
    Zimbra Desktop has been installed successfully for user malayo.
    
    You can start Zimbra Desktop by double-clicking the desktop icon or by running the following command:
    "/opt/zimbra/zdesktop/linux/prism/zdclient" -webapp "/home/malayo/zdesktop/zdesktop.webapp" -override "/home/malayo/zdesktop/zdesktop.webapp/override.ini" -profile "/home/malayo/zdesktop/profile"
    
    Press "Enter" to launch Zimbra Desktop; Press "Ctrl-c" to exit: 
    malayo@ctrl:~$ Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    
    (zdclient:8195): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
    LoadPlugin: failed to initialize shared library libXt.so [libXt.so: cannot open shared object file: No such file or directory]
    LoadPlugin: failed to initialize shared library libXext.so [libXext.so: cannot open shared object file: No such file or directory]
    LoadPlugin: failed to initialize shared library /usr/lib/flashplugin-nonfree/libflashplayer.so [/usr/lib/flashplugin-nonfree/libflashplayer.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-cone-plugin.so [/usr/lib/mozilla/plugins/libtotem-cone-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-gmp-plugin.so [/usr/lib/mozilla/plugins/libtotem-gmp-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-mully-plugin.so [/usr/lib/mozilla/plugins/libtotem-mully-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so [/usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so [/usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so [/usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /opt/google/talkplugin/libnpgoogletalk64.so [/opt/google/talkplugin/libnpgoogletalk64.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /opt/google/talkplugin/libnpgtpo3dautoplugin.so [/opt/google/talkplugin/libnpgtpo3dautoplugin.so: wrong ELF class: ELFCLASS64]
    /opt/zimbra/zdesktop/linux/prism/zdclient: symbol lookup error: /usr/lib32/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: undefined symbol: g_malloc_n

  7. #7
    Join Date
    Jul 2012
    Posts
    1
    Rep Power
    3

    Default

    I'm on Ubuntu Desktop 12.04 git 64 bit. And having the same problem:

    /opt/zimbra/zdesktop/linux/prism/zdclient: No such file or directory

    After doing a "apt-get install ia32-libs", ZD works but I'm still getting the following errors:

    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

    (zdclient:4628): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

    (zdclient:4628): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

    (zdclient:4628): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

    (zdclient:4628): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

    (zdclient:4628): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-gmp-plugin.so [/usr/lib/mozilla/plugins/libtotem-gmp-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so [/usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-cone-plugin.so [/usr/lib/mozilla/plugins/libtotem-cone-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-mully-plugin.so [/usr/lib/mozilla/plugins/libtotem-mully-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/flashplugin-installer/libflashplayer.so [/usr/lib/flashplugin-installer/libflashplayer.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so [/usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so: wrong ELF class: ELFCLASS64]
    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

    (zdclient:4628): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
    Anyone with any suggestions on how to fix this? Is there anything I can do to improve the ubuntu integration? I would like to receive alerts and use it as the default mail client.

    Thanks!
    -Rakon

  8. #8
    Join Date
    Sep 2009
    Posts
    26
    Rep Power
    6

    Default

    Quote Originally Posted by rakon View Post
    I'm on Ubuntu Desktop 12.04 git 64 bit. And having the same problem:
    After doing a "apt-get install ia32-libs", ZD works but I'm still getting the following errors:
    Anyone with any suggestions on how to fix this? Is there anything I can do to improve the ubuntu integration? I would like to receive alerts and use it as the default mail client.

    Thanks!
    -Rakon
    Not sure whether this helps - I recently tried ZDesktop on Xubuntu 12.04 x64. Worked out of the box...

  9. #9
    Join Date
    Jun 2012
    Posts
    1
    Rep Power
    3

    Default ZD-desktop 7-1-4 on mint12 (ubuntu)

    Quote Originally Posted by malayo View Post
    You can start Zimbra Desktop by double-clicking the desktop icon or by running the following command:
    "/opt/zimbra/zdesktop/linux/prism/zdclient" -webapp "/home/malayo/zdesktop/zdesktop.webapp" -override "/home/malayo/zdesktop/zdesktop.webapp/override.ini" -profile "/home/malayo/zdesktop/profile"
    Hi there,
    Zimbra-Desktop gives me headache too while installing it on mint12 which is built on Ubuntu.
    After installing ia32-libs and reinstallation of ZD 7.1.4 I got the ZD-icon on the desktop and then: The very same error messge as malayo reported.
    Trying to manually start the program brings the error:
    Code:
    /opt/zimbra/zdesktop/linux/prism/zdclient: Keine Berechtigung
    = (in German): no permission to do this - no matter whether I'm logged in as user or as root.
    Any suggestions?

    Thanks a lot for some help!

  10. #10
    Join Date
    Jun 2013
    Posts
    4
    Rep Power
    2

    Default

    Thank you Cringer... that did the trick. I have Zimbra 7.2 installed on Mint 15. Installing the 32 bit libraries fixed the issue.

Similar Threads

  1. speed up the net
    By mcesari in forum Administrators
    Replies: 10
    Last Post: 04-25-2008, 11:24 AM
  2. centos 5 zimbra 4.5.6 no statistics
    By rutman286 in forum Installation
    Replies: 9
    Last Post: 08-14-2007, 09:30 AM
  3. Replies: 5
    Last Post: 03-01-2007, 02:20 AM
  4. Traslation SVN tree status
    By meikka in forum I18N/L10N - Translations
    Replies: 7
    Last Post: 02-13-2007, 10:13 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •