Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: Installation Problem

  1. #1
    Join Date
    Apr 2007
    Posts
    8
    Rep Power
    8

    Default Installation Problem

    I cannot install my Zimbra Desktop in my PC, The Zimbra Desktop Core Service is not initializing.

    And at my terminal window displays:

    log4j:WARN No appenders could be found for logger (org.apache.commons.httpclient.HttpClient).
    log4j:WARN Please initialize the log4j system properly.
    I attached a screenshot of my installation

    Thank you for your notice
    ^__^
    Attached Images Attached Images

  2. #2
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Not initializing can be due to many reasons. The warnings in the log can be disregarded. Are you on Windows, Mac or Linux? Thanks!

  3. #3
    Join Date
    Apr 2007
    Posts
    8
    Rep Power
    8

    Default

    in Linux, but I also tried it in windows and MAC, the same problem happens

  4. #4
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    On either Mac or Linux, when the java process is hanging, you can get a stack trace dump by sending a SIGQUIT using kill like this:

    kill -3 <pid>

    where <pid> is the process id of the java process.

    The stack trace is dumped into <install>/log/zdesktop.out. If you can manage to generate the trace, please post it here. Thanks!

  5. #5
    Join Date
    Apr 2007
    Posts
    8
    Rep Power
    8

    Default

    sori jjzhuang, but i'm a bit confused, i didn't know which process i should kill.

    I included a printscreen of my processes. Which of those should I kill?
    Attached Images Attached Images

  6. #6
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    I don't see the process running. Do you see anything in your zdesktop.out or zdesktop.err log files? Thanks!

  7. #7
    Join Date
    Apr 2007
    Posts
    8
    Rep Power
    8

    Default

    I saw the zdesktop.err file from /root/zimbra/zdesktop/log/ is this the right file?

  8. #8
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Yup. Does it have any content?

  9. #9
    Join Date
    Apr 2007
    Posts
    8
    Rep Power
    8

    Default

    yes, here's the content:
    4 [main] INFO org.mortbay.log - Logging to org.slf4j.impl.SimpleLogger(org.mortbay.log) via org.mortbay.log.Slf4jLog
    1485 [main] INFO org.mortbay.log - Started SelectChannelConnector @ localhost:7633
    3292 [main] INFO org.mortbay.log - Started SslSocketConnector @ localhost:7634
    3292 [main] INFO org.mortbay.log - jetty-6.1.2rc1
    4859 [main] INFO org.mortbay.log - No Transaction manager found - if your webapp requires one, please configure one.
    log4j:WARN No appenders could be found for logger (zimbra.misc).
    log4j:WARN Please initialize the log4j system properly.
    Fatal error: terminating: Failed to loadLibrary(zimbra-native)
    java.lang.UnsatisfiedLinkError: /root/zimbra/zdesktop/lib/libzimbra-native.so: Can't load IA 32-bit .so on a IA 32-bit platform
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(Unknown Source)
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)
    at java.lang.System.loadLibrary(Unknown Source)
    at com.zimbra.znative.Util.loadLibrary(Util.java:48)
    at com.zimbra.znative.Util.<clinit>(Util.java:64)
    at com.zimbra.znative.Process.geteuid(Process.java:41 )
    at com.zimbra.cs.servlet.PrivilegedServlet.init(Privi legedServlet.java:138)
    at javax.servlet.GenericServlet.init(GenericServlet.j ava:241)
    at org.mortbay.jetty.servlet.ServletHolder.initServle t(ServletHolder.java:449)
    at org.mortbay.jetty.servlet.ServletHolder.doStart(Se rvletHolder.java:259)
    at org.mortbay.component.AbstractLifeCycle.start(Abst ractLifeCycle.java:40)
    at org.mortbay.jetty.servlet.ServletHandler.initializ e(ServletHandler.java:593)
    at org.mortbay.jetty.servlet.Context.startContext(Con text.java:139)
    at org.mortbay.jetty.webapp.WebAppContext.startContex t(WebAppContext.java:1174)
    at org.mortbay.jetty.handler.ContextHandler.doStart(C ontextHandler.java:503)
    at org.mortbay.jetty.webapp.WebAppContext.doStart(Web AppContext.java:444)
    at org.mortbay.component.AbstractLifeCycle.start(Abst ractLifeCycle.java:40)
    at org.mortbay.jetty.handler.HandlerCollection.doStar t(HandlerCollection.java:147)
    at org.mortbay.jetty.handler.ContextHandlerCollection .doStart(ContextHandlerCollection.java:141)
    at org.mortbay.component.AbstractLifeCycle.start(Abst ractLifeCycle.java:40)
    at org.mortbay.jetty.handler.HandlerCollection.doStar t(HandlerCollection.java:147)
    at org.mortbay.component.AbstractLifeCycle.start(Abst ractLifeCycle.java:40)
    at org.mortbay.jetty.handler.HandlerWrapper.doStart(H andlerWrapper.java:117)
    at org.mortbay.jetty.Server.doStart(Server.java:210)
    at org.mortbay.component.AbstractLifeCycle.start(Abst ractLifeCycle.java:40)
    at org.mortbay.xml.XmlConfiguration.main(XmlConfigura tion.java:929)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknow n Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.mortbay.start.Main.invokeMain(Main.java:183)
    at org.mortbay.start.Main.start(Main.java:497)
    at org.mortbay.start.Main.main(Main.java:115)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknow n Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)
    at com.install4j.runtime.Launcher.main(Unknown Source)

  10. #10
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    I see. What kind of Linux and hardware are you using? Is it 64bit? It looks like it's not plain 32bit intel which is what we support. Thanks!

Similar Threads

  1. INSTALLATION PROBLEM ON Centos 4.3 x_86-64Bit.
    By jawad@cogilent.com in forum Installation
    Replies: 11
    Last Post: 07-09-2007, 09:09 AM
  2. Problem with Ubuntu installation
    By Max Ma in forum Installation
    Replies: 3
    Last Post: 04-13-2007, 11:25 AM
  3. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 09:01 PM
  4. Installation problem
    By charlie in forum Administrators
    Replies: 1
    Last Post: 10-14-2005, 09:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •