Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: still getting error on Mac OS X after installation

  1. #11
    Join Date
    Nov 2005
    Location
    proxima centaury
    Posts
    33
    Rep Power
    9

    Unhappy JAVA is definitly getting me mad on OsX…

    all in the title…

    I tried, tried, tried and gave up.
    THE ONLY WAY I GET THIS TO WORK IS TO change the CurrentJDK symlink.

    Doing this-> the symlinks in /usr/bin automaticaly points to 1.5.0/bin/java, etc…

    If only exporting in /etc/profile or in .bashrc / .bash_profile to set JAVA 1.5, then the symlinks in /usr/bin still points to 1.4.2, and then zimbra doesn't like this at all.

    I really tried "quite" everything… that would much to long to tell here but believe me, the only way is to change the symlink of CurrentJDK.

    Anyone, who as succeeded with NO EDITING this symlink just please let me (us) know !
    User nigelkersten here suggested some stuff and I tried it with no success.
    I've Private message him to know if he got success and hope he'll respond.

    Now if you still don't really believe me:
    I've got 3 installs:
    1 with CurrentJDK hacked (aka 1.5.0)
    2 with CurrentJDK as default (aka 1.4.2)

    guess wich one just works fine ? the one with the CurrentJDK pointing to 1.5.0.

    So anyone that got this to work on OSx with no tricking CurrentJDK, just post here …

    Anyway, I stiil workin on it, to get it work with no CurrentJDK Symlink Hack.

    Waiting to learn for anyone…
    ;-)
    running Mac Os X

  2. #12
    Join Date
    Nov 2005
    Location
    proxima centaury
    Posts
    33
    Rep Power
    9

    Default use another NIC card… maybe a MAC adress mess here…

    in case it helps 'Playerson' and others.
    I had the same
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException zimbra.mkk-hamburg.de:389)
    and it just disapeared by using another NIC card.

    I just quote myself from here:
    http://www.zimbra.com/forums/showthread.php?t=1023

    So I did try to make a New fresh Install, on a virgin partition on another internal disc (on the same box that I'm using with the working Zimbra server) (and with another NIC card, mainly because I'm using AppleRemoteDesktop and it relays more on MAC adresses which in fact turned to confuse ARD and the zimbra box itself, because just to be sure I did change the domain name to not messing around with my working install aka (Working install#1 is zimbra.zimbra.org and second one is brazim.brazim.org) all my DNS are fine and running on OsX server and on my gigabitfirewall IPCOP Router wich is my second DNS server.)
    So, at least for me, getting the same MAC adress but with different hostname.domain.com (not at the same time - but the same Box) was getting server into trouble.
    Also I use kerberos on My OsX server and did put the 'test' box in a computer list, which here too relays on MAC adress. I HAVE to identify the computers in order for them to get 'accepted by the kerberized network'.

    So I'm quite sure that doing two different domains.com on the same MAC address did mess things around in OsXserver (myDNSMaster) and ARD… again tooking another NIC (5euros) just solved this issue. As now I have my test#1zimbra server (zimbra.zimbra.org) Identified on a Mac adress#1 and the second Test2zimbra server (brazim.brazim.org) Identified on ANOTHER MAC Adress. Even so it is on the same Box.
    ( in system pref/network, I only activate One NIC at a time)
    So Now OsXserver/LDAP/Kerberos and/or ARD are not confused anymore.
    Also before doing this, rebooting my router(a LINUX-IPCOP box), more or less solved the issue but not for long.

    not sure if I'm explicite as It's hard for me to explains this in english. not so binligue, And I'm more confortable with reading than writing.
    running Mac Os X

Similar Threads

  1. Installed on Mac OS X client, host file question
    By McBurtnieks in forum Installation
    Replies: 1
    Last Post: 04-01-2007, 11:09 AM
  2. Mac OS X Installation and Quick Start of Zimbra
    By zimbra_osx in forum Installation
    Replies: 10
    Last Post: 11-21-2006, 03:15 AM
  3. Mac OS X + Zimbra + Apache 2
    By abetam in forum Installation
    Replies: 1
    Last Post: 10-06-2006, 10:16 PM
  4. Uninstall in Mac OS X?
    By avi4now in forum Installation
    Replies: 10
    Last Post: 01-09-2006, 11:14 AM
  5. Installation on Mac OS X
    By fozzy in forum Installation
    Replies: 1
    Last Post: 11-19-2005, 10:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •