Results 1 to 8 of 8

Thread: imapproxy requiring root password to start?

  1. #1
    Join Date
    Mar 2007
    Posts
    9
    Rep Power
    8

    Question imapproxy requiring root password to start?

    Server: OS X 10.4.9 server
    Zimbra: Updated to 4.5.6. 1044

    After backing up and updating to 4.5.6, when the config.pl was starting the services, it stopped on 'starting imapproxyPassword: ' and was asking for the root pw like it's using sudo.

    I entered it and it just kept asking for the pw, so I hit return thinking that it would at least kick me out an error message and I got the standard sudo warning about passwords.

    And then it kept running the config.pl and said all was well. Except imapproxy won't start.

    I've reinstalled and rerun the config script, and tried everything I can think of.

    Any thoughts?

  2. #2
    Join Date
    Mar 2007
    Posts
    9
    Rep Power
    8

    Default

    Here's what it looks like when I run zmcontrol start:

    Code:
    server:/Users/admin zimbra$ zmcontrol start 
    Host server.purebrand.com
            Starting ldap...Done.
            Starting logger...Done.
            Starting mailbox...Done.
            Starting imapproxy...Password:
    Password:
    Password:
    Password:
    FAILED
    Starting imap4
    
    WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information.
    
    To proceed, enter your password, or type Ctrl-C to abort.
    
    Starting imap4s
    
    WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information.
    
    To proceed, enter your password, or type Ctrl-C to abort.
    
    Starting pop3
    
    WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information.
    
    To proceed, enter your password, or type Ctrl-C to abort.
    
    Starting pop3s
    
    WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information.
    
    To proceed, enter your password, or type Ctrl-C to abort.
    
    imap4 is not running
    imap4s is not running
    pop3 is not running
    pop3s is not running
    
    
            Starting antispam...Done.
            Starting antivirus...Done.
            Starting snmp...Done.
            Starting spell...Done.
            Starting mta...Done.
    server:/Users/admin zimbra$

  3. #3
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    Looks like the perdition entry didn't get added to /etc/sudoers.

    As root run visudo and add a line like this

    Code:
    %zimbra ALL=NOPASSWD:/opt/zimbra/perdition/sbin/perdition
    With this entry added to /etc/suoders you should not get prompted for a passwd when running zmsetup.
    Last edited by brian; 07-15-2007 at 10:51 PM.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  4. #4
    Join Date
    Mar 2007
    Posts
    9
    Rep Power
    8

    Default

    I just went to do that and that line is already in /etc/sudoers.

    Hmmm... I turned off imapproxy for now and users are able to connect via port 7143 until we get this figured out.

    Doing a "find /opt/zimbra/ -nogroup" gets me a list of perdition files that have a gid of 503... which isn't a valid gid. I may have to reinstall the system, something is awry.

    Thanks for the help, let me know if you think of anything else I should try before I rip everything apart.

  5. #5
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    Running /opt/zimbra/libexec/zmfixperms should resolve the uid=503 issue.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  6. #6
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    777
    Rep Power
    9

    Default

    There is a problem with zmfixperms:

    # NOT /opt/zimbra/store, /opt/zimbra/backup takes forever
    chown -R zimbra:zimbra /opt/zimbra/a* /opt/zimbra/[c-ot-z]* /opt/zimbra/s[a-su-z]* /opt/zimbra/perdition-1.17


    zimbra@rumpy:~$ ls -l|grep perd
    lrwxrwxrwx 1 root root 28 Jul 19 00:06 perdition -> /opt/zimbra/perdition-1.17.1
    drwxr-xr-x 3 zimbra zimbra 4096 Jul 19 00:06 perdition-1.17
    drwxr-xr-x 9 503 503 4096 Jul 19 00:06 perdition-1.17.1


    Looks like the zmfixperms script wasn't updated to reflect the new minor version number of perdition.
    Last edited by Krishopper; 07-18-2007 at 10:37 PM.

  7. #7
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    nice catch
    Can you file a bug?

  8. #8
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    This was fixed and will be in 4.5.7. In the meantime if you run the following as root it will resolve the problem.

    Code:
    rm -f /opt/zimbra/perdition
    ln -s /opt/zimbra/perdition-1.17.1 /opt/zimbra/perdition
    chown -R /opt/zimbra/perdition-1.17.1
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM
  2. Replies: 16
    Last Post: 09-07-2006, 06:39 AM
  3. Login does not appear
    By alexz in forum Administrators
    Replies: 10
    Last Post: 04-18-2006, 06:46 AM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM
  5. Seeming variety of problems on suse-9.1
    By Crexis in forum Installation
    Replies: 52
    Last Post: 03-03-2006, 11:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •