Results 1 to 2 of 2

Thread: Active Directory auth questions

  1. #1
    Join Date
    Apr 2007
    Rep Power

    Default Active Directory auth questions

    This seems to be a reoccuring question with new installs:

    I am using ZCS 4.5.6_GA_1044 on CentOS 5. The install went very well based on the instructions found here. At this time I am looking at integrating ZCS with my AD 2K3 domain. So far, it doesn't look good. For the GAL I chose external/AD. Despite the fact that the test at the end is reported as a success, it didn't return any results. I wound up using LDAP for the GAL and it appears to be working using these settings:

    GAL mode:
    Most results returned by GAL search:
    Server type:
    LDAP filter:*
    Autocomplete filter:
    LDAP search base:
    Bind DN:

    Now for authentication, I can't get anything to work, AD or LDAP. I receive successful messages using the following settings, but authentication at the login screen still fails:

    Authentication mechanism:
    External Active Directory
    LDAP bind DN template:

    The documentation is vague on exactly how to get this working. How do the accounts actually get created on the ZCS server? Once you set up AD auth, is is automatic? Or do you have to manually configure users in order to get auth to work?

  2. #2
    Join Date
    Jul 2007
    Rep Power

    Default a bug?

    I had the same issue and what worked for me was to recreate the domain from scratch and set up auth there. If you are like me you probably didn't get auth to work on the first try. After several failed attempts I finally got the credentials correct with the right filter etc. and had a successful test.

    The problem is that the config never changed. Once I would hit the finish button the config would stay the same. Restarting Zimbra did not change anything nor did rebooting the server. I had to delete the domain and create a new one with the correct info in it for ldap auth. Then, it worked like a charm.

Similar Threads

  1. Replies: 1
    Last Post: 05-28-2008, 04:18 AM
  2. centos 5 zimbra 4.5.6 no statistics
    By rutman286 in forum Installation
    Replies: 9
    Last Post: 08-14-2007, 09:30 AM
  3. Switching from Internal Auth to External Active Directory
    By MindexAdmin in forum Installation
    Replies: 5
    Last Post: 07-19-2007, 11:14 AM
  4. Replies: 5
    Last Post: 01-19-2007, 11:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts