Results 1 to 8 of 8

Thread: Zimba Beta 5 OSX install failure

  1. #1
    Join Date
    Nov 2005
    Posts
    16
    Rep Power
    9

    Default Zimba Beta 5 OSX install failure

    I am running Mac OSX 10.4.10 (intel), downloaded the beta install .dmg, and executed the installation package. Everything went ok, then it issued a statement to execute /opt/zimbra/libexec/zmsetup.pl as root which I then proceeded to do.

    The following collection of messages is what is displayed when I attempt to execute zmsetup.pl:

    Can't load '/opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/auto/DBI/DBI.bundle' for module DBI: dlopen(/opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/auto/DBI/DBI.bundle, 1): no suitable image found. Did find:
    /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/auto/DBI/DBI.bundle: mach-o, but wrong architecture at /System/Library/Perl/5.8.6/darwin-thread-multi-2level/DynaLoader.pm line 230, line 228.
    at /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/DBI.pm line 261
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/DBI.pm line 261, line 228.
    Compilation failed in require at /opt/zimbra/libexec/scripts/Migrate.pm line 28, line 228.
    BEGIN failed--compilation aborted at /opt/zimbra/libexec/scripts/Migrate.pm line 28, line 228.
    Compilation failed in require at /opt/zimbra/libexec/zmupgrade.pm line 32, line 228.
    BEGIN failed--compilation aborted at /opt/zimbra/libexec/zmupgrade.pm line 32, line 228.
    Compilation failed in require at libexec/zmsetup.pl line 69, line 228.
    BEGIN failed--compilation aborted at libexec/zmsetup.pl line 69, line 228.

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Maybe because of the 10 update.

    Do you have the Developer tools installed from the CD? Try that.

  3. #3
    Join Date
    Nov 2005
    Posts
    16
    Rep Power
    9

    Default Zimbra Beta 5 OSX install failure

    OK - I installed both the WebObjects and xCode developer tools (and also checked for updates, reboot, etc.). After all that - same result. Any other ideas?

  4. #4
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    but wrong architecture at /System/Library/Perl/5.8.6/darwin-thread-multi-2level/DynaLoader.pm line 230, line 228.
    log fragment says wrong architecture, sure you've got intel binaries, are there 64bit issues etc?

  5. #5
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Could be the arch, but I am testing leopard and had this problem with openssl. . .even though the libs it was looking at were intel, it said wrong arch.

    jh

  6. #6
    Join Date
    Nov 2005
    Posts
    16
    Rep Power
    9

    Default Zimbra Beta OSX install failure

    OK - I did have the wrong arch. version (sorry about that...). I get further and startup script does run, but it fails with a message about trying to stop Zimbra services (this is a new install, so there are no services running). The log file is attached.

    Question - does Zimbra need to be installed prior to installing this version? I would assume that it could be installed from scratch.
    Attached Files Attached Files

  7. #7
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    Hi

    This is because you have incomplete/corrupt info in /opt/zimbra due to the aborted install.

    sh install.sh -u
    rm -rf /opt/zimbra

    then start the install again

  8. #8
    Join Date
    Nov 2005
    Posts
    16
    Rep Power
    9

    Smile Zimba Beta 5 OSX install failure

    Thanks for the info - finally got it working! In addition to the commands you cited, the "zimbra" user has to be removed as well. Once I did that, it installed properly.

Similar Threads

  1. 5.0 Beta Test Server Install - Sanity Check
    By soxfan in forum Installation
    Replies: 3
    Last Post: 06-07-2007, 10:53 AM
  2. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 02:39 PM
  3. Installing Zimbra using OSX LDAP
    By camiriddle in forum Installation
    Replies: 2
    Last Post: 07-13-2006, 06:17 PM
  4. Zimbra 3.1.4 installation failure on package install
    By gmcraff in forum Installation
    Replies: 3
    Last Post: 07-08-2006, 11:24 AM
  5. OSX install failure
    By gregjohnson1024 in forum Installation
    Replies: 2
    Last Post: 02-22-2006, 08:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •