Results 1 to 10 of 11

Thread: fresh install down may be due to tomcat

Hybrid View

  1. #1
    Join Date
    Jul 2007
    Posts
    7
    Rep Power
    8

    Default fresh install down may be due to tomcat

    hello everybody

    first of all you have to know i am a newbie in mail system so if i am long to understand it's normal
    Yesterday i have installed my mail server and all worked fine. This morning when i tried to restart my server nothing worked.

    i have taken a look in /var/log/zimbra.log and this log tells that i have a problem with tomcat

    ==================================================
    Jul 25 07:25:17 mail sshd[2651]: Server listening on :: port 22.
    Jul 25 07:25:21 mail su[2754]: (pam_unix) session opened for user zimbra by (uid=0)
    Jul 25 07:25:24 mail zimbramon[2759]: 2759:info: Starting services
    Jul 25 07:25:27 mail slapd[2800]: @(#) $OpenLDAP: slapd 2.3.34 (Mar 28 2007 13:45:10) $ ^Iroot@build-debian.liquidsys.com:/home/build/p4/main/ThirdParty/openldap/openldap-2.3.34/servers/slapd
    Jul 25 07:25:27 mail slapd[2801]: slapd starting
    Jul 25 07:25:35 mail zimbramon[2759]: 2759:info: Rewriting configs antispam antivirus webxml mailbox antispam antivirus mta sasl
    Jul 25 07:25:42 mail zimbramon[2759]: 2759:info: Starting logger
    Jul 25 07:25:42 mail zimbramon[2759]: 2759:info: Starting mailbox
    Jul 25 07:25:53 mail zmtomcatmgr[3150]: status requested
    Jul 25 07:25:53 mail zmtomcatmgr[3150]: stale pid 7058 found in /opt/zimbra/log/zmtomcatmgr.pid: No such process
    Jul 25 07:25:53 mail zmtomcatmgr[3150]: assuming no other instance is running
    Jul 25 07:25:53 mail zmtomcatmgr[3150]: no manager process is running
    Jul 25 07:25:53 mail zmtomcatmgr[3157]: start requested
    Jul 25 07:25:53 mail zmtomcatmgr[3157]: checking if another instance of manager is already running
    Jul 25 07:25:53 mail zmtomcatmgr[3157]: stale pid 7058 found in /opt/zimbra/log/zmtomcatmgr.pid: No such process
    Jul 25 07:25:53 mail zmtomcatmgr[3157]: assuming no other instance is running
    Jul 25 07:25:53 mail zmtomcatmgr[3158]: wrote manager pid 3158 to /opt/zimbra/log/zmtomcatmgr.pid
    Jul 25 07:25:53 mail zmtomcatmgr[3158]: manager started tomcat/JVM with pid 3159
    Jul 25 07:25:53 mail zimbramon[2759]: 2759:info: Starting antispam
    Jul 25 07:25:54 mail zimbramon[2759]: 2759:info: Starting antivirus
    Jul 25 07:25:54 mail zimbramon[2759]: 2759:info: Starting snmp
    Jul 25 07:25:54 mail zimbramon[2759]: 2759:info: Starting spell
    Jul 25 07:25:55 mail clamd[3203]: clamd daemon 0.90.2 (OS: linux-gnu, ARCH: i386, CPU: i686)
    Jul 25 07:25:55 mail clamd[3203]: Log file size limited to 20971520 bytes.
    Jul 25 07:25:55 mail clamd[3203]: Reading databases from /opt/zimbra/clamav/db
    Jul 25 07:25:56 mail zimbramon[2759]: 2759:info: Starting mta
    Jul 25 07:25:56 mail postfix/postqueue[3227]: fatal: Queue report unavailable - mail system is down
    Jul 25 07:26:03 mail CRON[3249]: (pam_unix) session opened for user zimbra by (uid=0)
    Jul 25 07:26:05 mail amavis[3173]: starting. /opt/zimbra/amavisd/sbin/amavisd at mail.acoqp.fr amavisd-new-2.4.3 (20060930), Unicode aware, LANG=C
    Jul 25 07:26:05 mail amavis[3173]: user=1001, EUID: 1001 (1001); group=, EGID: 1001 1002 1001 5 4 (1001 1002 1001 5 4); log_level=1
    Jul 25 07:26:05 mail amavis[3173]: Perl version 5.008008
    Jul 25 07:26:05 mail postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.2.9/conf/main.cf
    Jul 25 07:26:06 mail amavis[3173]: SpamControl: init_pre_chroot done
    Jul 25 07:26:06 mail amavis[3291]: Net::Server: Process Backgrounded
    Jul 25 07:26:06 mail amavis[3291]: Net::Server: 2007/07/25-07:26:06 Amavis (type Net::Server::PreForkSimple) starting! pid(3291)
    Jul 25 07:26:06 mail amavis[3291]: Net::Server: Binding to UNIX socket file /opt/zimbra/amavisd/amavisd.sock using SOCK_STREAM
    Jul 25 07:26:06 mail amavis[3291]: Net::Server: Binding to TCP port 10024 on host 127.0.0.1
    Jul 25 07:26:06 mail amavis[3291]: Net::Server: Group Not Defined. Defaulting to EGID '1001 1002 1001 5 4'
    Jul 25 07:26:06 mail amavis[3291]: Net::Server: User Not Defined. Defaulting to EUID '1001'
    Jul 25 07:26:06 mail amavis[3291]: Module Amavis::Conf 2.072
    Jul 25 07:26:06 mail amavis[3291]: Module Archive::Tar 1.30
    Jul 25 07:26:06 mail amavis[3291]: Module Archive::Zip 1.18
    Jul 25 07:26:06 mail amavis[3291]: Module BerkeleyDB 0.31
    Jul 25 07:26:06 mail amavis[3291]: Module Compress::Zlib 2.004
    Jul 25 07:26:06 mail amavis[3291]: Module Convert::TNEF 0.17
    Jul 25 07:26:06 mail amavis[3291]: Module Convert::UUlib 1.08
    Jul 25 07:26:06 mail amavis[3291]: Module DBD::mysql 4.003
    Jul 25 07:26:06 mail amavis[3291]: Module DBI 1.54
    Jul 25 07:26:06 mail amavis[3291]: Module DB_File 1.815
    Jul 25 07:26:06 mail amavis[3291]: Module Digest::MD5 2.36
    Jul 25 07:26:06 mail amavis[3291]: Module MIME::Entity 5.420
    Jul 25 07:26:06 mail amavis[3291]: Module MIME::Parser 5.420
    Jul 25 07:26:06 mail amavis[3291]: Module MIME::Tools 5.420
    Jul 25 07:26:06 mail amavis[3291]: Module Mail::Header 1.74
    Jul 25 07:26:06 mail amavis[3291]: Module Mail::Internet 1.74
    Jul 25 07:26:06 mail amavis[3291]: Module Mail::SpamAssassin 3.001008
    Jul 25 07:26:06 mail amavis[3291]: Module Net::Cmd 2.27
    Jul 25 07:26:06 mail amavis[3291]: Module Net:NS 0.59
    Jul 25 07:26:06 mail amavis[3291]: Module Net::LDAP 0.34
    Jul 25 07:26:06 mail amavis[3291]: Module Net::SMTP 2.30
    Jul 25 07:26:06 mail amavis[3291]: Module Net::Server 0.95
    Jul 25 07:26:06 mail amavis[3291]: Module Time::HiRes 1.9707
    Jul 25 07:26:06 mail amavis[3291]: Module Unix::Syslog 0.99
    Jul 25 07:26:06 mail amavis[3291]: Amavis:B code loaded
    Jul 25 07:26:06 mail amavis[3291]: Amavis::Cache code loaded
    Jul 25 07:26:06 mail amavis[3291]: SQL base code NOT loaded
    Jul 25 07:26:06 mail amavis[3291]: SQL::Log code NOT loaded
    Jul 25 07:26:06 mail amavis[3291]: SQL::Quarantine NOT loaded
    Jul 25 07:26:06 mail amavis[3291]: Lookup::SQL code NOT loaded
    Jul 25 07:26:06 mail amavis[3291]: Lookup::LDAP code loaded
    Jul 25 07:26:06 mail amavis[3291]: AM.PDP-in proto code loaded
    Jul 25 07:26:06 mail amavis[3291]: SMTP-in proto code loaded
    Jul 25 07:26:06 mail amavis[3291]: Courier proto code NOT loaded
    Jul 25 07:26:06 mail amavis[3291]: SMTP-out proto code loaded
    Jul 25 07:26:06 mail amavis[3291]: Pipe-out proto code NOT loaded
    Jul 25 07:26:06 mail amavis[3291]: BSMTP-out proto code NOT loaded
    Jul 25 07:26:06 mail amavis[3291]: Local-out proto code loaded
    Jul 25 07:26:06 mail amavis[3291]: OS_Fingerprint code NOT loaded
    Jul 25 07:26:06 mail amavis[3291]: ANTI-VIRUS code loaded
    Jul 25 07:26:06 mail amavis[3291]: ANTI-SPAM code loaded
    Jul 25 07:26:06 mail amavis[3291]: ANTI-SPAM-SA code loaded
    Jul 25 07:26:06 mail amavis[3291]: Unpackers code loaded
    Jul 25 07:26:07 mail amavis[3291]: Found $file at /usr/bin/file
    Jul 25 07:26:07 mail amavis[3291]: No $dspam, not using it
    Jul 25 07:26:07 mail amavis[3291]: Internal decoder for .mail
    Jul 25 07:26:07 mail amavis[3291]: Internal decoder for .asc
    Jul 25 07:26:07 mail amavis[3291]: Internal decoder for .uue
    Jul 25 07:26:07 mail amavis[3291]: Internal decoder for .hqx
    Jul 25 07:26:07 mail amavis[3291]: Internal decoder for .ync
    Jul 25 07:26:07 mail amavis[3291]: No decoder for .F tried: unfreeze, freeze -d, melt, fcat
    Jul 25 07:26:07 mail amavis[3291]: Found decoder for .Z at /bin/uncompress
    Jul 25 07:26:07 mail amavis[3291]: Internal decoder for .gz
    Jul 25 07:26:07 mail amavis[3291]: Found decoder for .bz2 at /bin/bzip2 -d
    Jul 25 07:26:07 mail amavis[3291]: No decoder for .lzo tried: lzop -d
    Jul 25 07:26:07 mail amavis[3291]: No decoder for .rpm tried: rpm2cpio.pl, rpm2cpio
    Jul 25 07:26:07 mail amavis[3291]: Found decoder for .cpio at /bin/cpio
    Jul 25 07:26:07 mail amavis[3291]: Found decoder for .tar at /bin/cpio
    Jul 25 07:26:07 mail amavis[3291]: Found decoder for .deb at /usr/bin/ar
    Jul 25 07:26:07 mail amavis[3291]: Internal decoder for .zip
    Jul 25 07:26:07 mail amavis[3291]: No decoder for .rar tried: rar, unrar
    Jul 25 07:26:07 mail amavis[3291]: No decoder for .arj tried: arj, unarj
    Jul 25 07:26:07 mail amavis[3291]: No decoder for .arc tried: nomarch, arc
    Jul 25 07:26:07 mail amavis[3291]: No decoder for .zoo tried: zoo
    Jul 25 07:26:07 mail amavis[3291]: No decoder for .lha tried: lha
    Jul 25 07:26:07 mail amavis[3291]: No decoder for .cab tried: cabextract
    Jul 25 07:26:07 mail amavis[3291]: No decoder for .tnef tried: tnef
    Jul 25 07:26:07 mail amavis[3291]: Internal decoder for .tnef
    Jul 25 07:26:07 mail amavis[3291]: No decoder for .exe tried: rar, unrar; lha; arj, unarj
    Jul 25 07:26:07 mail amavis[3291]: Using internal av scanner code for (primary) ClamAV-clamd
    Jul 25 07:26:07 mail amavis[3291]: Creating db in /opt/zimbra/amavisd/db/; BerkeleyDB 0.31, libdb 4.2
    Jul 25 07:26:07 mail postfix/postfix-script: starting the Postfix mail system
    Jul 25 07:26:07 mail postfix/master[3306]: fatal: bind 0.0.0.0 port 25: Address already in use
    Jul 25 07:26:08 mail saslauthd[3317]: detach_tty : master pid is: 3317
    Jul 25 07:26:08 mail saslauthd[3317]: ipc_init : listening on socket: /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/state/mux
    Jul 25 07:26:08 mail amavis[3291]: SpamControl: initializing Mail::SpamAssassin
    Jul 25 07:26:08 mail su[2754]: (pam_unix) session closed for user zimbra
    Jul 25 07:26:10 mail amavis[3291]: SpamControl: init_pre_fork done
    Jul 25 07:26:10 mail sshd[3312]: Accepted password for root from 192.168.0.5 port 38582 ssh2
    Jul 25 07:26:10 mail sshd[3337]: (pam_unix) session opened for user root by root(uid=0)
    Jul 25 07:26:15 mail zmtomcatmgr[3158]: manager woke up from wait on tomcat/JVM with pid 3159
    Jul 25 07:26:15 mail zmtomcatmgr[3158]: manager started tomcat/JVM with pid 3389
    Jul 25 07:26:17 mail su[3439]: (pam_unix) session opened for user zimbra by (uid=0)
    Jul 25 07:26:17 mail zmtomcatmgr[3441]: status requested
    Jul 25 07:26:17 mail zmtomcatmgr[3441]: status OK
    Jul 25 07:26:17 mail postfix/postqueue[3453]: fatal: Queue report unavailable - mail system is down
    Jul 25 07:26:19 mail zimbramon[3250]: 3250:info: 2007-07-25 07:26:03, STATUS: mail.acoqp.fr: antispam: Running
    Jul 25 07:26:19 mail zimbramon[3250]: 3250:info: 2007-07-25 07:26:03, STATUS: mail.acoqp.fr: antivirus: Stopped
    Jul 25 07:26:19 mail zimbramon[3250]: 3250:info: 2007-07-25 07:26:03, STATUS: mail.acoqp.fr: ldap: Running
    Jul 25 07:26:19 mail zimbramon[3250]: 3250:info: 2007-07-25 07:26:03, STATUS: mail.acoqp.fr: logger: Running
    Jul 25 07:26:19 mail zimbramon[3250]: 3250:info: 2007-07-25 07:26:03, STATUS: mail.acoqp.fr: mailbox: Running
    Jul 25 07:26:19 mail zimbramon[3250]: 3250:info: 2007-07-25 07:26:03, STATUS: mail.acoqp.fr: mta: Stopped
    Jul 25 07:26:19 mail zimbramon[3250]: 3250:info: 2007-07-25 07:26:03, STATUS: mail.acoqp.fr: snmp: Running
    Jul 25 07:26:19 mail zimbramon[3250]: 3250:info: 2007-07-25 07:26:03, STATUS: mail.acoqp.fr: spell: Running
    Jul 25 07:26:19 mail CRON[3249]: (pam_unix) session closed for user zimbra
    Jul 25 07:26:28 mail zmtomcatmgr[3158]: manager woke up from wait on tomcat/JVM with pid 3389
    Jul 25 07:26:28 mail zmtomcatmgr[3158]: tomcat/JVM exited twice in 13 seconds (tolerance=60)
    ===============================================

    Of course i have tried to restart services but it does not change the problem

    If someone can help me plzzz thanks by advance

  2. #2
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    Jul 25 07:26:07 mail postfix/master[3306]: fatal: bind 0.0.0.0 port 25: Address already in use
    You've got some other MTA running, stop it first.

    Common reason for tomcat shutting down at this stage is another IMAP/POP daemon running on standard ports, check you're not running another mail system.

    How much memory do you have?

  3. #3
    Join Date
    Jul 2007
    Posts
    7
    Rep Power
    8

    Default

    hello

    first of all thanks for your help

    I have 1giga of memory on the server

    i have stopped the zimbra services with zmcontrol stop and i check the connection with a netstat -l and the port 25 is still in use
    I don't know how find which service use this port ??

    may be you can help me

  4. #4
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    ps -ef |grep sendmail
    ps -ef |grep postfix
    ps -ef |grep exim

    lsof -i tcp:25

  5. #5
    Join Date
    Jul 2007
    Posts
    7
    Rep Power
    8

    Default

    thanks for your help

    here the answer of the command:

    mail:~# ps -ef |grep sendmail
    root 11709 2828 0 14:49 pts/0 00:00:00 grep sendmail

    mail:~# ps -ef |grep postfix
    root 11719 2828 0 14:49 pts/0 00:00:00 grep postfix

    mail:~# ps -ef |grep exim
    100 2634 1 0 12:35 ? 00:00:00 /usr/sbin/exim4 -bd -q30m
    root 11805 2828 0 14:50 pts/0 00:00:00 grep exim

    mail:~# lsof -i tcp:25
    COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
    exim4 2634 Debian-exim 3u IPv4 7773 TCP localhost:smtp (LISTEN)



    So if i understand well i have a exim service running on my server. I did a kill -9 2634 on restart zimbra with command zmcontrol start
    zmcontrol status
    Host mail.acoqp.fr
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Stopped
    tomcat is not running
    mta Running
    snmp Running
    spell Running


    TomCat is still in error

    Thanks a lots for your help

  6. #6
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    anything show up for:

    lsof -i tcp:143
    lsof -i tcp:110
    lsof -i tcp:80

    ?

Similar Threads

  1. fresh install (both OS and Zimbra) but zimbra-spell fails
    By xtremetoonz in forum Installation
    Replies: 14
    Last Post: 09-09-2007, 01:34 AM
  2. New Install - mta won't start (part 1 due to IMG limits)
    By omegainstitute in forum Installation
    Replies: 5
    Last Post: 05-08-2007, 01:43 PM
  3. RedHat EL4 fresh install
    By richard.bessey in forum Installation
    Replies: 1
    Last Post: 10-24-2006, 09:47 PM
  4. Going Crazy (Fresh Install Problems)
    By hirnschmalz in forum Installation
    Replies: 2
    Last Post: 09-16-2006, 04:55 PM
  5. tomcat - macosx install - please help
    By gmsmith in forum Installation
    Replies: 3
    Last Post: 04-19-2006, 01:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •