Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: SPF Question

  1. #1
    Join Date
    Jun 2007
    Location
    Philippines
    Posts
    193
    Rep Power
    8

    Default SPF Question

    Hi all,

    Im interested to integrate SPF in my Zimbra installation, and I have this instruction from the zimbra wiki for Ubuntu (dapper drake).

    sudo apt-get install libmail-spf-query-perl
    After this has been installed, should there be anything more I need to do so that it will be used properly by Zimbra?

    Thanks in advance for your feedback.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    That's only one of the steps needed, you need to make changes to the spamassassin config (further down that page).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jun 2007
    Location
    Philippines
    Posts
    193
    Rep Power
    8

    Default

    I've been looking as where to enable this SPF in spamassassin config but not lucky to find it. I have looked at the entire forum also in vain.

    The v310 file doens't have the option to load SPF. Do i have to add the line manually or was it not really included at all?

    If I have to add the line manually, how do I do it? Anyone who have the luck doing this in Dapper Drake?

    Thanks so much in advance.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    There's nothing else to do apart from add the perl module and make the score changes in the config as per the wiki article. You can see if it's getting called by looking at the /var/log/zimbra.log and looking for SPF - you should see entries in there like the following:

    Code:
    Aug 13 17:38:42 chinook amavis[1715]: Module Mail::SPF::Query    1.999001
    you should see those entries without the score having been set.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Jun 2007
    Location
    Philippines
    Posts
    193
    Rep Power
    8

    Default

    Thanks for the reply Bill.

    I will check this one out.

  6. #6
    Join Date
    Jun 2007
    Location
    Philippines
    Posts
    193
    Rep Power
    8

    Default

    Quote Originally Posted by phoenix View Post
    There's nothing else to do apart from add the perl module and make the score changes in the config as per the wiki article. You can see if it's getting called by looking at the /var/log/zimbra.log and looking for SPF - you should see entries in there like the following:

    Code:
    Aug 13 17:38:42 chinook amavis[1715]: Module Mail::SPF::Query    1.999001
    you should see those entries without the score having been set.
    Ok Bill, somehow I think I manage this to work since I can see that my e-mail now have an SPF in the header when I tested sending to Gmail.

    My concern now is, I think, it's not checking the incoming mails for SPF and I keep looking for the similar message you posted, but I'm not having it in my logs, so that means that incoming mails are not being tested for SPF.

    Am i missing something still?

    Thanks in advance for the feedback.

  7. #7
    Join Date
    Mar 2007
    Posts
    85
    Rep Power
    8

    Default

    Hello,
    I have the same issue as randall. I can see SPF check in email when I send to gmail. But it's not checking the incoming mails for SPF. Am I missing anythings?
    Do you have ways to debug it?

    I have this log in zimbra.log
    Dec 6 17:12:43 server amavis[13528]: Module Mail::SPF v2.005

    Best Regards,

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Make sure that any lines you've added to config files have carriage returns and that there are no extraneous characters, this does work as described in the wiki.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Mar 2007
    Posts
    85
    Rep Power
    8

    Default

    Hi, phoenix. Please show your configuration exactly. I don't still have it to work.

    Many thanks for your information.

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    It's exactly as described in the wiki article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Hot backup question on open source?
    By cfigurelli in forum Administrators
    Replies: 7
    Last Post: 10-09-2008, 02:43 AM
  2. Replies: 7
    Last Post: 06-08-2008, 02:54 PM
  3. Question about host names
    By OverZealous in forum Installation
    Replies: 7
    Last Post: 06-10-2007, 02:47 PM
  4. Multiple Domains Question
    By kristiaan_d in forum Administrators
    Replies: 2
    Last Post: 03-14-2007, 05:38 AM
  5. Shared Calendar question, & saving settings.
    By achow in forum Zimbra in Education
    Replies: 1
    Last Post: 01-25-2006, 01:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •