Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Checking POP accounts within IMAP

  1. #11
    Join Date
    Jul 2007
    San Jose, CA
    Rep Power

    Default Not working yet. . .

    Quote Originally Posted by phoenix View Post
    Just give it the email address you want it sent to and it'll get delivered i.e.
    Hey Bill, I just got back from vacation and tried this. . .set up a fetchmail process for user zimbra within Webmin, gave it the name and server address of an external POP account, directed it to my local Zimbra address, and the webmin module seemed happy. However, then I clicked the "check all servers" link in webmin and got the following error:

    Checking for mail on server(s) with command fetchmail -v -f '/opt/zimbra/.fetchmailrc' ..
    /opt/zimbra/ Permission denied
    fetchmail: lock creation failed.
    .. checking failed!
    I'm not a Linux expert but this message suggests to me that it might be a permissions issue with /opt/zimbra/.fetchmailrc itself, which has the permissions -rwx------ at this moment, but I'm reluctant to screw with permissions without asking somebody who knows more than I do first. Suggestions?

    Just for reference, here is the redacted contents of /opt/zimbra/.fetchmailrc:

    poll myaccountname
            proto pop3
            via myaccount_servername
            user "myuser"
            pass "mypassword"

    Last edited by dwmtractor; 08-15-2007 at 03:59 PM.

  2. #12
    Join Date
    Jul 2007
    San Jose, CA
    Rep Power

    Default Problem solved!

    OK, I found a similar problem in another thread. My error was setting up Fetchmail to use the Zimbra user as the user for the fetching process.

    For those who know as much as I did or less Fetchmail requires a local user for the rights under which to run its process. That user has to have a .fetchmailrc file in their home directory, which is where the configuration settings get saved. This user doesn't have to have anything at all to do with your Zimbra mail address to which the fetched mail will be sent.

    Anyway, using the user "zimbra" as that user appears to work when you're setting up the fetchmail process, but apparently the rights are such that you can't write the mail to that directory. Using any other local Linux user does the trick.

Similar Threads

  1. having some trouble in install to FC6 X 64
    By Max Ma in forum Installation
    Replies: 2
    Last Post: 07-13-2007, 09:46 PM
  2. Replies: 13
    Last Post: 05-15-2007, 06:41 AM
  3. Disable SSL checking for slave POP accounts
    By SteveSmith in forum Administrators
    Replies: 0
    Last Post: 04-03-2007, 12:49 AM
  4. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 10:30 PM
  5. zimbra 4.5RC2 pop accounts auto check???
    By nfear24 in forum Administrators
    Replies: 5
    Last Post: 01-30-2007, 12:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts