Results 1 to 8 of 8

Thread: Problems installing (cvs) on FC4 (x86_64)

Threaded View

  1. #1
    Join Date
    Nov 2005
    Location
    Israel
    Posts
    13
    Rep Power
    10

    Unhappy Problems installing (cvs) on FC4 (x86_64)

    Hi.

    Let me start by saying that I really appreciate the fact that Zimbra is FOSS. I also know that it is just the beginning, and that as such it suffers from many compatibility issues.

    I am trying to build and install from the CVS version. I am using FC4, on a x86_64 machine. I have encountered some problems while building ThirdParty tools - but I resolved them (I can send the diffs if needed): they mostly invlove adding "-fPIC" to the Native compilation. Once I am done, I will post my experience.

    Also, the CVS head is not very stable, and doesn't always compile. Can you please make sure that at least the CVS HEAD branch compiles? I was forced many times to mix-and-match files from vaious dates, just to make the server/client compile ;-)

    I use the following guidelines:
    * "http://www.zimbra.com/blog/archives/2005/08/developing_with.html"
    * ZimbraServer/docs/build_cvs_howto.txt

    Currently, I have reached the stage where I need to run /opt/zimbra/libexec/zmldapinit. It fails, because of an authentication?? file.
    ++++++
    TLS: could not load verify locations (file:`/opt/zimbra/conf/ca/ca.pem',dir:`').
    ++++++

    What is this ca.pem file? The "conf/ca" directory is empty in my case - where should have it been initialized?

    Thanks.

    These are the last lines of running the init script in verbose mode (+slapd in verbose):
    =================================================
    Code:
    daemon_init: ldap://:389/
    /opt/zimbra/openldap/etc/openldap/schema/zimbra.schema: line 2832: bad config line (ignored)
    bdb_db_init: Initializing BDB database
    TLS: could not load verify locations (file:`/opt/zimbra/conf/ca/ca.pem',dir:`').
    TLS: error:02001002:system library:fopen:No such file or directory bss_file.c:104
    TLS: error:2006D080:BIO routines:BIO_new_file:no such file bss_file.c:107
    TLS: error:0B084002:x509 certificate routines:X509_load_cert_crl_file:system lib by_file.c:279
    main: TLS init def ctx failed: -1
    slapd stopped.
    connections_destroy: nothing to destroy.
    Started slapd: pid
    
    if [ $? -ne 0 ]; then
            exit 1
    fi
    
    ${zimbra_home}/openldap/bin/ldapmodify -a -c -H ldap://127.0.0.1:389 -w ${ldap_root_password} -D "${zimbra_ldap_userdn}" -x -f ${config_dir}/zimbra.ldif
    ldap_bind: Can't contact LDAP server (-1)
    
    if [ $? -ne 0 ]; then
            exit 2
    fi
    ===============================
    Last edited by shohamlevy; 12-13-2005 at 01:07 PM.

Similar Threads

  1. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  2. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 11:34 PM
  3. Problems when making and installing Perl
    By wildhuman in forum Developers
    Replies: 10
    Last Post: 09-08-2006, 06:36 AM
  4. Replies: 21
    Last Post: 08-29-2006, 09:47 AM
  5. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •