Results 1 to 4 of 4

Thread: enable core? failed install

  1. #1
    Join Date
    Mar 2007
    Posts
    33
    Rep Power
    8

    Default enable core? failed install

    Hi!

    System: Ubuntu 7.04
    Version: 4.5.6
    Problem: after installing spell, I get a message that I need to enable the core:
    root@danis:/home/dani/Desktop/zcs# ./install.sh

    Operations logged to /tmp/install.log.10591
    Checking for existing installation...
    zimbra-ldap...NOT FOUND
    zimbra-logger...NOT FOUND
    zimbra-mta...NOT FOUND
    zimbra-snmp...NOT FOUND
    zimbra-store...NOT FOUND
    zimbra-apache...NOT FOUND
    zimbra-spell...NOT FOUND
    zimbra-core...NOT FOUND


    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

    License Terms for the Zimbra Collaboration Suite:
    http://www.zimbra.com/license/collab...cense_1.0.html


    Press Return to continue

    Checking for prerequisites...
    NPTL...FOUND
    sudo...FOUND sudo-1.6.8p12-4ubuntu5
    libidn11...FOUND libidn11-0.6.5-1build1
    curl...FOUND curl-7.15.5-1ubuntu2.1
    fetchmail...FOUND fetchmail-6.3.6-1ubuntu2
    libpcre3...FOUND libpcre3-6.7-1ubuntu2
    libgmp3c2...FOUND libgmp3c2-2:4.2.1+dfsg-4build1
    libexpat1...FOUND libexpat1-1.95.8-3.4build1
    libxml2...FOUND libxml2-2.6.27.dfsg-1ubuntu3
    libstdc++6...FOUND libstdc++6-4.1.2-0ubuntu4
    libstdc++5...FOUND libstdc++5-1:3.3.6-15ubuntu1
    openssl...FOUND openssl-0.9.8c-4build1

    Checking for installable packages

    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell


    Select the packages to install

    Install zimbra-ldap [Y]

    Install zimbra-logger [Y]

    Install zimbra-mta [Y]

    Install zimbra-snmp [Y]

    Install zimbra-store [Y]

    Install zimbra-spell [Y]
    Checking required space for zimbra-core
    checking space for zimbra-store

    Installing:
    zimbra-core
    zimbra-ldap
    zimbra-logger
    zimbra-mta
    zimbra-snmp
    zimbra-store
    zimbra-apache
    zimbra-spell

    The system will be modified. Continue? [N] Y

    Removing /opt/zimbra
    Installing packages

    zimbra-core......zimbra-core_4.5.6_GA_1044.UBUNTU6_i386.deb...done
    zimbra-ldap......zimbra-ldap_4.5.6_GA_1044.UBUNTU6_i386.deb...done
    zimbra-logger......zimbra-logger_4.5.6_GA_1044.UBUNTU6_i386.deb...done
    zimbra-mta......zimbra-mta_4.5.6_GA_1044.UBUNTU6_i386.deb...done
    zimbra-snmp......zimbra-snmp_4.5.6_GA_1044.UBUNTU6_i386.deb...done
    zimbra-store......zimbra-store_4.5.6_GA_1044.UBUNTU6_i386.deb...done
    zimbra-apache......zimbra-apache_4.5.6_GA_1044.UBUNTU6_i386.deb...done
    zimbra-spell......zimbra-spell_4.5.6_GA_1044.UBUNTU6_i386.deb...done
    Operations logged to /tmp/zmsetup.log.11797
    zimbra-core must be enabled.
    The log file contains:
    Getting installed packages
    checking isEnabled zimbra-core
    zimbra-core not in enabled cache
    enabled packages
    Newinstall enabling all installed packages
    zimbra-core must be enabled.
    So what is this? I have no clue what to do now. I searched but couldnt find any solution.
    Thx

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    We currently do not support ubuntu 7.
    That's why it's failing. Perhaps another member of the forums can help you hack it, if you need ubuntu 7 badly.

  3. #3
    Join Date
    Aug 2007
    Posts
    2
    Rep Power
    8

    Default

    To get past that stage you need a *dirty* hack. I haven't got it fully working but at least this will get it installed & config'ed.

    As soon as you see:
    "zimbra-core......zimbra-core_4.5.6_GA_1044.UBUNTU6_i386.deb...done"

    Act fast in a separate console:
    $ sudo nano +263 /opt/zimbra/libexec/zmsetup.pl

    Make it look like this:
    sub isEnabled {
    my $package = shift;
    detail("checking isEnabled $package");
    # if its already defined return;
    detail("$package is enabled"); #ADD THIS
    return 1; #AND THIS

    This will make install.sh *think* zimbra-core is 'enabled' and allow the script to continue.

    I have not yet been able to actually start zimbra successfully on feisty though.

    Hope this helps

  4. #4
    Join Date
    Mar 2007
    Posts
    33
    Rep Power
    8

    Default

    Yup... Thanx... Helped however didn't work. The core didnt start successfully. So disappointing. However I know that it requires lots of time and work to port this huge project to other platforms too and it is not an option to redo the work every half year to only ubuntu. I will get it working in a VM

Similar Threads

  1. Replies: 11
    Last Post: 02-23-2014, 12:08 PM
  2. Lotus migration
    By babou in forum Migration
    Replies: 15
    Last Post: 03-05-2007, 09:33 PM
  3. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM
  4. OS X Server 10.4.3 install issues
    By jono in forum Installation
    Replies: 10
    Last Post: 11-22-2005, 08:43 PM
  5. FC3 Install Hanging on core RPM
    By hawlej2 in forum Installation
    Replies: 4
    Last Post: 10-21-2005, 08:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •