Results 1 to 3 of 3

Thread: 5 beta 3: can't find Tie/Hash.pm (ubuntu606 fresh install)

  1. #1
    Join Date
    Jul 2007
    Posts
    6
    Rep Power
    8

    Default 5 beta 3: can't find Tie/Hash.pm (ubuntu606 fresh install)

    OK so I'm trying desperately to make the beta3 do an install, and not having much luck.

    Freshly wiped HD, slapped in Ubuntu 6.06 server ver., run apt-get update / upgrade, then add the needed libraries like libidn11 and libgmp3c2 via apt-get.

    Then run install.sh from the beta. and after adding the .deb packages, it fails rather consistently right here:

    Can't locate Tie/Hash.pm in @INC (@INC contains: /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi /opt/zimbra/zimbramon/lib/Zimbra/DB /opt/zimbra/zimbramon/lib/Zimbra/Mon /opt/zimbra/zimbramon/lib/Zimbra/SOAP /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi /opt/zimbra/zimbramon/lib /opt/zimbra/libexec /etc/perl /usr/local/lib/perl/5.8.7 /usr/local/share/perl/5.8.7 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 10.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 10.
    Compilation failed in require at /opt/zimbra/libexec/zmsetup.pl line 32.
    BEGIN failed--compilation aborted at /opt/zimbra/libexec/zmsetup.pl line 32.


    That would be perl erroring out, right? because it can't find it's module? So ... where do I get the module? CPAN doesn't seem to have a Hash.pm nor even a Tie::Hash. Err ... What, aside from Hash.pm, am I missing?

    TIA

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Code:
    apt-get install curl fetchmail libpcre3 libgmp3c2 libexpat1 libxml2 libtie-ixhash-perl

  3. #3
    Join Date
    Jul 2007
    Posts
    6
    Rep Power
    8

    Lightbulb that part, solved

    OK with some very general searching with apt-cache, I guessed perhaps "tie-ixhash-perl' was the package I was missing.

    Code:
    sudo apt-get install libtie-ixhash-perl
    which says it's also going to install perl. and perl-modules. Yeah, I can see how that could help.

    Anyway, haven't tested it yet but the install finished.

Similar Threads

  1. Replies: 3
    Last Post: 11-03-2007, 11:55 PM
  2. fresh install (both OS and Zimbra) but zimbra-spell fails
    By xtremetoonz in forum Installation
    Replies: 14
    Last Post: 09-09-2007, 01:34 AM
  3. Zimba Beta 5 OSX install failure
    By jjprusk in forum Installation
    Replies: 7
    Last Post: 07-24-2007, 10:06 AM
  4. 5.0 Beta Test Server Install - Sanity Check
    By soxfan in forum Installation
    Replies: 3
    Last Post: 06-07-2007, 11:53 AM
  5. RedHat EL4 fresh install
    By richard.bessey in forum Installation
    Replies: 1
    Last Post: 10-24-2006, 09:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •