Results 1 to 3 of 3

Thread: openldap glibc problems

  1. #1
    Join Date
    Sep 2005
    Posts
    42
    Rep Power
    10

    Default openldap glibc problems

    hey there,

    i am currently running centos 3.5 with the 2.6.10 kernel. i have previously succesfully installed milestone 1 on centos 4.1 with no problems, this time however i am trying to install zimbra m2 on a new dedicated server that i have.

    i recently installed zimbra on this server and during the installation problems encountered java runtime errors stating that it couldn't communicate to ldap on port 389. i then tried starting zimbra but the same java error was returned, ldap wasn't starting properly. i then su'd into the zimbra account and tried to run ldap, but ldap wouldnt start.

    using ldd it appears that i have an older version of glibc than that required by ldap.

    below is what ldd returned:

    Code:
    opt/zimbra/openldap/libexec/slapd: /lib/tls/libc.so.6: version `GLIBC_2.3.4' not found (required by /opt/zimbra/openldap/libexec/slapd) libsasl2.so.2 => /usr/local/lib/libsasl2.so.2 (0xb7fcd000) libssl.so.4 => /lib/libssl.so.4 (0xb7f98000) libcrypto.so.4 => /lib/libcrypto.so.4 (0xb7ea6000) libresolv.so.2 => /lib/libresolv.so.2 (0xb7e94000) libpthread.so.0 => /lib/tls/libpthread.so.0 (0xb7e84000) libc.so.6 => /lib/tls/libc.so.6 (0xb7d4b000) libdl.so.2 => /lib/libdl.so.2 (0xb7d48000) libgssapi_krb5.so.2 => /usr/kerberos/lib/libgssapi_krb5.so.2 (0xb7d34000) libkrb5.so.3 => /usr/kerberos/lib/libkrb5.so.3 (0xb7cd6000) libcom_err.so.3 => /usr/kerberos/lib/libcom_err.so.3 (0xb7cd4000) libk5crypto.so.3 => /usr/kerberos/lib/libk5crypto.so.3 (0xb7cc2000) libz.so.1 => /usr/local/lib/libz.so.1 (0xb7cb1000) /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0xb7feb000)
    after quering rpm for what glic version i have it appears that i have: glibc-2.3.2-95.37.

    when trying to update glibc via yum it states that it is the latest version.

    please help.

    much appreciated,

    josh

    btw i understand that centos 3.5 isn't a supported platform, but because this is a dedicated server I have no option to change distribution/upgrade.
    Last edited by joshuamorgan; 12-14-2005 at 08:54 PM.

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default Os and zimbra version

    I'm not sure why you're trying to use a newer version of zimbra with an older version of your OS, but it's not going to work. Since you've already gotten it running on CentOs 4.1, you should upgrade your other server.

    Or, build from source, but that's likely to be more trouble than simply updating the box.

  3. #3
    Join Date
    Sep 2005
    Posts
    42
    Rep Power
    10

    Default

    hmm ok. the reason i am using it on centos 3.5 is because it is a dedicated server with BurstNET and the version of centos they install is 3.5.

    i might try building from source if that resolves the issue.

Similar Threads

  1. Replies: 6
    Last Post: 01-02-2008, 02:17 PM
  2. Custom LDAP Server
    By KermitTheFragger in forum Developers
    Replies: 22
    Last Post: 12-30-2007, 01:48 PM
  3. Restarting and german 'umlaut' problems
    By Oswald-Kolle in forum Installation
    Replies: 3
    Last Post: 05-29-2007, 02:09 AM
  4. iSync Connector / Apple Address Book Problems
    By jrosen in forum CalDAV / CardDAV / iSync
    Replies: 11
    Last Post: 04-16-2007, 03:40 PM
  5. Problems with public Subversion repository
    By dwhite in forum Developers
    Replies: 0
    Last Post: 11-18-2006, 11:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •