Results 1 to 4 of 4

Thread: Compilation error during installation

  1. #1
    Join Date
    Jul 2007
    Posts
    8
    Rep Power
    8

    Default Compilation error during installation

    I attempted to install 4.5.7 and 4.5.6 on a Debian Etch server running i386 kernel. The hardware is amd64. I am following the HowTo for installing 3.1 binaries on Etch.

    When I run sh install.sh I get the following output:

    <--snip-->
    The system will be modified. Continue? [N] y

    Removing /opt/zimbra
    Installing packages

    zimbra-core......zimbra-core_4.5.6_GA_1044.DEBIAN3.1_i386.deb...done
    zimbra-ldap......zimbra-ldap_4.5.6_GA_1044.DEBIAN3.1_i386.deb...done
    zimbra-logger......zimbra-logger_4.5.6_GA_1044.DEBIAN3.1_i386.deb...done
    zimbra-mta......zimbra-mta_4.5.6_GA_1044.DEBIAN3.1_i386.deb...done
    zimbra-snmp......zimbra-snmp_4.5.6_GA_1044.DEBIAN3.1_i386.deb...done
    zimbra-store......zimbra-store_4.5.6_GA_1044.DEBIAN3.1_i386.deb...done
    zimbra-apache......zimbra-apache_4.5.6_GA_1044.DEBIAN3.1_i386.deb...done
    zimbra-spell......zimbra-spell_4.5.6_GA_1044.DEBIAN3.1_i386.deb...done
    Can't locate Tie/Hash.pm in @INC (@INC contains: /opt/zimbra/zimbramon/lib/i386-linux-thread-multi /opt/zimbra/zimbramon/lib/Zimbra/DB /opt/zimbra/zimbramon/lib/Zimbra/Mon /opt/zimbra/zimbramon/lib/Zimbra/SOAP /opt/zimbra/zimbramon/lib /opt/zimbra/libexec /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 10.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 10.
    Compilation failed in require at /opt/zimbra/libexec/zmsetup.pl line 32.
    BEGIN failed--compilation aborted at /opt/zimbra/libexec/zmsetup.pl line 32.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Do you have the perl modules installed? Search the forums for Tie/Hash.pm - the answer is in the search results.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jul 2007
    Posts
    8
    Rep Power
    8

    Default

    Thanks. I was using the wrong search box and not finding any results. The top right search box doesn't seem to search the forums properly.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by vclark View Post
    The top right search box doesn't seem to search the forums properly.
    It's not obvious but that box does an initial search of the Zimbra web site.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Spam training problem...
    By TaskMaster in forum Installation
    Replies: 2
    Last Post: 05-08-2007, 10:49 AM
  2. Installation Failed
    By freit5 in forum Installation
    Replies: 2
    Last Post: 08-18-2006, 12:38 AM
  3. Installation fails on zimbra-store
    By wyleyrabbit in forum Installation
    Replies: 8
    Last Post: 01-15-2006, 08:19 AM
  4. Replies: 16
    Last Post: 01-05-2006, 09:55 AM
  5. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 09:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •