Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: [SOLVED] Disable 8BITMIME in PostFix?

  1. #1
    Join Date
    Sep 2007
    Location
    New York, NY
    Posts
    15
    Rep Power
    8

    Question [SOLVED] Disable 8BITMIME in PostFix?

    I'm relaying all my outbound mail through an Exchange 2003 server, which advertises 8BITMIME, but when sending to certain domains which don't support it, returns a "Body type not supported" message. (seems Exchange2003 doesn't handle translating to 8bit->7bit properly)

    Is there a simple way to turn off 8BitMime entirely in Postfix, so that even though Exchange allows it, it will send everything in 7bit?

    Thanks in advance!

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Quote Originally Posted by RobLarose
    Is there a simple way to turn off 8BitMime entirely in Postfix, so that even though Exchange allows it, it will send everything in 7bit?
    Well there's a command for the exact opposite of what you want to do; added in 2.1? I think. It disables the conversion of 8BIT > 7BIT format, so that it uses 8bit only. (disable_mime_output_conversion the default is no)
    But you want "to turn off 8BitMime entirely"... not force the use of it, so you can pretty much ignore that.

    Now the idea-(though this would kill 8bit in exchange)
    -leaving the above alone so that postfix still 8bit > 7bit
    -turn off ESMTP verbs in exchange
    How to turn off ESMTP verbs in Exchange 2000 Server and in Exchange Server 2003
    (for those that find this later there's also How to turn off 8BITMIME in Windows 2000 and in Windows Server 2003 SMTP service)
    -thus 8bit will not be advertised on the exchange box, so the postfix box will send in 7bit
    -then there's no downgrade of any type on the exchange box taking place!

    So your mail looks like:
    postfix internal: 8bit > 7bit
    postfix external to exchange: 7bit
    exchange to some other domain: 7bit

    It's not really your fault that the other end doesn't take 8bit-they really should upgrade. But at the same time exchange should be better backwards compatible...I don't feel like wasting my time reading into MS shortcommings...

    Alternatively, you could force exchange to use of the simpler HELO command instead, or the more complicated EHLO scheme; by creating a SMTP connector for just the domains that are failing.
    How to configure the SMTP connector in Exchange 200x
    Quote Originally Posted by RFC2821 sec 3.2
    Servers MUST NOT return the extended EHLO-style response to a HELO command.
    While I hate to blame the box that works...on the Postfix helo front there's also smtpd_recipient_restrictions of always_send_ehelo=yes, never_send_ehelo=yes, (and think there's even the opposites never_send_helo & always_send_helo - which would be the same as always send ehelo so I don't know why this redundancy)

    EDIT:

    smtpd_discard_ehlo_keywords -A case insensitive list of EHLO keywords (pipelin- ing, starttls, auth, etc.) that the SMTP server will not send in the EHLO response to any remote SMTP client.

    or the more complicated:
    smtpd_discard_ehlo_keyword_address_maps - Lookup tables, indexed by the remote SMTP client address, with case insensitive lists of EHLO keywords (pipelining, starttls, auth, etc.) that the SMTP server will not send in the EHLO response to a remote SMTP client.


    Note: smtpd_helo_required is not what your looking for; even though it sound's like it would be. It has to do with requiring that the client sends the HELO/EHLO command before sending the MAIL FROM/ETRN command. This is off by default.
    Last edited by mmorse; 09-20-2007 at 09:57 AM.

  3. #3
    Join Date
    Sep 2007
    Location
    New York, NY
    Posts
    15
    Rep Power
    8

    Default Exchange SMTP connector?

    Your last about setting up an exchange connector for HELO for the affected domains wouldn't work, because it would still rely on Exchange to have converted from 8-bit (from Zimbra) to 7-bit, right?

    Could i just edit the main.cf in /opt/zimbra/postfix-2.2.9/conf/ and add the never_send_ehlo option to the smtp command? Would that disable EHLO in *all* mail sent from Zimbra?

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Well I guess my question would be-
    Though you did say
    Quote Originally Posted by RobLarose
    (seems Exchange2003 doesn't handle translating to 8bit->7bit properly)
    I couldn't find any info on the conversion process itself being broken, I thought it was more of an issue on the outgoing communication protocol linkage, so I just ran off a list of possible methods where exchange would never deal with 8bit.
    Could you point me at some docs about the converter process in exchange being broken?

    Try whatever suits you best; though the title of this thread is "Disable 8BITMIME in Postfix" I always hate blaming the box that technically works as it should ya know?

    The problem is that even with "smtp_always_send_ehlo = no" postfix will still send EHLO when the word "ESMTP" appears in the opposite server's greeting banner
    Last edited by mmorse; 10-02-2007 at 08:09 PM.

  5. #5
    Join Date
    Sep 2007
    Location
    New York, NY
    Posts
    15
    Rep Power
    8

    Default Exchange blows

    Nothing official from MS, but lots of complaints in forums about it.. a 5.6.1 "body type not supported" error gets generated. One example of a discussion about it:

    http://www.ureader.com/message/1329553.aspx

    "When Exchange 2000/2003 receives a message in 8bit, it will not downgrade
    this mail to 7bit when he needs to forward this to a system which does not
    support 8bit mime...."

    Their suggestion is the same as yours -- disable advertising ESMTP verbs. I hate dicking around in AD with ADSIEdit though. :-(

  6. #6
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    And that's from 05 no less-why they couldn't patch exchange 03 (before they got to 07) I don't know; guess they didn't find enough of a flaw to do anything besides give a workaround to disable ESMTP...

    Brings up a point I just added in after I hit 'submit':
    Quote Originally Posted by mmorse View Post
    Try whatever suits you best; though the title of this thread is "Disable 8BITMIME in Postfix" I always hate blaming the box that technically works as it should ya know?
    + If you fix it on the exchange box; In addition to zimbra, any other relays that you do through it will get solved too.
    Last edited by mmorse; 09-20-2007 at 10:10 AM.

  7. #7
    Join Date
    Sep 2007
    Location
    New York, NY
    Posts
    15
    Rep Power
    8

    Default

    A solid point. Okay, I guess I'll mess with AD. ::shudder::

  8. #8
    Join Date
    Sep 2007
    Location
    New York, NY
    Posts
    15
    Rep Power
    8

    Default

    Actually, I take that back. There are all sorts of Exchange warnings about tampering with ESMTP making the exchange servers incapable of talking to each other. I have another Exchange server in my other office that needs to keep working. :-(

    Any other ideas? what about just changing postfix's main.cf?

    --Rob

  9. #9
    Join Date
    Sep 2007
    Location
    New York, NY
    Posts
    15
    Rep Power
    8

    Default Just mail out of Zimbra?

    So I don't have a good solution for this yet on the postfix side, and since the problem is with Exchange, can anyone tell me how to just let Zimbra route its own mail out to the internet?

    So I want to continue receiving mail for Zimbra mailboxes @mydomain.com (this is happening now, per the split domain wiki article, with Zimbra as the secondary)

    I want to send mail for addresses @mydomain.com that do NOT have Zimbra mailboxes to exchangeserver.mydomain.com. (this is happening now, per that same wiki)

    But I want Zimbra to go ahead and do the lookup and deliver internet-bound mail itself (right now, all outbound mail is being routed through exchangeserver.mydomain.com)

    I assume this is as simple as creating a mail route on postfix? Or is it done through Zimbra itself somehow?

    Thanks in advance for your ideas!

  10. #10
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Split Domain - Configuring_Zimbra_as_the_Secondary_System - ZimbraWiki

    Ok, so in order to continue forwarding for accounts that don't exist in zimbra your leaving this part alone:
    zmprov md example.com zimbraMailCatchAllAddress @domain.com
    zmprov md example.com zimbraMailCatchAllForwardingAddress @domain.com
    zmprov md example.com zimbraMailTransport smtp:exchange.domain.com
    Just undo a part of what you did before, ie zimbraMtaDnsLookupsEnabled TRUE and remove the relay for external delivery-I assume you did:
    zmprov mcf zimbraMtaRelayHost exchange.domain.com
    zmprov mcf zimbraMtaDnsLookupsEnabled FALSE
    You can also enable dns lookups, and remove the relay for external delivery from the admin console gui > global settings mta tab (or the individual servers tab's, but use global settings if you only had one zcs box in the first place). -You shouldn't be messing with the 'webmail mta' blank which is also in that same area. Then zmcontrol stop/start.
    Last edited by mmorse; 09-24-2007 at 06:00 PM.

Similar Threads

  1. Replies: 3
    Last Post: 11-03-2007, 11:55 PM
  2. Sending Mail! Still something wrong!
    By BlueHaven in forum Installation
    Replies: 11
    Last Post: 08-02-2007, 05:19 PM
  3. Error while trying to view queues
    By SpEnTBoY in forum Administrators
    Replies: 17
    Last Post: 05-08-2007, 10:43 AM
  4. Cannot send mail.
    By jeremyshoe in forum Installation
    Replies: 7
    Last Post: 10-17-2006, 10:42 PM
  5. unable to restart zimbra after reboot
    By droefs in forum Administrators
    Replies: 28
    Last Post: 04-16-2006, 03:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •