Results 1 to 4 of 4

Thread: Installation Issues - SLES 10_Zimbra 5.0 Beta 3

  1. #1
    Join Date
    Sep 2007
    Posts
    1
    Rep Power
    8

    Default Installation Issues - SLES 10_Zimbra 5.0 Beta 3

    I'm building a migration test server currently running SLES 10_SP1-32bit
    attempting to install Zimbra 5.0_beta3 on.

    During the install I have received multiple times the error, "sudo: /etc/sudoers is mode 0640, should be 0440 Failed to start slapd. Attempting debug start to determine error."
    I have attempted the mentioned "solution" posted in another post of chmod /etc/sudoers yet has failed to work.


    I have included a few logs that hopefully will explain my issue.


    #zmsetup.log.###
    Code:
    Getting installed packages
    checking isEnabled zimbra-core
    zimbra-core not in enabled cache
    enabled packages
    Getting local config zimbra_server_hostname
    Getting local config ldap_url
    zimbra_server_hostname contained in ldap_url checking ldap status
    Checking ldap status
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    Starting ldap
    *** Running as zimbra user: /opt/zimbra/openldap/sbin/slapindex -b '' -q -f /opt/zimbra/conf/slapd.conf
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    Failed to start slapd.  Attempting debug start to determine error.
    
    ldap_bind: Can't contact LDAP server (-1)
    ldap_bind: Can't contact LDAP server (-1)
    ldap_bind: Can't contact LDAP server (-1)
    ldap_bind: Can't contact LDAP server (-1)
    ldap_bind: Can't contact LDAP server (-1)
    ls: /opt/zimbra/lib/conf/*ldif: No such file or directory
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    *** Running as zimbra user: /opt/zimbra/bin/ldap start
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    Failed to start slapd.  Attempting debug start to determine error.
    
    ldap startup failed with exit code 256
    Setting defaults...
    Setting local config zimbra_java_home to /opt/zimbra/java
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_java_home='/opt/zimbra/java'
    checking isEnabled zimbra-store
    zimbra-store not in enabled cache
    enabled packages
    zimbra_server_hostname contained in ldap_url checking ldap status
    Checking ldap status
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    Starting ldap
    *** Running as zimbra user: /opt/zimbra/openldap/sbin/slapindex -b '' -q -f /opt/zimbra/conf/slapd.conf
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    *** Running as zimbra user: /opt/zimbra/bin/ldap start
    sudo: /etc/sudoers is mode 0640, should be 0440
    ldap startup failed with exit code 33280
    checking isEnabled zimbra-ldap
    zimbra-ldap not in enabled cache
    enabled packages
    zimbra_server_hostname contained in ldap_url checking ldap status
    Checking ldap status
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    Starting ldap
    *** Running as zimbra user: /opt/zimbra/openldap/sbin/slapindex -b '' -q -f /opt/zimbra/conf/slapd.conf
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
    sudo: /etc/sudoers is mode 0640, should be 0440
    
    Session terminated, killing shell... ...killed.



    #install.log.###
    Code:
    Preparing packages for installation...
    zimbra-core-5.0.0_BETA3_1276.SuSEES10-20070822161025
    zimbra                    0:off  1:off  2:off  3:on   4:off  5:on   6:off
    mkdir: cannot create directory `/opt/zimbra/.ssh': File exists
    Loading classes to share ... done.
    Rewriting and unlinking classes ... done.
    Calculating hash values for String objects .. done.
    Calculating fingerprints ... done.
    Removing unshareable information ... done.
    Moving pre-ordered read-only objects to shared space at 0x94060000 ... done.
    Moving read-only objects to shared space at 0x9447aa48 ... done.
    Moving common symbols to shared space at 0x9447c3c0 ... done.
    Moving remaining symbols to shared space at 0x94543d48 ... done.
    Moving string char arrays to shared space at 0x94544980 ... done.
    Moving additional symbols to shared space at 0x945da9d8 ... done.
    Read-only space ends at 0x946406f0, 6162160 bytes.
    Moving pre-ordered read-write objects to shared space at 0x94860000 ... done.
    Moving read-write objects to shared space at 0x94ed0fa0 ... done.
    Moving String objects to shared space at 0x94f0e208 ... done.
    Read-write space ends at 0x94f51d68, 7282024 bytes.
    Updating references to shared objects ... done.
    
    Preparing packages for installation...
    zimbra-ldap-5.0.0_BETA3_1276.SuSEES10-20070822161025
    chown: cannot access `/opt/zimbra/a*': No such file or directory
    chown: cannot access `/opt/zimbra/perdition-1.17.1': No such file or directory
    chown: cannot access `/opt/zimbra/apache-tomcat-*': No such file or directory
    chown: cannot access `/opt/zimbra/jetty-*': No such file or directory
    mv: cannot stat `/opt/zimbra/openldap-data/log.*': No such file or directory
    Preparing packages for installation...
    zimbra-logger-5.0.0_BETA3_1276.SuSEES10-20070822161025
    Preparing packages for installation...
    zimbra-mta-5.0.0_BETA3_1276.SuSEES10-20070822161025
    umount2: No such file or directory
    umount: /opt/zimbra/amavisd/tmp: not found
    chown: cannot access `/opt/zimbra/perdition-1.17.1': No such file or directory
    chown: cannot access `/opt/zimbra/apache-tomcat-*': No such file or directory
    chown: cannot access `/opt/zimbra/jetty-*': No such file or directory
    Preparing packages for installation...
    zimbra-snmp-5.0.0_BETA3_1276.SuSEES10-20070822161025
    Preparing packages for installation...
    zimbra-store-5.0.0_BETA3_1276.SuSEES10-20070822161025
    ln -s /opt/zimbra/jetty-6.1.5 /opt/zimbra/jetty
    Relinking mailboxd to /opt/zimbra/jetty-6.1.5
    Preparing packages for installation...
    zimbra-apache-5.0.0_BETA3_1276.SuSEES10-20070822161025
    Preparing packages for installation...
    zimbra-spell-5.0.0_BETA3_1276.SuSEES10-20070822161025
    Preparing packages for installation...
    zimbra-proxy-5.0.0_BETA3_1276.SuSEES10-20070822161025
    malbec:/tmp # cat install.log.26715
    COMMAND: zmlocalconfig -s | sed -e "s/ = \(.*\)/=\'\1\'/" > /opt/zimbra/.saveconfig/config.save
    COMMAND: zmcontrol shutdown
    Host malbec.reliablenetworks.com
            Stopping stats...Done
            Stopping mta...Done
            Stopping spell...Done
            Stopping snmp...Done
            Stopping antivirus...Done
            Stopping antispam...Done
            Stopping imapproxy...Done
            Stopping logger...Done
            Stopping ldap...Done
    Preparing packages for installation...
    zimbra-core-5.0.0_BETA3_1276.SuSEES10-20070822161025

  2. #2
    Join Date
    Sep 2007
    Posts
    5
    Rep Power
    8

    Default I have got the same problem

    I have got the same problem but no one of the solutions on line were effective. This is the error that I get when trying to install
    Failed to start slapd. Attempting debug start to determine error.
    daemon: bind(7) failed errno=98 (Address already in use)
    slap_open_listener: failed on ldap://mail.webformer.local:389

    I tried stopping everything on port 389 but nothing stays on 389 until zimbra uses it, so I cannot stop it
    I tried changing user permission for zimbra
    I tried looking for slapd daemon, but nothing.
    My os is ubuntu server 7.04 and I had to change lsb-release and move debian_version during installation. I cannot find any help. I am getting crazy. Please help me.

  3. #3
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    please run:

    lsof | grep TCP | grep 389

  4. #4
    Join Date
    Jul 2007
    Posts
    1
    Rep Power
    8

    Default why.. somehow it worked

    I too had this problem. I had tried changing the permissions a few times before I ran the install. The install would still fail.I don't know why or how this worked but this is what I did. I ran /opt/zimbra/libexec/zmsetup.pl. From another console about 20-30 seconds in, I changed the permissions while the install was running.

Similar Threads

  1. Outlook 2007 Beta Overview
    By GregA in forum Zimbra Connector for Outlook
    Replies: 19
    Last Post: 03-03-2008, 03:24 PM
  2. Migrating from Zimbra 4.5.x to 5.0 beta?
    By jbwiv in forum Administrators
    Replies: 2
    Last Post: 11-16-2007, 10:24 AM
  3. [SOLVED] ZCS 5.0 Beta Testing
    By link915 in forum Administrators
    Replies: 7
    Last Post: 09-20-2007, 12:34 PM
  4. ZCS 5.0 Beta 2 is Out!
    By jholder in forum Announcements
    Replies: 0
    Last Post: 07-25-2007, 11:54 AM
  5. 5.0 Beta Test Server Install - Sanity Check
    By soxfan in forum Installation
    Replies: 3
    Last Post: 06-07-2007, 10:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •