Results 1 to 3 of 3

Thread: [SOLVED] logger & snmp not starting

  1. #1
    Join Date
    Sep 2007
    Posts
    2
    Rep Power
    8

    Default [SOLVED] logger & snmp not starting

    Hi everybody Great forum you have here it has already helped me a lot !

    Anyway, i'm installing zimbra on some machine, and so i did.

    The machine: a FreeBSD 6.2, zimbra Release 4.0.3_GA_411.FreeBSD

    Everything went fine, BUT (!!) when i do a zmcontrol status, i received this "error":
    Code:
    [zimbra@galileo ~]$ bin/zmcontrol status
    Host xxx.xxx
            antispam                Running
            antivirus               Running
            ldap                    Running
            logger                  Stopped
                    zmlogswatchctl is not running
            mailbox                 Running
            mta                     Running
            snmp                    Stopped
                    swatch is not running
            spell                   Running
    and i was requested to let everything running.

    So, i started, but i found a little problem which i don't understand:

    Code:
    [zimbra@galileo ~]$ tail /tmp/logswatch.out
    Can't locate Date/Parse.pm in @INC (@INC contains: /usr/local/lib/perl5/5.8.8/BSDPAN /usr/local/lib/perl5/site_perl/5.8.8/mach /usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/5.8.8/mach /usr/local/lib/perl5/5.8.8 .) at /opt/zimbra/libexec/logswatch line 347.
    BEGIN failed--compilation aborted at /opt/zimbra/libexec/logswatch line 347.
    I guess that would be the reason why swatch isn't running? Really don't know what to do now, any suggestion?

    (snmp is next :P)

    If you need any more info, please reply

    Thanks !


    PD:

    zmlogswatchctl start command:

    Code:
    [zimbra@galileo ~]$ bin/zmlogswatchctl start
    + BASE=/opt/zimbra
    + CONFIG=/opt/zimbra/conf/logswatchrc
    + PIDFILE=/opt/zimbra/log/logswatch.pid
    + '[' -f /opt/zimbra/log/logswatch.pid ']'
    ++ cat /opt/zimbra/log/logswatch.pid
    + PID=29111
    + source /opt/zimbra/.bashrc
    bin/zmlogswatchctl: line 36: /opt/zimbra/.bashrc: No such file or directory
    + case "$1" in
    + '[' -f /opt/zimbra/conf/logswatchrc ']'
    + PID=35311
    + chmod 777 /tmp/logswatch.out
    + /opt/zimbra/libexec/logswatch --config-file=/opt/zimbra/conf/logswatchrc --use-cpan-file-tail --script-dir=/tmp -t /var/log/zimbra.log
    + echo 35311
    + '[' x35311 '!=' x ']'
    + kill -0 35311
    + exit 0
    [zimbra@galileo ~]$
    Last edited by unreal4u; 09-29-2007 at 08:04 PM.

  2. #2
    Join Date
    Sep 2007
    Posts
    2
    Rep Power
    8

    Default

    SOLVED !

    some perl module (Date::Parse) was not installed, so i installed it and everything is running smoothly now, snmp & logger

    Greetings

  3. #3
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    -marking as solved -even though you've already changed the inside title, that way it'll show up when viewing threads

Similar Threads

  1. Mailbox and logger not starting - SLES9 M3 Beta436
    By DanielP in forum Installation
    Replies: 49
    Last Post: 08-25-2008, 04:23 AM
  2. postfix stopped
    By riegersteve in forum Administrators
    Replies: 1
    Last Post: 05-15-2007, 04:25 PM
  3. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  4. Cannot start logger or snmp
    By hikenboots in forum Administrators
    Replies: 5
    Last Post: 01-16-2006, 02:39 PM
  5. Zimbra on Debian?
    By omry_y in forum Installation
    Replies: 25
    Last Post: 11-04-2005, 11:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •