Results 1 to 9 of 9

Thread: [SOLVED] Unable to receive email 4.5.6:

  1. #1
    Join Date
    Sep 2007
    Posts
    80
    Rep Power
    8

    Default [SOLVED] Unable to receive email 4.5.6:

    All receiving email get's deferred:


    Sep 29 09:32:03 mailer postfix/smtpd[3704]: connect from njbrmta2.airbridge.net[66.174.76.139]
    Sep 29 09:32:03 mailer postfix/smtpd[3704]: setting up TLS connection from njbrmta2.airbridge.net[66.174.76.139]
    Sep 29 09:32:03 mailer postfix/smtpd[3704]: TLS connection established from njbrmta2.airbridge.net[66.174.76.139]: TLSv1 with cipher EDH-RSA-DES-CBC3-SHA (168/168 bits)
    Sep 29 09:32:04 mailer postfix/smtpd[3704]: 30AFDCB397: client=njbrmta2.airbridge.net[66.174.76.139]
    Sep 29 09:32:04 mailer postfix/cleanup[3734]: 30AFDCB397: message-id=<25742150.1191083522989.JavaMail.root@njbr-wigdb2>
    Sep 29 09:32:04 mailer postfix/qmgr[3455]: 30AFDCB397: from=, size=718, nrcpt=1 (queue active)
    Sep 29 09:32:04 mailer postfix/smtpd[3704]: disconnect from njbrmta2.airbridge.net[66.174.76.139]
    Sep 29 09:32:04 mailer amavis[3152]: (03152-01) ESMTP::10024 /opt/zimbra/amavisd/tmp/amavis-20070929T093204-03152: -> SIZE=718 Received: from mailer.myzimbradomain.com ([127.0.0.1]) by localhost (mailer.myzimbradomain.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for ; Sat, 29 Sep 2007 09:32:04 -0700 (PDT)
    Sep 29 09:32:04 mailer amavis[3152]: (03152-01) Checking: lV8S6-rwUIq1 [66.174.76.139] ->
    Sep 29 09:32:05 mailer zmtomcatmgr[3787]: status requested
    Sep 29 09:32:05 mailer zmtomcatmgr[3787]: status OK
    Sep 29 09:32:05 mailer zimbramon[3665]: 3665:info: 2007-09-29 09:32:01, STATUS: mailer.myzimbradomain.com: antispam: Running
    Sep 29 09:32:05 mailer zimbramon[3665]: 3665:info: 2007-09-29 09:32:01, STATUS: mailer.myzimbradomain.com: antivirus: Running
    Sep 29 09:32:05 mailer zimbramon[3665]: 3665:info: 2007-09-29 09:32:01, STATUS: mailer.myzimbradomain.com: ldap: Running
    Sep 29 09:32:05 mailer zimbramon[3665]: 3665:info: 2007-09-29 09:32:01, STATUS: mailer.myzimbradomain.com: logger: Running
    Sep 29 09:32:05 mailer zimbramon[3665]: 3665:info: 2007-09-29 09:32:01, STATUS: mailer.myzimbradomain.com: mailbox: Running
    Sep 29 09:32:05 mailer zimbramon[3665]: 3665:info: 2007-09-29 09:32:01, STATUS: mailer.myzimbradomain.com: mta: Running
    Sep 29 09:32:05 mailer zimbramon[3665]: 3665:info: 2007-09-29 09:32:01, STATUS: mailer.myzimbradomain.com: snmp: Running
    Sep 29 09:32:05 mailer zimbramon[3665]: 3665:info: 2007-09-29 09:32:01, STATUS: mailer.myzimbradomain.com: spell: Running
    Sep 29 09:32:05 mailer zimbramon[3665]: 3665:info: 2007-09-29 09:32:01, STATUS: mailer.myzimbradomain.com: stats: Stopped
    Sep 29 09:32:05 mailer CRON[3664]: (pam_unix) session closed for user zimbra
    Sep 29 09:32:06 mailer postfix/smtpd[3837]: connect from localhost.localdomain[127.0.0.1]
    Sep 29 09:32:06 mailer postfix/smtpd[3837]: D4D67CB3A4: client=localhost.localdomain[127.0.0.1]
    Sep 29 09:32:06 mailer postfix/cleanup[3734]: D4D67CB3A4: message-id=<25742150.1191083522989.JavaMail.root@njbr-wigdb2>
    Sep 29 09:32:06 mailer postfix/qmgr[3455]: D4D67CB3A4: from=, size=1339, nrcpt=1 (queue active)
    Sep 29 09:32:06 mailer amavis[3152]: (03152-01) FWD via SMTP: -> ,BODY=7BIT 250 2.6.0 Ok, id=03152-01, from MTA([127.0.0.1]:10025): 250 Ok: queued as D4D67CB3A4
    Sep 29 09:32:06 mailer amavis[3152]: (03152-01) Passed CLEAN, [66.174.76.139] [66.174.76.21] -> , Message-ID: <25742150.1191083522989.JavaMail.root@njbr-wigdb2>, mail_id: lV8S6-rwUIq1, Hits: -2.506, size: 718, queued_as: D4D67CB3A4, 2368 ms
    Sep 29 09:32:06 mailer postfix/smtp[3754]: 30AFDCB397: to=, relay=127.0.0.1[127.0.0.1], delay=2, status=sent (250 Ok: queued as D4D67CB3A4)
    Sep 29 09:32:06 mailer postfix/qmgr[3455]: 30AFDCB397: removed
    Sep 29 09:32:06 mailer postfix/smtpd[3837]: disconnect from localhost.localdomain[127.0.0.1]
    Sep 29 09:32:06 mailer postfix/lmtp[3838]: D4D67CB3A4: to=, relay=none, delay=0, status=deferred (connect to mailer.myzimbradomain.com[71.245.107.235]: Connection refused)

    I am able to send fine.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by cornbread View Post
    to=, relay=none, delay=0, status=deferred (connect to mailer.myzimbradomain.com[71.245.107.235]: Connection refused)
    What else is in the logs? Is there any reason the connection might be refused? Are your DNS A & MX records correct? Is your hosts file correct? Is there any firewall? Are you behind a router? If so, you'll need a Split DNS setup.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    BTW, your other post was attached to a thread that's almost two years old - I've deleted it, don't duplicate your posts.

    In the other thread you asked what the answer was, it was a DNS issue. Please search the forums or read the wiki article about split dns.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    Sep 2007
    Posts
    80
    Rep Power
    8

    Default Network settings

    I have several boxes set up. windows 2k3 server primary dns server is off-site. Mail server is at ip 192.168.0.17 internal secondary dns server(also windows 2k3 dns) is on site 192.168.0.3. Both are behind routers.

    I don't understand why i can't just tell my zimbra mail server to receive mail. it is getting to the box just fine.

  5. #5
    Join Date
    Sep 2007
    Posts
    80
    Rep Power
    8

    Default ?

    I modified my resolv.conf to point to my internal secondary dns server and now can receive mail but when i try to send. the messages get deferred saying:

    name service error for name=localhost type=a: host not found

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by cornbread View Post
    I don't understand why i can't just tell my zimbra mail server to receive mail. it is getting to the box just fine.
    Have you looked at the Split DNS article in the wiki? Postfix requires that it's able to resolve the LAN IP address via DNS, you need A & MX records on your LAN DNS server to achieve that.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by cornbread View Post
    name service error for name=localhost type=a: host not found
    Read the Split DNS article for the answer.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Sep 2007
    Posts
    80
    Rep Power
    8

    Default [solved]

    fixed it. i have concluded that postfix is stupid.

    Thanks for the help...

  9. #9
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

Similar Threads

  1. cann't receive email at remote network, but send is ok
    By koolokamba in forum Administrators
    Replies: 4
    Last Post: 09-15-2007, 07:27 PM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  3. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 03:56 AM
  4. Can't receive email
    By Phantasmagoria in forum Installation
    Replies: 4
    Last Post: 11-23-2005, 01:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •