Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: [SOLVED] 5.0 RC1 - mailboxd won't start after a reboot

  1. #11
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Yeah, I encountered this on the demo. It seems that on a mac, rerunning the install script doesn't fix it. I would recommend that mac users try the above command and see what happens.

    Because the mac users are still in the dark, I'm not going to mark this as solved until we get a solution for them.

  2. #12
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Actually, I'm wrong. Mac users try this:
    zmprov -l ms `zmhostname` +zimbraServiceInstalled mailbox
    Last edited by jholder; 10-19-2007 at 10:30 PM.

  3. #13
    Join Date
    Sep 2006
    Posts
    252
    Rep Power
    9

    Default

    Quote Originally Posted by jholder View Post
    Nice find. When I was setting up the Zimbra hosted demo, I ran into this twice.

    Not once. Twice

    I thought I was going crazy, because the "mailbox" service wasn't showing as installed. When I mentioned this to a few colleagues, I'm not sure the believed me. How can the Mailbox service disappear??? heh

    Well, here's the bug. It's true. You have to run the install.sh again to get it back.

    Bug 20765 - zimbraServicedInstaled is not set for mailbox

    Best,
    john
    This is off-topic but what kind of hardware/os are you guys using for the hosted demo?

  4. #14
    Join Date
    Oct 2007
    Posts
    67
    Rep Power
    8

    Default

    Hi guys,

    Just an update. I have replicated this time and time again, I took a log of things this time though. I wonder if you have anymore input on this?

    Basically I started tracking the log file, and after changing the "DNS lookup" option in the MTA tab using the admin console, nothing happened at first and things continued to work. Two minutes later this appeared in the logs:

    zimbra.log:

    Oct 22 16:05:58 Fedora7 zmmailboxdmgr[17522]: threaddump requested
    Oct 22 16:05:58 Fedora7 zmmailboxdmgr[16260]: sending SIQUIT to mailboxd/JVM process 16261
    Oct 22 16:06:00 Fedora7 zmmailboxdmgr[17529]: stop requested
    Oct 22 16:06:00 Fedora7 zmmailboxdmgr[17529]: waiting for manager process 16260 to die
    Oct 22 16:06:00 Fedora7 zmmailboxdmgr[16260]: shutdown requested, sending TERM signal to 16261
    Oct 22 16:06:02 Fedora7 zmmailboxdmgr[16260]: mailboxd/JVM process exited (waitpid expected 16261 got 16261)
    Oct 22 16:06:02 Fedora7 zmmailboxdmgr[16260]: manager woke up from wait on mailboxd/JVM with pid 16261
    Oct 22 16:06:02 Fedora7 zmmailboxdmgr[17529]: manager process 16260 died, shutdown completed
    Oct 22 16:06:07 Fedora7 zimbramon[17559]: 17559:info: 2007-10-22 16:06:02, STATUS: zimbra.fedora7.vm: antispam: Running
    Oct 22 16:06:07 Fedora7 zimbramon[17559]: 17559:info: 2007-10-22 16:06:02, STATUS: zimbra.fedora7.vm: antivirus: Running
    Oct 22 16:06:07 Fedora7 zimbramon[17559]: 17559:info: 2007-10-22 16:06:02, STATUS: zimbra.fedora7.vm: ldap: Running
    Oct 22 16:06:07 Fedora7 zimbramon[17559]: 17559:info: 2007-10-22 16:06:02, STATUS: zimbra.fedora7.vm: logger: Running
    Oct 22 16:06:07 Fedora7 zimbramon[17559]: 17559:info: 2007-10-22 16:06:02, STATUS: zimbra.fedora7.vm: mta: Running
    Oct 22 16:06:07 Fedora7 zimbramon[17559]: 17559:info: 2007-10-22 16:06:02, STATUS: zimbra.fedora7.vm: snmp: Running
    Oct 22 16:06:07 Fedora7 zimbramon[17559]: 17559:info: 2007-10-22 16:06:02, STATUS: zimbra.fedora7.vm: spell: Running
    Oct 22 16:06:07 Fedora7 zimbramon[17559]: 17559:info: 2007-10-22 16:06:02, STATUS: zimbra.fedora7.vm: stats: Running
    Oct 22 16:06:11 Fedora7 postfix/postfix-script[18019]: refreshing the Postfix mail system
    Oct 22 16:06:11 Fedora7 postfix/master[12728]: reload configuration /opt/zimbra/postfix-2.4.3.3/conf
    Oct 22 16:06:12 Fedora7 zmmailboxdmgr[18095]: threaddump requested
    Oct 22 16:06:12 Fedora7 zmmailboxdmgr[18095]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    Oct 22 16:06:12 Fedora7 zmmailboxdmgr[18095]: assuming no other instance is running
    Oct 22 16:06:12 Fedora7 zmmailboxdmgr[18095]: no manager process is running
    Oct 22 16:06:14 Fedora7 zmmailboxdmgr[18102]: stop requested
    Oct 22 16:06:14 Fedora7 zmmailboxdmgr[18102]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    Oct 22 16:06:14 Fedora7 zmmailboxdmgr[18102]: assuming no other instance is running
    Oct 22 16:06:14 Fedora7 zmmailboxdmgr[18102]: no manager process is running
    Oct 22 16:08:05 Fedora7 zimbramon[18174]: 18174:info: 2007-10-22 16:08:01, STATUS: zimbra.fedora7.vm: antispam: Stopped
    Oct 22 16:08:05 Fedora7 zimbramon[18174]: 18174:info: 2007-10-22 16:08:01, STATUS: zimbra.fedora7.vm: amavisd: running
    Oct 22 16:08:05 Fedora7 zimbramon[18174]: 18174:info: 2007-10-22 16:08:01, STATUS: zimbra.fedora7.vm: antivirus: Stopped
    Oct 22 16:08:05 Fedora7 zimbramon[18174]: 18174:info: 2007-10-22 16:08:01, STATUS: zimbra.fedora7.vm: amavisd: running
    Oct 22 16:08:05 Fedora7 zimbramon[18174]: 18174:info: 2007-10-22 16:08:01, STATUS: zimbra.fedora7.vm: ldap: Running
    Oct 22 16:08:05 Fedora7 zimbramon[18174]: 18174:info: 2007-10-22 16:08:01, STATUS: zimbra.fedora7.vm: logger: Running
    Oct 22 16:08:05 Fedora7 zimbramon[18174]: 18174:info: 2007-10-22 16:08:01, STATUS: zimbra.fedora7.vm: mta: Stopped
    Oct 22 16:08:05 Fedora7 zimbramon[18174]: 18174:info: 2007-10-22 16:08:01, STATUS: zimbra.fedora7.vm: saslauthd: is
    Oct 22 16:08:05 Fedora7 zimbramon[18174]: 18174:info: 2007-10-22 16:08:01, STATUS: zimbra.fedora7.vm: snmp: Running
    Oct 22 16:08:05 Fedora7 zimbramon[18174]: 18174:info: 2007-10-22 16:08:01, STATUS: zimbra.fedora7.vm: spell: Running
    Oct 22 16:08:05 Fedora7 zimbramon[18174]: 18174:info: 2007-10-22 16:08:01, STATUS: zimbra.fedora7.vm: stats: Stopped
    I gave those commands a try that have been listed in this thread so far, but with no success. It looks like running the install.sh really is the only way to fix it. This does however take waaayy too long for me on the server that I am using, and our company needs to implement this on a dedicated server for a client in the next month. Do you know of any faster way to get this fixed, or will we just have to wait for the next patch?

    Regards,
    Gary

  5. #15
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    We believe we have this fixed for RC2. Other than that, there isn't much we can do

  6. #16
    Join Date
    Oct 2007
    Posts
    67
    Rep Power
    8

    Default

    Alright jholder, thanks for the update. I will let everybody know. Whilst we are on the subject, when do you think RC2 might be out?

    Regards,
    Gary

  7. #17
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    BTW if you missed it from the first page of this thread that was Bug 20765 - zimbraServicedInstaled is not set for mailbox

    The best guess at dates is occasionally updated in the Zimbra Product Portal

  8. #18
    Join Date
    Oct 2007
    Posts
    67
    Rep Power
    8

    Default

    Thanks mmorse,

    I will look at that bug and see if I can find a fix in there. Other than that, I shall look forward to your next release. Thank you for the link with the version tracking, I shall keep an eye on that for future reference!

    Regards,
    Gary

Similar Threads

  1. Errors installing Outlook Connector
    By Tim G in forum Zimbra Connector for Outlook
    Replies: 57
    Last Post: 05-05-2011, 02:27 PM
  2. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  3. After reboot mailbox and tomcat don't start
    By gon in forum Administrators
    Replies: 1
    Last Post: 11-02-2007, 11:50 AM
  4. Error Installing Outlook Connector
    By DanO in forum Zimbra Connector for Outlook
    Replies: 17
    Last Post: 08-28-2007, 09:35 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •