Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: [SOLVED] Installation fails at slapd

  1. #1
    Join Date
    Oct 2007
    Posts
    7
    Rep Power
    8

    Default [SOLVED] Installation fails at slapd

    I have been trying to install Zimbra 5rc1 using the Ubuntu binary, but the installation fails when it tries to initialize LDAP. This system is running Ubuntu 7.04 but I have successfully followed the directions in the WIKI to trick it into thinking it's 6. Here's what happens:

    Code:
    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes]
    Save config in file: [/opt/zimbra/config.6432]
    Saving config in /opt/zimbra/config.6432...done.
    The system will be modified - continue? [No] yes
    Operations logged to /tmp/zmsetup.log.6432
    Setting local config values...done.
    Setting up CA...done.
    Creating SSL certificate...done.
    Initializing ldap...sed: can't read /opt/zimbra/openldap/etc/openldap/slapd.conf: Permission denied
    Failed to start slapd.  Attempting debug start to determine error.
    daemon: bind(7) failed errno=98 (Address already in use)
    slap_open_listener: failed on ldap://audiobiblio.com:389
    However, doing ps aux | grep ldap shows the process spawned by the installer. Modifying the permissions of slapd.conf prevents it from even starting in the first place. Any ideas?

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Welcome to the forums,

    ps auxx |grep zimbra

    & then kill any left over services

    Post your netstat -a

    First check if you have another ldap instance running/installed.

    If not, as root try running ./zmfixperms from /opt/zimbra/libexec/ when you reach the step "The system will be modified - continue?"

    If it becomes a 99 post your hostsfile for us (/etc/hosts)

  3. #3
    Join Date
    Oct 2007
    Posts
    7
    Rep Power
    8

    Default

    Thanks, that worked.

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    marking as solved
    (which was it - another ldap or the fix perms?)

  5. #5
    Join Date
    Oct 2007
    Posts
    7
    Rep Power
    8

    Default

    I think the permission fixing script did the trick. I tried killing all the zimbra processes before but that didn't work.

  6. #6
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

  7. #7
    Join Date
    Nov 2007
    Posts
    28
    Rep Power
    8

    Default Port Conflict zimbra-ldap

    The same error!

    ----------------------------

    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes]
    Save config in file: [/opt/zimbra/config.11034]
    Saving config in /opt/zimbra/config.11034...Done
    The system will be modified - continue? [No] y
    Operations logged to /tmp/zmsetup.log.11034
    Setting local config values...Done
    Setting up CA...Done
    Creating SSL certificate...Done
    Initializing ldap...sed: can't read /opt/zimbra/openldap/etc/openldap/slapd.conf: Permission denied
    Failed to start slapd. Attempting debug start to determine error.
    daemon: bind(7) failed errno=98 (Address already in use)
    slap_open_listener: failed on ldap://zcsagu.com:389

    ----------------------------

    Please help me!
    Thanks.

    -- xcoi

  8. #8
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Quote Originally Posted by xcoi View Post
    The same error!

    ----------------------------

    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes]
    Save config in file: [/opt/zimbra/config.11034]
    Saving config in /opt/zimbra/config.11034...Done
    The system will be modified - continue? [No] y
    Operations logged to /tmp/zmsetup.log.11034
    Setting local config values...Done
    Setting up CA...Done
    Creating SSL certificate...Done
    Initializing ldap...sed: can't read /opt/zimbra/openldap/etc/openldap/slapd.conf: Permission denied
    Failed to start slapd. Attempting debug start to determine error.
    daemon: bind(7) failed errno=98 (Address already in use)
    slap_open_listener: failed on ldap://zcsagu.com:389

    ----------------------------

    Please help me!
    Thanks.

    -- xcoi
    Turn off ldap.
    Last edited by jholder; 05-16-2008 at 07:18 PM.

  9. #9
    Join Date
    Nov 2007
    Posts
    28
    Rep Power
    8

    Default

    Thank you, but i uninstalled my openldap!
    So,
    ps -e | grep sldapd --> return null;
    --
    However, Install Zimbra has got the same problem!
    Help me please!

    --xcoi

  10. #10
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Well, did you update your hosts file the way the docs say?

    can you cat /etc/hosts

    The permission denied error isn't a file denied. It can't bind because it's in use or not available.

    ***Actually, I'm wrong. are you installing on Ubuntu 710 or some other crazy platform?
    Did you try what mmorse said?

Similar Threads

  1. Zimbra installation fails (Debian)
    By info in forum Installation
    Replies: 5
    Last Post: 01-01-2007, 04:12 AM
  2. Installation fails on zimbra-store
    By wyleyrabbit in forum Installation
    Replies: 8
    Last Post: 01-15-2006, 08:19 AM
  3. Zimbra fails to start after installation
    By Alex-- in forum Administrators
    Replies: 18
    Last Post: 12-05-2005, 12:10 PM
  4. Installation fault - getDirectContext fails
    By gregjohnson1024 in forum Administrators
    Replies: 3
    Last Post: 11-07-2005, 04:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •