Results 1 to 2 of 2

Thread: Permission Refused

  1. #1
    Join Date
    Dec 2005
    Posts
    19
    Rep Power
    9

    Default Permission Refused

    I have a domain registered for which I am trying to set up zimbra as a mail server. I also have an ISP account from which I am sending test emails. The output below is what I see in my zimbra for each mail that I try and send, nothing ever appears in the inbox.

    Dec 29 17:12:36 localhost postfix/smtpd[7904]: initializing the server-side TLS engine
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: warning: cannot get certificate from file /opt/zimbra/conf/smtpd.crt
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: warning: TLS library problem: 7904:error:02001002:system library:fopen:No such file or direct
    ory:bss_file.c:278:fopen('/opt/zimbra/conf/smtpd.crt','r'):
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: warning: TLS library problem: 7904:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.
    c:280:
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: warning: TLS library problem: 7904:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_
    file:system lib:ssl_rsa.c:760:
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: cannot load RSA certificate and key data
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: connect from ctb-mesg5.saix.net[196.25.240.75]
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: AC75F78879D: client=ctb-mesg5.saix.net[196.25.240.75]
    Dec 29 17:12:36 localhost postfix/cleanup[7906]: AC75F78879D: message-id=<43B3FCE2.80208@telkomsa.net>
    Dec 29 17:12:36 localhost postfix/qmgr[4019]: AC75F78879D: from=, size=1104, nrcpt=1 (queue active)
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: disconnect from ctb-mesg5.saix.net[196.25.240.75]
    Dec 29 17:12:37 localhost postfix/qmgr[4019]: AC75F78879D: to=, relay=none, delay=1, status=deferred (delivery
    temporarily suspended: connect to 127.0.0.1[127.0.0.1]: Connection refused)

    It looks as though the mail is being received by simbra, but that it is unable to connect to some portion of the solution. I assume that is has already passed through, or at least into postfix as the system has received it, even is the user has not and I am able to telnet to port 25 as zimbra. This even though zmcontrol status shows both the mta nad the spam filter as being stopped. I know postfix is running, not sure how to check spamassasin. Postifix is not being started by the rc scripts, BTW.

    One other thing in the log is a referenc to '/opt/zimbra/conf/zmtpd.crt' not existing. It doesn't, but this is only output as a warning. I have no errors in the log.

    I am executing this on FC4 if that is helpfule

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    Quote Originally Posted by inzanix
    I have a domain registered for which I am trying to set up zimbra as a mail server. I also have an ISP account from which I am sending test emails. The output below is what I see in my zimbra for each mail that I try and send, nothing ever appears in the inbox.

    Dec 29 17:12:36 localhost postfix/smtpd[7904]: initializing the server-side TLS engine
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: warning: cannot get certificate from file /opt/zimbra/conf/smtpd.crt
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: warning: TLS library problem: 7904:error:02001002:system library:fopen:No such file or direct
    ory:bss_file.c:278:fopen('/opt/zimbra/conf/smtpd.crt','r'):
    Search the forums for the correct way to generate this file - search on zmcreatecert, or tls auth
    Quote Originally Posted by inzanix
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: warning: TLS library problem: 7904:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.
    c:280:
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: warning: TLS library problem: 7904:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_
    file:system lib:ssl_rsa.c:760:
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: cannot load RSA certificate and key data
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: connect from ctb-mesg5.saix.net[196.25.240.75]
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: AC75F78879D: client=ctb-mesg5.saix.net[196.25.240.75]
    Dec 29 17:12:36 localhost postfix/cleanup[7906]: AC75F78879D: message-id=<43B3FCE2.80208@telkomsa.net>
    Dec 29 17:12:36 localhost postfix/qmgr[4019]: AC75F78879D: from=, size=1104, nrcpt=1 (queue active)
    Dec 29 17:12:36 localhost postfix/smtpd[7904]: disconnect from ctb-mesg5.saix.net[196.25.240.75]
    Dec 29 17:12:37 localhost postfix/qmgr[4019]: AC75F78879D: to=, relay=none, delay=1, status=deferred (delivery
    temporarily suspended: connect to 127.0.0.1[127.0.0.1]: Connection refused)

    It looks as though the mail is being received by simbra, but that it is unable to connect to some portion of the solution. I assume that is has already passed through, or at least into postfix as the system has received it, even is the user has not and I am able to telnet to port 25 as zimbra. This even though zmcontrol status shows both the mta nad the spam filter as being stopped. I know postfix is running, not sure how to check spamassasin. Postifix is not being started by the rc scripts, BTW.
    Did you search? This has been covered.

    Run zmamavisdctl start, check for errors.
    Quote Originally Posted by inzanix

    One other thing in the log is a referenc to '/opt/zimbra/conf/zmtpd.crt' not existing. It doesn't, but this is only output as a warning. I have no errors in the log.

    I am executing this on FC4 if that is helpfule

Similar Threads

  1. Can not reach https://example.com:7017/zimbraAdmin
    By Max Ma in forum Installation
    Replies: 14
    Last Post: 03-31-2007, 09:14 AM
  2. Backup issues
    By telescop in forum Administrators
    Replies: 3
    Last Post: 03-01-2007, 05:09 PM
  3. Replies: 26
    Last Post: 02-12-2007, 06:23 PM
  4. Ldap issues
    By mississippiman in forum Installation
    Replies: 11
    Last Post: 01-09-2007, 07:00 PM
  5. Move server to different OS
    By EriSan500 in forum Administrators
    Replies: 7
    Last Post: 03-05-2006, 12:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •