I am trying to upgrade my 4.5.7 to 4.5.9 and first of all support told me to run the installer as zimbra. I get an error that says must run as root. So I run it as root and now I am getting this error.

Checking for installable packages

Found zimbra-core
Error: attempting to install i386 packages on a unknown OS.
Exiting...

This is an upgrade.
I ran zmfixperms as root and that didnt help but didnt give an error either.
When I upgraded to 4.5.7 I had to call support because slapd wouldnt upgrade which left the server inoperable. I dont know whats wrong with my install but upgrades are not smooth. Any help would be appreciated.

Thanks
Josh