Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: upgrade to 30m1

  1. #1
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default upgrade to 30m1

    I have tried the instruction and get this error know it is probably something simple on my end but fedora is still very strange to me any ideas

    /etc/rc.d/init.d/ia64fmt

    ./migrate20050824a-Volume.pl -bash: ./migrate20050824a-Volume.pl: cannot execute binary file
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  2. #2
    Join Date
    Sep 2005
    Location
    Los Angeles
    Posts
    51
    Rep Power
    10

    Default

    are you running FC 64 bit ?

  3. #3
    Join Date
    Sep 2005
    Location
    Michigan
    Posts
    10
    Rep Power
    10

    Default Another 3.0 FC problem

    Installed the latest release on a new machine (lot's of memory and disk), ran the symlinks and verified the hosts settings.

    I get this error at the end of install:

    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail.abtechmail.net:389)

    I recognize the LDAP port, but don't know where to go next . . .
    Last edited by abtech; 09-22-2005 at 03:17 PM.

  4. #4
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default install log?

    Anything in the installation logs? Sounds like ldap isn't up.

    do a ps, look for slapd - is it up? How long has it been up? (Did the uninstall fail to shut it down?)

  5. #5
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default

    nope i guess i should give some specifics with my posts sorry folks

    uname -a
    Linux canmail.org 2.6.12-1.1376_FC3 #1 Fri Aug 26 23:27:26 EDT 2005 i686 athlon

    rpm -q perl
    perl-5.8.5-14.FC3

    perl -v
    This is perl, v5.8.5 built for i386-linux-thread-multi

    I gave everthing 777 perms in the migrate forlder
    drwxrwxrwx 2 zimbra zimbra 4096 Sep 21 19:57 30_M1_migrate

    tried as root and zimbra su please help

    [root@canmail zimbra]# cd 30_M1_migrate/
    [root@canmail 30_M1_migrate]# ./migrate20050824a-Volume.pl
    bash: ./migrate20050824a-Volume.pl: cannot execute binary file
    [root@canmail 30_M1_migrate]# su - zimbra
    [zimbra@canmail ~]$ ./migrate20050824a-Volume.pl
    -bash: ./migrate20050824a-Volume.pl: No such file or directory
    [zimbra@canmail ~]$ /opt/zimbra/30_M1_migrate/migrate20050824a-Volume.pl
    -bash: /opt/zimbra/30_M1_migrate/migrate20050824a-Volume.pl: cannot execute binary file
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  6. #6
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    I just re-download the files from the site, and there is something wrong. They are corrupted inside. I've put up a new copy and checked the download. After running chmod 755 *.pl it worked for me.

    http://downloads.zimbra.com/3.0_M1/z...1a.migrate.zip

  7. #7
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default

    now i get this

    ./migrate20050824a-Volume.pl
    : bad interpreter: No such file or directoryn/perl
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  8. #8
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Do you have perl in your path. This should be ran as the zimbra user. Also might want to try running it as /path/to/perl ./migrate...

  9. #9
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default First line?

    Quote Originally Posted by rmvg
    now i get this

    ./migrate20050824a-Volume.pl
    : bad interpreter: No such file or directoryn/perl
    Verify that the first line in the script reads:
    #!/usr/bin/perl

  10. #10
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default shooting in the dark

    in the past when I've seen "bad interpreter", the file turns out to be
    DOS text.

    # dos2unix *.pl

    on the those scripts may help?

Similar Threads

  1. Upgrade 4.5.4 to 4.5.5 questions
    By dlochart in forum Zimbra Connector for Outlook
    Replies: 11
    Last Post: 05-14-2007, 02:44 AM
  2. Replies: 5
    Last Post: 03-01-2007, 02:20 AM
  3. 4.01 to 4.02 upgrade problem (with solution)
    By criley in forum Migration
    Replies: 2
    Last Post: 09-28-2006, 11:36 PM
  4. 3.1.3OS Upgrade Problem
    By mcevoys in forum Installation
    Replies: 7
    Last Post: 06-16-2006, 09:47 AM
  5. M1 -> M2 Upgrade Scripts
    By KevinH in forum Announcements
    Replies: 57
    Last Post: 12-15-2005, 09:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •