Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Sorry, another 'can't login to admin' -ism

Hybrid View

  1. #1
    Join Date
    Dec 2005
    Posts
    12
    Rep Power
    9

    Default Sorry, another 'can't login to admin' -ism

    Just installed zcs-3.0.0_M3_270.RHEL4 on a fully patched/updated centos 4.2 box.

    The install went beautifully, only configuration required was admin password.

    Applied password, started zimbra, all is well.

    Can't log into admin console at https://blahblah:7071 get "Authentication Failed"
    when logging in as admin@host.domain.tld.

    However, using the same user/password pair for the "regular" account
    at admin@host.domain.tld it works just fine. I thought at admin@host.domain.tld
    was the same ldap info user and administrator. So, why does one work and
    not the other? Perhaps that's the wrong question.

    At any rate, before I reformat this whole machine and start the entire installation
    process over from scratch, can someone point out what I have done wrong?

    Thanks kindly in advance.

  2. #2
    Join Date
    Dec 2005
    Posts
    24
    Rep Power
    9

    Default

    Quote Originally Posted by cpm001
    Just installed zcs-3.0.0_M3_270.RHEL4 on a fully patched/updated centos 4.2 box.

    The install went beautifully, only configuration required was admin password.

    Applied password, started zimbra, all is well.

    Can't log into admin console at https://blahblah:7071 get "Authentication Failed"
    when logging in as admin@host.domain.tld.

    However, using the same user/password pair for the "regular" account
    at admin@host.domain.tld it works just fine. I thought at admin@host.domain.tld
    was the same ldap info user and administrator. So, why does one work and
    not the other? Perhaps that's the wrong question.

    At any rate, before I reformat this whole machine and start the entire installation
    process over from scratch, can someone point out what I have done wrong?

    Thanks kindly in advance.
    What does zimbra.log say? /opt/zimbra/log/zimbra.log

  3. #3
    Join Date
    Dec 2005
    Posts
    12
    Rep Power
    9

    Default

    Quote Originally Posted by retireoncsco
    What does zimbra.log say? /opt/zimbra/log/zimbra.log
    It sayeth: (in short)

    2006-01-04 08:39:50,911 WARN [http-7071-Processor49] [ip=192.168.0.9;] misc - LC.get(trial_expiration_date) was null, returning empty string

  4. #4
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default admin console login

    When logging into the admin console, you have to use the full user name user@domain.com - are you doing that?

    From the command line, zmprov ga admin@domain.com - is zimbraIsAdminAccount set to TRUE?

    Try resetting the password (zmprov sp) and logging in again.

  5. #5
    Join Date
    Dec 2005
    Posts
    12
    Rep Power
    9

    Default

    Quote Originally Posted by marcmac
    When logging into the admin console, you have to use the full user name user@domain.com - are you doing that?
    Yes

    Quote Originally Posted by marcmac
    From the command line, zmprov ga admin@domain.com - is zimbraIsAdminAccount set to TRUE?
    Yes

    Quote Originally Posted by marcmac
    Try resetting the password (zmprov sp) and logging in again.
    I have no earthly concept how one would do this.
    Belive it or not, what spews forth from zmprov sp isn't the most intuitive thing
    some of us have ever seen. I know that's subjective, but seriously.

    Please know that as a regular user, admin@domain.com works just fine.

  6. #6
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default What spews forth

    zmprov sp user password

  7. #7
    Join Date
    Dec 2005
    Posts
    12
    Rep Power
    9

    Default

    Quote Originally Posted by marcmac
    zmprov sp user password
    Did That Thing.

    Authentication Failed

    2006-01-04 08:51:27,341 WARN [http-7071-Processor44] [ip=192.168.0.9;] misc - LC.get(trial_expiration_date) was null, returning empty string

    And again, logging in as a regular user, with the new pasword, worked fine.

  8. #8
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default hmmm

    try setting the trial exp date, see if that does it
    zmlocalconfig -e trial_expiration_date=20060606
    tomcat stop
    tomcat start

    That shouldn't be the problem, but we may have a bug.

  9. #9
    Join Date
    Dec 2005
    Posts
    12
    Rep Power
    9

    Default

    Quote Originally Posted by marcmac
    try setting the trial exp date, see if that does it
    zmlocalconfig -e trial_expiration_date=20060606
    tomcat stop
    tomcat start

    That shouldn't be the problem, but we may have a bug.
    Well, got better errors now.

    Still failed, but logs are a bit more verbose about it.

    2006-01-04 09:01:09,106 INFO [http-7071-Processor48] [ip=192.168.0.9;] SoapEngine - handler exception
    com.zimbra.cs.account.AccountServiceException: authentication failed for admin
    at com.zimbra.cs.account.AccountServiceException.AUTH _FAILED(AccountServiceException.java:76)
    at com.zimbra.cs.service.admin.Auth.handle(Auth.java: 80)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:252)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:163)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:230)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:152)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:252)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:173)
    at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:214)
    at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:178)
    at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:126)
    at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:105)
    at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:107)
    at org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:526)
    at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:148)
    at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:825)
    at org.apache.coyote.http11.Http11Protocol$Http11Conn ectionHandler.processConnection(Http11Protocol.jav a:738)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:526)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:80)
    at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:684)
    at java.lang.Thread.run(Thread.java:595)
    Last edited by cpm001; 01-04-2006 at 09:30 AM.

  10. #10
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default orthogonal errors

    I think the error you just posted is orthogonal to the trial_exp error.

    Try this (with your domain for domain.com):

    zmprov ca testadmin@domain.com test123 zimbraIsAdminAccount TRUE

    Then try logging in as testadmin@domain.com/test123

Similar Threads

  1. Failed Admin Login
    By apdicaprio in forum Installation
    Replies: 10
    Last Post: 04-06-2008, 05:53 PM
  2. Admin login stuck on "Loading..."
    By danfluidmind in forum Installation
    Replies: 9
    Last Post: 07-12-2007, 10:04 AM
  3. No admin login using Opera
    By eddie in forum Administrators
    Replies: 3
    Last Post: 04-09-2007, 11:07 PM
  4. Cannot login as admin after install
    By elesouef in forum Installation
    Replies: 23
    Last Post: 02-13-2007, 09:06 AM
  5. Zimbra M3-270 Admin login problem
    By phoenix in forum Administrators
    Replies: 0
    Last Post: 12-09-2005, 06:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •