Results 1 to 10 of 32

Thread: Fedora 8 install

Hybrid View

  1. #1
    Join Date
    Nov 2007
    Posts
    11
    Rep Power
    7

    Default Fedora 8 install

    I get this error during install on a Fedora 8 box:

    Operations logged to /tmp/zmsetup.11292007-224303.log
    Setting local config values...done.
    Setting up CA...done.
    Creating SSL certificate...done.
    Initializing ldap...IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapinit line 150.
    FAILED (111)


    Log:
    Operations logged to /tmp/zmsetup.11292007-224303.log
    Getting installed packages
    checking isEnabled zimbra-core
    zimbra-core not in enabled cache
    enabled packages
    Newinstall enabling all installed packages
    Enabling zimbra-core
    Enabling zimbra-ldap
    Enabling zimbra-store
    Enabling zimbra-mta
    Enabling zimbra-snmp
    Enabling zimbra-logger
    Enabling zimbra-apache
    Enabling zimbra-spell
    Setting defaults...
    Setting local config zimbra_java_home to /opt/zimbra/java
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_java_home='/opt/zimbra/java' 2> /dev/null
    checking isEnabled zimbra-cluster
    zimbra-cluster not in enabled cache
    enabled packages zimbra-logger zimbra-store zimbra-mta zimbra-core zimbra-apache zimbra-snmp zimbra-ldap zimbra-spell
    Newinstall enabling all installed packages
    Enabling zimbra-core
    Enabling zimbra-ldap
    Enabling zimbra-store
    Enabling zimbra-mta
    Enabling zimbra-snmp
    Enabling zimbra-logger
    Enabling zimbra-apache
    Enabling zimbra-spell
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled


    DNS ERROR resolving MX for mail.answertg.com
    It is suggested that the domain name have an MX record configured in DNS
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    MX: mail.answertg.com (192.168.55.12)

    Interface: 192.168.55.12
    Interface: 127.0.0.1
    done.
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-spell
    zimbra-spell is enabled
    Checking for port conflicts
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-logger
    zimbra-logger is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    Global config attribute retrieved from ldap: zimbraSpamIsSpamAccount=
    Global config attribute retrieved from ldap: zimbraSpamIsNotSpamAccount=
    Global config attribute retrieved from ldap: zimbraNotebookAccount=
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-archiving
    zimbra-archiving not in enabled cache
    enabled packages zimbra-logger zimbra-store zimbra-mta zimbra-core zimbra-apache zimbra-cluster zimbra-snmp zimbra-ldap zimbra-spell
    Newinstall enabling all installed packages
    Enabling zimbra-core
    Enabling zimbra-ldap
    Enabling zimbra-store
    Enabling zimbra-mta
    Enabling zimbra-snmp
    Enabling zimbra-logger
    Enabling zimbra-apache
    Enabling zimbra-spell
    checking isComponentAvailable archiving
    Component archiving is not available.
    checking isEnabled zimbra-snmp
    zimbra-snmp is enabled
    checking isEnabled zimbra-spell
    zimbra-spell is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-archiving
    zimbra-archiving is not enabled
    checking isComponentAvailable archiving
    Component archiving is not available.
    checking isEnabled zimbra-snmp
    zimbra-snmp is enabled
    checking isEnabled zimbra-spell
    zimbra-spell is enabled
    Saving config in /opt/zimbra/config.27368...
    done.
    Operations logged to /tmp/zmsetup.11292007-224303.log
    Setting local config values...
    Setting local config zimbra_server_hostname to mail.answertg.com
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_server_hostname='mail.answertg.com' 2> /dev/null
    Setting local config ldap_master_url to ldap://mail.answertg.com:389
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_master_url='ldap://mail.answertg.com:389' 2> /dev/null
    Setting local config ldap_url to ldap://mail.answertg.com:389
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_url='ldap://mail.answertg.com:389' 2> /dev/null
    Setting local config ldap_port to 389
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_port='389' 2> /dev/null
    Setting local config ldap_host to mail.answertg.com
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_host='mail.answertg.com' 2> /dev/null
    Setting local config zimbra_uid to 500
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_uid='500' 2> /dev/null
    Setting local config zimbra_gid to 500
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_gid='500' 2> /dev/null
    Setting local config zimbra_user to zimbra
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_user='zimbra' 2> /dev/null
    Setting local config av_notify_user to admin@answertg.com
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e av_notify_user='admin@answertg.com' 2> /dev/null
    Setting local config ssl_allow_untrusted_certs to TRUE
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ssl_allow_untrusted_certs='TRUE' 2> /dev/null
    Setting local config mysql_memory_percent to 30
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e mysql_memory_percent='30' 2> /dev/null
    Setting local config mailboxd_java_heap_memory_percent to 40
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e mailboxd_java_heap_memory_percent='40' 2> /dev/null
    Setting local config mailboxd_directory to /opt/zimbra/mailboxd
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e mailboxd_directory='/opt/zimbra/mailboxd' 2> /dev/null
    Setting local config mailboxd_keystore to /opt/zimbra/mailboxd/etc/keystore
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e mailboxd_keystore='/opt/zimbra/mailboxd/etc/keystore' 2> /dev/null
    Setting local config mailboxd_server to jetty
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e mailboxd_server='jetty' 2> /dev/null
    Setting local config mailboxd_truststore_password to changeit
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e mailboxd_truststore_password='changeit' 2> /dev/null
    Setting local config mailboxd_keystore_password to Ogz_fMo6RI
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e mailboxd_keystore_password='Ogz_fMo6RI' 2> /dev/null
    Setting local config zimbra_ldap_userdn to uid=zimbra,cn=admins,cn=zimbra
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_ldap_userdn='uid=zimbra,cn=admins,cn=zimbra ' 2> /dev/null
    done.
    Setting up CA...
    *** Running as root user: /opt/zimbra/bin/zmcertmgr createca
    done.
    Creating SSL certificate...
    checking isEnabled zimbra-store
    zimbra-store is enabled
    *** Running as root user: /opt/zimbra/bin/zmcertmgr install self
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    *** Running as root user: /opt/zimbra/bin/zmcertmgr install self
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    *** Running as root user: /opt/zimbra/bin/zmcertmgr install self
    done.
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    FAILED (111)


    ERROR



    Configuration failed

    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration.

    Errors have been logged to /tmp/zmsetup.11292007-224303.log

  2. #2
    Join Date
    Dec 2007
    Posts
    4
    Rep Power
    7

    Default

    Hi Ahuman,

    I have the same problem installing on opensuse 10.3

    I get this error during installation

    Initializing ldap...IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapinit line 158.
    FAILED (111)
    I have tried different things but no luck

  3. #3
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Welcome to the forums,
    First I just wanted to check: NE or FOSS?
    5.0 FOSS GA or 4.5.10 FOSS or 4.5.10 NE?
    I ask because you should not be running NE on an unsupported platform.
    The error seems to be as noted in Bug 22140 - latest mainline builds not installing, throws error in zmldapinit a permissions issue on the certs.
    You might checkout:
    http://www.zimbra.com/forums/install...ete-guide.html
    http://www.zimbra.com/forums/develop...at_tag-sh.html

  4. #4
    Join Date
    Nov 2007
    Posts
    11
    Rep Power
    7

    Default Fedora 8 install

    I ended up backing up the data. Then I reloaded the system with fedora 6 and then used the my restore script to put zimbra back to its former state. I ended up modifying some perl backup scripts and then using them for the backup and restore.

    On a good note i now have scripts that automatically backup the zimbra on a weekly basis. And i know the restore script works, because i used it!

    I know that the zimbra 4.10 won't run on fedora 7 or 8 because of the newer version of curl on 7 and 8. I would make a new package and post it, but there are no good directions on how to compile your own build of zimbra open source.

  5. #5
    Join Date
    Nov 2007
    Posts
    11
    Rep Power
    7

    Default CentOS

    I ended moving to CentOS in the end, so that i didn't have to worry about fedoras updates breaking zimbra.

  6. #6
    Join Date
    Jan 2008
    Posts
    2
    Rep Power
    7

    Default

    I'm doing an install of the F7 release zimbra 5.0.1_GA_1902 and am getting a similar error.

    Note - this is using Fedora 8

    From looking around its not a permission problem for me. The certificate files don't exist in the /opt/zimbra/conf directory.

    I can't seem to work out why they're not being created. I couldn't find anything that looked significant in the install log.

  7. #7
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    Quote Originally Posted by schpork View Post
    I'm doing an install of the F7 release zimbra 5.0.1_GA_1902 and am getting a similar error.
    As noted on a few other threads, the 5.0.1 F7 packages have a missing dependency on libtool-ltdl. This is fixed for 5.0.2. I suggest making sure libtool-ltdl is installed, otherwise slapd won't start.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  8. #8
    Join Date
    Jan 2008
    Posts
    2
    Rep Power
    7

    Default

    Quote Originally Posted by quanah View Post
    As noted on a few other threads, the 5.0.1 F7 packages have a missing dependency on libtool-ltdl. This is fixed for 5.0.2. I suggest making sure libtool-ltdl is installed, otherwise slapd won't start.
    Yup. Found those posts. Had that installed prior to starting my install. Also made sure I had tty not required in my sudo configuration.

  9. #9
    Join Date
    Feb 2008
    Posts
    5
    Rep Power
    7

    Default

    Hi Guys,

    I am also trying to install Zimbra 5.02 Open Source Edition on FC8. Same error - initializing ldap. I would really appreciate if someone has a workaround to share.

    BTW, install 5.01 version on my FC8 gives same ldap error as 5.02
    Last edited by masionas; 02-12-2008 at 07:31 AM.

  10. #10
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    Quote Originally Posted by masionas View Post
    Hi Guys,

    I am also trying to install Zimbra 5.02 Open Source Edition on FC8.
    As noted previously, the FOSS build is for Fedora 7, not for Fedora 8. I'd advise using the supported release.

    --Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Similar Threads

  1. Replies: 21
    Last Post: 09-27-2007, 11:49 AM
  2. Zimbra can't install on Fedora core 6 and FC 4
    By Grejao in forum Installation
    Replies: 3
    Last Post: 04-27-2007, 07:19 AM
  3. broken install on fedora core 4??
    By rmvg in forum Installation
    Replies: 5
    Last Post: 03-05-2006, 06:40 PM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM
  5. more fedora install problems
    By jlynch3 in forum Installation
    Replies: 13
    Last Post: 09-14-2005, 09:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •