Results 1 to 5 of 5

Thread: Upgrade from ZCS 4.5.9 to ZCS 5.0 RC3

  1. #1
    Join Date
    Aug 2007
    Posts
    4
    Rep Power
    8

    Default Upgrade from ZCS 4.5.9 to ZCS 5.0 RC3

    Hi ,

    I have upgraded zimbra 4.5.9 on redhat to 5.0 RC3 in a multi install environment. Upgrade went fine but while sending mail i get following errors in /var/log/zimb ra.log

    Dec 3 04:12:30 multi-mb1 postfix/smtpd[25094]: warning: problem talking to service rewrite: Success
    Dec 3 04:12:30 multi-mb1 postfix/master[4350]: warning: process /opt/zimbra/postfix-2.4.3.3/libexec/trivial-rewrite pid 28850 exit status 1
    Dec 3 04:13:30 multi-mb1 postfix/trivial-rewrite[29115]: error: dict_ldap_connect: Unable to set STARTTLS: -11: Connect error
    Dec 3 04:13:30 multi-mb1 last message repeated 2 times
    Dec 3 04:13:30 multi-mb1 postfix/trivial-rewrite[29115]: fatal: ldap:/opt/zimbra/conf/ldap-vad.cf(0,lock|fold_fix): table lookup problem
    D

    Any clue ?

    -Punit

  2. #2
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    the problem is you travelled into the future and got a version that hasn't been released yet! (rc3). seriously, looks like your postfix can't talk tls to openldap for table lookups. make sure openldap is starting up with tls support, and make sure both postfix and openldap are picking up the correct ssl libs (ldd libldap.so etc).

  3. #3
    Join Date
    Nov 2006
    Posts
    31
    Rep Power
    8

    Default

    I'm getting this exact same error but on the release version, did you ever get it resolved?

    Quote Originally Posted by punit.jain View Post
    Hi ,

    I have upgraded zimbra 4.5.9 on redhat to 5.0 RC3 in a multi install environment. Upgrade went fine but while sending mail i get following errors in /var/log/zimb ra.log

    Dec 3 04:12:30 multi-mb1 postfix/smtpd[25094]: warning: problem talking to service rewrite: Success
    Dec 3 04:12:30 multi-mb1 postfix/master[4350]: warning: process /opt/zimbra/postfix-2.4.3.3/libexec/trivial-rewrite pid 28850 exit status 1
    Dec 3 04:13:30 multi-mb1 postfix/trivial-rewrite[29115]: error: dict_ldap_connect: Unable to set STARTTLS: -11: Connect error
    Dec 3 04:13:30 multi-mb1 last message repeated 2 times
    Dec 3 04:13:30 multi-mb1 postfix/trivial-rewrite[29115]: fatal: ldap:/opt/zimbra/conf/ldap-vad.cf(0,lock|fold_fix): table lookup problem
    D

    Any clue ?

    -Punit

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

  5. #5
    Join Date
    Nov 2006
    Posts
    31
    Rep Power
    8

    Default

    Unfortunately that only works with selfsigned certs. I have been able to get that far, but I want to use my SSL Cert from Thawte.

    I think the main problem is that it is a two year CERT and I'm about fourteen months into it, so it seems that Postfix/LDAP thinks it's expired or something.

    This is driving me nuts, everytime I start up a fat client, visit the webpage, or use my iPhone a prompt spits out about it not being trusted. That would be fine if it was just me, but I have about 30 people using the system to.

    Not to mention it was working on 4.10.

Similar Threads

  1. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 04:52 AM
  2. Outlook 2007 Beta Overview
    By GregA in forum Zimbra Connector for Outlook
    Replies: 19
    Last Post: 03-03-2008, 03:24 PM
  3. [SOLVED] zmzimletctl error after 4.5.9 upgrade
    By Maja in forum Installation
    Replies: 1
    Last Post: 11-06-2007, 09:32 AM
  4. Replies: 41
    Last Post: 10-29-2007, 02:36 PM
  5. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 03:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •