Results 1 to 2 of 2

Thread: glibc error upgrading from 4.5.5 to 4.5.10 on CentOS 4.4

  1. #1
    Join Date
    Nov 2006
    Posts
    177
    Rep Power
    9

    Default glibc error upgrading from 4.5.5 to 4.5.10 on CentOS 4.4

    I was performing an upgrade and all seemed to go well until I saw this:

    Code:
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...Restoring backup schedule...done
    chown: cannot access `/opt/zimbra/conf/smtpd.key': No such file or directory
    chown: cannot access `/opt/zimbra/conf/smtpd.crt': No such file or directory
    Can't load '/opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/DBI/DBI.so' for module DBI: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/DBI/DBI.so) at /usr/lib/perl5/5.8.5/i386-linux-thread-multi/DynaLoader.pm line 230,  line 228.
     at /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/DBI.pm line 266
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/DBI.pm line 266,  line 228.
    Compilation failed in require at /opt/zimbra/libexec/scripts/Migrate.pm line 18,  line 228.
    BEGIN failed--compilation aborted at /opt/zimbra/libexec/scripts/Migrate.pm line 18,  line 228.
    Compilation failed in require at /opt/zimbra/libexec/zmupgrade.pm line 21,  line 228.
    BEGIN failed--compilation aborted at /opt/zimbra/libexec/zmupgrade.pm line 21,  line 228.
    Compilation failed in require at /opt/zimbra/libexec/zmsetup.pl line 59,  line 228.
    BEGIN failed--compilation aborted at /opt/zimbra/libexec/zmsetup.pl line 59,  line 228.
    It looks like there is a new DBI.so being installed that expects glibc 2.4. Am I right on this? Is there another work around? I would have to do a major upgrade to get glibc 2.4 ( I don't feel lik egoing through the pain of installing it in addition to what is there ... that always turns into a nightmare) Could I get a DBI.so linked against glibc 2.3?

    I forgot to add that we are using the NETWORK edition. If I need to put this in through support please let me know.
    Thanks
    Last edited by dlochart; 12-17-2007 at 02:06 PM.

  2. #2
    Join Date
    Nov 2006
    Posts
    177
    Rep Power
    9

    Default

    My mistake I downloaded the wrong one. We have moved to RHEL 5 on all of our boxes except Zimbra and I wasn't paying attention and downloaded the RHEL 5 version.

Similar Threads

  1. CentOS 4.4 imapsync problems
    By timschmidt in forum Migration
    Replies: 19
    Last Post: 08-01-2007, 09:29 AM
  2. CentOS 4.4 64 bit - 4.5.0_GA install problems
    By davespigot in forum Installation
    Replies: 1
    Last Post: 01-25-2007, 08:25 PM
  3. Centos 4.4 and Zimbra 4.0.5 takes FOREVER to install
    By eaperezh in forum Installation
    Replies: 3
    Last Post: 01-17-2007, 01:23 AM
  4. LDAP problem installaing 4.0.1 on CentOS 4.4
    By Henrik in forum Installation
    Replies: 12
    Last Post: 09-15-2006, 08:45 AM
  5. Zimbra startup hangs after install CentOS 4.2
    By eger in forum Installation
    Replies: 4
    Last Post: 02-10-2006, 11:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •