Results 1 to 3 of 3

Thread: [SOLVED] Problems with DNS (on CentOS5 and Zimbra5 RC2)

  1. #1
    Join Date
    Dec 2007
    Posts
    5
    Rep Power
    7

    Default [SOLVED] Problems with DNS (on CentOS5 and Zimbra5 RC2)

    Hello @all,

    i have installed zimbra on a xen virtual machine, using debian etch for dom0 and centos5 for domX. Everything fine, except the main feature -> I can't send or receive mails.
    First of all, I have read nearly the whole wiki and the forums for dns questions..nevertheless I have no solution for my problem.

    Symptoms: Send/Receive Mail doesn't work (even inside mails)
    Caution: all < and > replaced with ### due the fact that the forum software doesn't display this in code mode
    Code:
    Dec 20 13:37:03 mail postfix/smtpd[13007]: A42F08C1A8: client=unknown[195.122.130.23]
    Dec 20 13:37:03 mail postfix/cleanup[13012]: A42F08C1A8: message-id=###1198157055.5859.14.camel@dontcare###
    Dec 20 13:37:03 mail postfix/qmgr[9718]: A42F08C1A8: from=###test@externaldomain.de###, size=2349, nrcpt=1 (queue active)
    Dec 20 13:37:03 mail amavis[9614]: (09614-01) ESMTP::10024 /opt/zimbra/amavisd/tmp/amavis-20071220T133703-09614: ###test@externaldomain.de### -### ###test@dissz.net### SIZE=2349 BODY=8BITMIME
     Received: from mail.dissz.net ([127.0.0.1]) by localhost (mail.dissz.net [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for ###test@dissz.net###; Thu, 20 Dec 2007 13:37:03 +0000
    (UTC)
    Dec 20 13:37:03 mail postfix/smtpd[13007]: disconnect from unknown[195.122.130.23]
    Dec 20 13:37:03 mail amavis[9614]: (09614-01) Checking: p8oIhaurAHTf [195.122.130.23] ###test@externaldomain.de### -### ###test@dissz.net###
    Dec 20 13:37:04 mail postfix/smtpd[13016]: connect from localhost.localdomain[127.0.0.1]
    Dec 20 13:37:04 mail postfix/smtpd[13016]: 18DCF8C1A9: client=localhost.localdomain[127.0.0.1]
    Dec 20 13:37:04 mail postfix/cleanup[13012]: 18DCF8C1A9: message-id=###1198157055.5859.14.camel@dontcare###
    Dec 20 13:37:04 mail postfix/qmgr[9718]: 18DCF8C1A9: from=###test@externaldomain.de###, size=2907, nrcpt=1 (queue active)
    Dec 20 13:37:04 mail postfix/smtpd[13016]: disconnect from localhost.localdomain[127.0.0.1]
    Dec 20 13:37:04 mail amavis[9614]: (09614-01) FWD via SMTP: ###test@externaldomain.de### -### ###test@dissz.net###,BODY=8BITMIME 250 2.6.0 Ok, id=09614-01, from MTA([127.0.0.1]:10025): 250 2.
    0.0 Ok: queued as 18DCF8C1A9
    Dec 20 13:37:04 mail amavis[9614]: (09614-01) Passed CLEAN, [195.122.130.23] [195.122.130.2] ###test@externaldomain.de### -### ###test@dissz.net###, Message-ID: ###1198157055.5859.14.camel@dont
    care###, mail_id: p8oIhaurAHTf, Hits: 3.667, size: 2348, queued_as: 18DCF8C1A9, 349 ms
    Dec 20 13:37:04 mail postfix/smtp[13013]: A42F08C1A8: to=###test@dissz.net###, relay=127.0.0.1[127.0.0.1]:10024, delay=0.54, delays=0.18/0.01/0.01/0.34, dsn=2.0.0, status=sent (250 2
    .0.0 Ok: queued as 18DCF8C1A9)
    Dec 20 13:37:04 mail postfix/qmgr[9718]: A42F08C1A8: removed
    Dec 20 13:37:04 mail postfix/lmtp[13017]: 18DCF8C1A9: to=###test@dissz.net###, relay=none, delay=0.02, delays=0.01/0.01/0/0, dsn=4.4.3, status=deferred (Host or domain name not found
    . Name service error for name=mail.dissz.net type=A: Host not found, try again)
    Postfix has Problems with DNS, ok..

    Code:
    my /etc/hosts, but afaik postfix doesn't use this
    
    127.0.0.1 localhost.localdomain localhost
    78.47.207.92 mail.dissz.net mail
    DNS seems right, even rdns seems correct
    Code:
    dns check for dissz.net (mx) and mail.dissz.net (a)
    host -t mx dissz.net
    dissz.net mail is handled by 10 mail.dissz.net.
    host -t a mail.dissz.net
    mail.dissz.net has address 78.47.207.92
    host 78.47.207.92
    92.207.47.78.in-addr.arpa domain name pointer mail.dissz.net.
    No ideas left, can somebody help me?

    xaos

    EDIT: The CentOS Xen machine has its own IP and is connected via XENBR (Xen Bridge) to the net. Direct Connect via http to Zimbra Collaboration Suite Log In works, Webfrontend works like a charm
    Last edited by xaosmail; 12-20-2007 at 06:49 AM.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Is SELinux disabled? It should be. If you are behind a firewall you may also need a Split DNS or you may need to open some ports.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Dec 2007
    Posts
    5
    Rep Power
    7

    Default

    W00t! Failure found..

    Two Issues:

    a) selinux was enabled
    b) /etc/resolv.conf had incorrect permissions (user postfix couldn't read them)

    thx for the help

    xaos

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •