Results 1 to 10 of 10

Thread: centos4 upgrade to 5.0 errors

  1. #1
    Join Date
    Feb 2007
    Location
    Pennsylvania
    Posts
    96
    Rep Power
    8

    Default centos4 upgrade to 5.0 errors

    centos follows the RHEL path so i thought an upgrade from 4.5.10 to 5.0 would be fine but it fails at this point:

    Code:
    Updating from 5.0.0_RC3
    5 is only avaliable with the XS version at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30,  line 1 6.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 970,  line 16.
    i need some help. at this point my mail is down. i'm not sure if i should revert back. or try.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Have you actually installed the correct version of Zimbra for your o/s i.e which version of Centos is this and do you have the correct Zimbra version for that o/s?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Feb 2007
    Location
    Pennsylvania
    Posts
    96
    Rep Power
    8

    Default

    the current successful version i was running was:

    zcs-4.5.10_GA_1575.RHEL4

    the version i tried to upgrade to was:

    zcs-5.0.0_GA_1869.RHEL4.20071218182359

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    OK, in that case check this post and follow the instructions.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Feb 2007
    Location
    Pennsylvania
    Posts
    96
    Rep Power
    8

    Default

    forgive my ignorance but does that mean that the PERLLIB and PERL5LIB environment variables in root's .bashrc need to match zimbra user's .bashrc?

    i'm pretty sure that is what i read. can you please confirm?

    thanks.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Yes, that's what I read too.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Feb 2007
    Location
    Pennsylvania
    Posts
    96
    Rep Power
    8

    Default

    i did try that but still got the same error. i copied the PERLLIB and PERL5LIB to root's .bashrc but still got the same errors. those variables did not exist in root's .bashrc so i just added them at the bottom including the export parameters for them.

    it looks as though it's only partially installed. some of the GUI is there and all services are running but MTA. i can't get it to work though. is there something i did wrong with the copy paste into .bashrc?

  8. #8
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    Actually, what I meant was to export those as the root user. Copying them into root's .bashrc won't do anything unless you log out as root and then log back in to pick it up, or reset the environment.

    --Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  9. #9
    Join Date
    Sep 2006
    Location
    Space station 101
    Posts
    182
    Rep Power
    9

    Thumbs up My solution

    Trying to upgrade from 4.5.10 to 5.0 on CentOS 4 x86_64.

    Failed with error:

    Code:
    5 is only avaliable with the XS version at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30,  line 17.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 970,  line 17.
    After reading a few threads, I tried running:

    Code:
    cpan -i Scalar::Util
    (I had problems with my cpan server so deleted /usr/lib/perl5/5.8.5/CPAN/Config.pm, then ran the code above again and setup some cpan servers from here)

    After installing - I re-ran the ./install.sh and it worked ok...

    Good luck all - best wishes for 2008

    *** Note all code extracts were performed as root
    Last edited by Costa-101; 01-01-2008 at 03:35 PM.
    ------------------------------
    http://www.lcrm.co.uk

  10. #10
    Join Date
    Jul 2007
    Location
    Peoria, IL
    Posts
    11
    Rep Power
    8

    Default Fix For CentOS And Zimbra 5.0.1 or 5.0.0 upgrade

    After much searching and hair pulling out as 50K email accounts on my server quit working it seems that the Perl RPM in CentOS *Plus* is broken (missing XS that Zimbra needs during install) but the Perl that comes with CentOS (non-Plus) has XS in it. See the below link on how to restore back to the plain Perl with XS support. After I did this my upgrade went perfectly. Everything else in the above posts did not work for me.

    http://www.zimbra.com/forums/install...pported-4.html

Similar Threads

  1. Successful upgrade from OpenSuSE 10.0 (4.5.9 to 5.0)
    By bradb21 in forum Installation
    Replies: 6
    Last Post: 01-02-2008, 10:02 AM
  2. ZCS 5.0 FOSS is Released!!!
    By jholder in forum Announcements
    Replies: 1
    Last Post: 12-21-2007, 11:21 AM
  3. dspam errors after 5.0 upgrade
    By Krishopper in forum Administrators
    Replies: 2
    Last Post: 12-20-2007, 04:57 PM
  4. [SOLVED] Upgrade from 4.5 to 5.0
    By Stergil in forum Installation
    Replies: 2
    Last Post: 10-05-2007, 01:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •