Results 1 to 3 of 3

Thread: Admin UI unavailable after upgrade from RC1 to GA

  1. #1
    Join Date
    Jan 2008
    Posts
    1
    Rep Power
    7

    Default Admin UI unavailable after upgrade from RC1 to GA

    HI,

    after upgrading from 5 RC1 to 5 GA I had a few problems with ssl certificates but having got those working I now still have a problem logging in to the Admin UI. The UI asks for my admin username and password but once I enter those and click to continue the page stalls on "Loading". Using Firebug to inspect the process I see that a soap call ti "GetLDAPEntrysRequest" is returning a 500 with the following body.

    Is there a way of repairing this without doing a full install again?

    Code:
    {"Body":
    	{"Fault":
    	{"Detail":
    	{"Error":
    	{"Trace":
    	"com.zimbra.common.service.ServiceException: unknown document: GetLDAPEntrysRequest Code:service.UNKNOWN_DOCUMENT
    	at com.zimbra.common.service.ServiceException.UNKNOWN_DOCUMENT(ServiceException.java:197)
    	at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:269)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:213)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:118)
    	at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:272)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
    	at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:174)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
    	at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
    	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093)
    	at org.mortbay.servlet.UserAgentFilter.doFilter(UserAgentFilter.java:81)
    	at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter.java:132)
    	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
    	at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
    	at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
    	at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
    	at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:712)
    	at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
    	at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:211)
    	at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
    	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
    	at org.mortbay.jetty.handler.RewriteHandler.handle(RewriteHandler.java:176)
    	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
    	at org.mortbay.jetty.Server.handle(Server.java:313)
    	at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:506)
    	at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:844)
    	at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:644) 
    	at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:205)
    	at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:381)
    	at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:396)
    	at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:442)\n","Code":"service.UNKNOWN_DOCUMENT","_jsns":"urn:zimbra"
    	}
    	},"Code"{"Value":"soap:Sender"},"Reason":{"Text":"unknown document: GetLDAPEntrysRequest"}
    	}
    	},"Header":{"context":{"sessionId":[{"id":"3184","_content":"3184","type":"admin"}],"change":{"token":7899},"_jsns":"urn:zimbra"}
    	},"_jsns":"urn:zimbraSoap"
    FYI, I am using the Posix and Samba zimlets.


    Thanks,

    Lauch

  2. #2
    Join Date
    Nov 2007
    Location
    UK
    Posts
    5
    Rep Power
    8

    Default

    I had the same problem after the upgrade to 5, the upgrade removes the existing zimlets.

    I fixed it by deploying the samba and posix zimlets using "zmzimletctl deploy "

    The samba and posix zips are in /opt/zimbra/zimlet_admin_extension.

    I also had to do the slapd.conf changes and copy the samba.schema as outlined in the docs.

    But I can't see my posix groups, accounts or samba domain, time to do a bit more investigating.

    Maurice

  3. #3
    Join Date
    Nov 2007
    Location
    UK
    Posts
    5
    Rep Power
    8

    Default

    It's /opt/zimbra/conf/slapd.conf.in that I should have changed, I'm now running on 5 with all my accounts (zimbra, posix and samba working again).

    Maurice

Similar Threads

  1. [SOLVED] Admin UI unreadable after upgrade
    By sel5150 in forum Installation
    Replies: 20
    Last Post: 01-03-2008, 02:37 PM
  2. Replies: 27
    Last Post: 12-11-2007, 07:54 AM
  3. 5.0 RC1: admin interface: no statistics, no mail queue
    By christian.kieft in forum Administrators
    Replies: 1
    Last Post: 11-13-2007, 09:22 AM
  4. INVALID_PDU error on 4.5 GA
    By figuser in forum Installation
    Replies: 33
    Last Post: 06-15-2007, 01:11 AM
  5. 4.0 RC1 Documents initialization failed on upgrade
    By neilmc in forum Administrators
    Replies: 13
    Last Post: 10-05-2006, 03:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •