Results 1 to 10 of 10

Thread: Can't access server details

  1. #1
    Join Date
    Jan 2008
    Posts
    30
    Rep Power
    7

    Default Can't access server details

    I've just installed the network edition trial on ubuntu LTS. Everything seems to work fine with regards to email / calendar etc, but I cannot access the server details without getting javascript errors.

    If I log in to the admin control panel, then click on the arrow besides servers at the left hand side I see my single zimbra server.

    I then click on it, and get the following javascript error in Firefox:

    JavaScript error encountered in method ZaController.prototype._setView
    message: this._toolbar has no properties fileName: https://zimbra.domain.lan:7071/servi..._zimbra_hsm.js lineNumber: 355 stack: ([object Object])@https://zimbra.domain.lan:7071/service/zimlet/com_zimbra_hsm/com_zimbra_hsm.js:355 call([object Object],[object Object])@:0 ([object Ob...

    In Internet Explorer I also get a JS error, though it is different:

    JavaScript error encountered in method ZaController.prototype._setView
    name: TypeError message: 'this._toolbar' is null or not an object number: - 2146823281 description: 'this._toolbar' is null or not an object

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    can you stop the server and
    rm -rf /opt/zimbra/jetty/work/*
    zmcontrol start
    and clear your cache.

    See if it works.

  3. #3
    Join Date
    Jan 2008
    Posts
    30
    Rep Power
    7

    Default New error

    Now I get the following error from Firefox:

    Server error encountered Message: system failure: exception during auth {RemoteManager: zimbra.snp.org->zimbra@zimbra.snp.org:22} Error code: service.FAILURE Method: GetServerNIfsRequest Details:soap:Receiver

    This persists through reboots.

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Are you able to login? Where are you getting that error? During queue check?

  5. #5
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    If you're getting it say when you click on mail queues or certs in the admin console - try this:

    1. Check /etc/sshd_config and be sure it's set to 22
    Code:
    port 22
    2. stop/start/restart sshd
    Code:
    /etc/init.d/ssh restart
    3. su - zimbra
    4. Be sure zimbra's ssh port is set to 22
    Code:
    zmprov ms server.domain.com zimbraRemoteManagementPort 22
    5. Generate new ssh keys
    Code:
    cd /opt/zimbra/bin/
    ./zmsshkeygen
    6. Deploy the keys
    Code:
    ./zmupdateauthkeys
    To test this, you can run the following command:
    Code:
    ssh -i .ssh/zimbra_identity -o strictHostKeyChecking=no zimbra@server.domain.com -p 22
    -Shouldn't prompt you for a password at this point...then check the admin console mail queues area.
    If you continue to get that error please see this doc for some more ideas Mail Queue Monitoring - Zimbra :: Wiki

  6. #6
    prozaconstilts Guest

    Default

    I am also experiencing the same problem on 5.0.1GA Open Source.
    I followed the first suggestion and ran

    rm -rf /opt/zimbra/jetty/work/*

    and cleared my browser cache.

    I did not have the error troubles experienced after that, but still received the same error as before.

    Here are the details of the error as reported:

    JavaScript error encountered in method ZaController.prototype._setView message: xFormObject.items[2].items[5].items[4] has no properties fileName: https://myserver:7071/service/zimlet..._zimbra_hsm.js lineNumber: 456 stack: ([object Object])@https://myserver:7071/service/zimlet/com_zimbra_hsm/com_zimbra_hsm.js:456 call([objec...

    As far as I can tell, I do not have the ability to enable or diable the com_zimbra_hsm zimlet, so I'm assuming it's something that should always be on

    Thank you for any help.

  7. #7
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

  8. #8
    Join Date
    Jul 2006
    Location
    ireland
    Posts
    388
    Rep Power
    9

    Talking excellent

    Quote Originally Posted by jholder View Post
    can you stop the server and
    rm -rf /opt/zimbra/jetty/work/*
    zmcontrol start
    and clear your cache.

    See if it works.
    thanks John this worked for me

  9. #9
    Join Date
    Jan 2008
    Posts
    30
    Rep Power
    7

    Default

    It turned out to be an SSH issue - ssh runs on a non standard port to reduce the entries from script kiddies in the serverlogs.

    Thanks mmorse

  10. #10
    Join Date
    Jul 2006
    Location
    ireland
    Posts
    388
    Rep Power
    9

    Exclamation beware of removing /opt/zimbra/jetty/work/*


Similar Threads

  1. How to: cold standby server (no cluster)
    By fisch09 in forum Installation
    Replies: 50
    Last Post: 02-18-2014, 09:51 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 09:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •