Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: SLES10: Problem upgrading from Zimbra NE 5.0 to NE 5.0.1

  1. #1
    Join Date
    Oct 2006
    Posts
    78
    Rep Power
    9

    Default SLES10: Problem upgrading from Zimbra NE 5.0 to NE 5.0.1

    hi, i have a big problem with upgrading:

    Code:
    Operations logged to /tmp/zmsetup.01182008-130512.log
    Getting installed packages
    Getting local config zimbra_server_hostname
    Getting local config ldap_url
    zimbra_server_hostname contained in ldap_url checking ldap status
    Checking ldap status.
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    Starting ldap...
    *** Running as zimbra user: /opt/zimbra/sleepycat/bin/db_recover -h /opt/zimbra/openldap-data
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapapplyldif line 133.
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    *** Running as zimbra user: /opt/zimbra/bin/ldap start
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    Failed to start slapd.  Attempting debug start to determine error.
    
    failed with exit code 256.
    checking isEnabled zimbra-core
    zimbra-core not in enabled cache
    enabled packages
    zimbra_server_hostname contained in ldap_url checking ldap status
    Checking ldap status.
    
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    Starting ldap...
    *** Running as zimbra user: /opt/zimbra/sleepycat/bin/db_recover -h /opt/zimbra/openldap-data
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapapplyldif line 133.
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    *** Running as zimbra user: /opt/zimbra/bin/ldap start
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    Failed to start slapd.  Attempting debug start to determine error.
    
    failed with exit code 256.
    Setting defaults...
    Setting local config zimbra_java_home to /opt/zimbra/java
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_java_home='/opt/zimbra/java'
    2> /dev/null
    checking isEnabled zimbra-cluster
    zimbra-cluster not in enabled cache
    enabled packages
    zimbra_server_hostname contained in ldap_url checking ldap status
    Checking ldap status.
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    Starting ldap...
    
    *** Running as zimbra user: /opt/zimbra/sleepycat/bin/db_recover -h /opt/zimbra/openldap-data
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapapplyldif line 133.
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    *** Running as zimbra user: /opt/zimbra/bin/ldap start
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    Failed to start slapd.  Attempting debug start to determine error.
    
    failed with exit code 256.
    checking isEnabled zimbra-store
    zimbra-store not in enabled cache
    enabled packages
    zimbra_server_hostname contained in ldap_url checking ldap status
    Checking ldap status.
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    Starting ldap...
    *** Running as zimbra user: /opt/zimbra/sleepycat/bin/db_recover -h /opt/zimbra/openldap-data
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapapplyldif line 133.
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    *** Running as zimbra user: /opt/zimbra/bin/ldap start
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    sudo: /etc/sudoers is mode 0640, should be 0440
    Failed to start slapd.  Attempting debug start to determine error.
    
    failed with exit code 256.
    the upgrade process never ends, because of these LDAP errors.

    I'm astonished that the upgrade fails because:
    • my setup has ONLY two accounts;
    • my setup is fresh (done last week);
    • SLES 10 is in the list of SUPPORTED platforms
    so, I would really know if you test all Zimbra versions on a SLES10 server or not........

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by trapanator View Post
    so, I would really know if you test all Zimbra versions on a SLES10 server or not........
    Is that meant to be a serious question or is it rhetorical? Of course we test Zimbra on the supported platforms and we do extensive QA on it. Did you search the forums or wiki for an answer? Try searching the wiki for 'sudoers' and see if that fixes your problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Oct 2006
    Posts
    78
    Rep Power
    9

    Default

    Quote Originally Posted by phoenix View Post
    Is that meant to be a serious question or is it rhetorical? Of course we test Zimbra on the supported platforms and we do extensive QA on it. Did you search the forums or wiki for an answer? Try searching the wiki for 'sudoers' and see if that fixes your problem.
    Two yours ago I found the fix to the problem, by modifying "zmsetup.pl" scripts, thanks to the wiki page you mentioned.

    But, I would like to know why do you provide SLES10 packages without this modification, that would be uninstallable on these systems?

  4. #4
    Join Date
    Nov 2006
    Posts
    13
    Rep Power
    8

    Default same Issue on a fresh install on SLES 10 zcs network 5.0.1

    i want install a second Mailbox Server on SLES10 SP1. after installation i become following errors:

    -snip-
    Starting mailbox...FAILED
    Sat Feb 2 13:31:46 2008 Service mta is not enabled. Skipping amavis
    Sat Feb 2 13:31:46 2008 Service antivirus is not enabled. Skipping antivirus
    Sat Feb 2 13:31:46 2008 Service antispam is not enabled. Skipping antispam
    Sat Feb 2 13:31:46 2008 Service archiving is not enabled. Skipping archiving
    Sat Feb 2 13:31:46 2008 Service mta is not enabled. Skipping mta
    Sat Feb 2 13:31:46 2008 Service mta is not enabled. Skipping sasl
    Sat Feb 2 13:31:46 2008 Service imapproxy is not enabled. Skipping imapproxy
    Sat Feb 2 13:31:46 2008 Rewrote: /opt/zimbra/mailboxd/etc/jetty.properties
    Sat Feb 2 13:31:46 2008 Rewrote: /opt/zimbra/conf/log4j.properties
    Sat Feb 2 13:31:46 2008 Rewrote: /opt/zimbra/mailboxd/etc/jetty.xml
    sudo: /etc/sudoers is mode 0640, should be 0440
    mailboxed failed to start.


    Starting snmp...Done.
    Starting spell...Done.
    Starting stats...Done.
    zimbra@server2:/root> zmcontrol status
    Host lxpop2e.dmz.as29145.net
    mailbox Stopped
    zmmailboxdctl is not running
    snmp Running
    spell Running
    stats Running

    zimbra@server2:/root> zmmailboxdctl start
    sudo: /etc/sudoers is mode 0640, should be 0440
    mailboxed failed to start.
    -snip-

    i did not found any solution in the wiki. can you tell me the link to solve this problem

    Thank you

  5. #5
    Join Date
    Dec 2007
    Posts
    50
    Rep Power
    7

    Default

    The way I have install Zimbra on Suse (SLES) 10.1 was to do the following:

    -Run the install.sh with the -s option, which is Software only installation.

    -vi /opt/zimbra/libexec/zmsetup.pl and look for the line that contains "if ($platform =~ /SuSE|openSUSE|SLES/) { `chmod 640 /etc/sudoers`;}" and change is the 640 to 440.

    -Then run zmsetup.pl

    I also found that I had to do the same with upgrading the software.

    Using this method I have been able to setup a multi-server environment using SLES 10.1 for two LDAPs, two MTAs, and three mailbox servers.

  6. #6
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    The problem is that SuSE isn't consistent in how it wants /etc/sudoers treated. Our default for all other OSes is 440. We don't run into problems on our installs with setting it to 640, so something is different with your install that is causing that to be problematic. In fact in our installs, setting it to 440 is what causes problems on SuSE.

    --Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  7. #7
    Join Date
    Feb 2008
    Posts
    10
    Rep Power
    7

    Smile

    Quote Originally Posted by drhughes View Post
    The way I have install Zimbra on Suse (SLES) 10.1 was to do the following:

    -Run the install.sh with the -s option, which is Software only installation.

    -vi /opt/zimbra/libexec/zmsetup.pl and look for the line that contains "if ($platform =~ /SuSE|openSUSE|SLES/) { `chmod 640 /etc/sudoers`;}" and change is the 640 to 440.

    -Then run zmsetup.pl
    ....
    .
    Same exact problem on SLES 10.1, and this fixed the problem. Thank you, Thank you Thank you!!!!

  8. #8
    Join Date
    Feb 2008
    Posts
    11
    Rep Power
    7

    Default

    Thanks for this post i was having the same issues of problems of "Initializing LDAP (29440)" Errors
    and for some reason installing via ./install.sh -s and then running the script manually worked.

    Thanks for the pointer I was going

    Anyone know why this needs to be done??

  9. #9
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    Quote Originally Posted by cam34 View Post
    Anyone know why this needs to be done??
    Because SuSE can't make up its mind about what they want to require the permissions to be on /etc/sudoers.

    --Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  10. #10
    Join Date
    Feb 2008
    Posts
    11
    Rep Power
    7

    Default

    Quote Originally Posted by quanah View Post
    Because SuSE can't make up its mind about what they want to require the permissions to be on /etc/sudoers.

    --Quanah
    Sorry I was referring to the "./install.sh -s and then running the script manually" part, or is that the same thing?
    I tried to install 3 times by ./install.sh - but failed each time - when i did ./install.sh -s it worked first time....

Similar Threads

  1. Creating accounts problem
    By d64 in forum Administrators
    Replies: 17
    Last Post: 02-13-2008, 06:24 AM
  2. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 11:45 AM
  3. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 09:39 AM
  4. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 03:33 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •