hi, i have a big problem with upgrading:

Code:
Operations logged to /tmp/zmsetup.01182008-130512.log
Getting installed packages
Getting local config zimbra_server_hostname
Getting local config ldap_url
zimbra_server_hostname contained in ldap_url checking ldap status
Checking ldap status.
*** Running as zimbra user: /opt/zimbra/bin/ldap status
Starting ldap...
*** Running as zimbra user: /opt/zimbra/sleepycat/bin/db_recover -h /opt/zimbra/openldap-data
*** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapapplyldif line 133.
*** Running as zimbra user: /opt/zimbra/bin/ldap status
*** Running as zimbra user: /opt/zimbra/bin/ldap start
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
Failed to start slapd.  Attempting debug start to determine error.

failed with exit code 256.
checking isEnabled zimbra-core
zimbra-core not in enabled cache
enabled packages
zimbra_server_hostname contained in ldap_url checking ldap status
Checking ldap status.

*** Running as zimbra user: /opt/zimbra/bin/ldap status
Starting ldap...
*** Running as zimbra user: /opt/zimbra/sleepycat/bin/db_recover -h /opt/zimbra/openldap-data
*** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapapplyldif line 133.
*** Running as zimbra user: /opt/zimbra/bin/ldap status
*** Running as zimbra user: /opt/zimbra/bin/ldap start
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
Failed to start slapd.  Attempting debug start to determine error.

failed with exit code 256.
Setting defaults...
Setting local config zimbra_java_home to /opt/zimbra/java
*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_java_home='/opt/zimbra/java'
2> /dev/null
checking isEnabled zimbra-cluster
zimbra-cluster not in enabled cache
enabled packages
zimbra_server_hostname contained in ldap_url checking ldap status
Checking ldap status.
*** Running as zimbra user: /opt/zimbra/bin/ldap status
Starting ldap...

*** Running as zimbra user: /opt/zimbra/sleepycat/bin/db_recover -h /opt/zimbra/openldap-data
*** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapapplyldif line 133.
*** Running as zimbra user: /opt/zimbra/bin/ldap status
*** Running as zimbra user: /opt/zimbra/bin/ldap start
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
Failed to start slapd.  Attempting debug start to determine error.

failed with exit code 256.
checking isEnabled zimbra-store
zimbra-store not in enabled cache
enabled packages
zimbra_server_hostname contained in ldap_url checking ldap status
Checking ldap status.
*** Running as zimbra user: /opt/zimbra/bin/ldap status
Starting ldap...
*** Running as zimbra user: /opt/zimbra/sleepycat/bin/db_recover -h /opt/zimbra/openldap-data
*** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapapplyldif line 133.
*** Running as zimbra user: /opt/zimbra/bin/ldap status
*** Running as zimbra user: /opt/zimbra/bin/ldap start
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
Failed to start slapd.  Attempting debug start to determine error.

failed with exit code 256.
the upgrade process never ends, because of these LDAP errors.

I'm astonished that the upgrade fails because:
  • my setup has ONLY two accounts;
  • my setup is fresh (done last week);
  • SLES 10 is in the list of SUPPORTED platforms
so, I would really know if you test all Zimbra versions on a SLES10 server or not........