Results 1 to 2 of 2

Thread: [SOLVED] Zimbra + ldap + samba: failed to add sambadomain

  1. #1
    Join Date
    Jan 2008
    Location
    Netherlands
    Posts
    3
    Rep Power
    7

    Default [SOLVED] Zimbra + ldap + samba: failed to add sambadomain

    Hello everybody

    Recently I have set up a shiny new Zimbra 5.01 system on ubuntu 6.06 running und vmware-server 1.04. I runs very nice.

    Then I saw the wiki article by Greg describing how to create a single sign on solution by adding posix and samba accounts to the Zimbra admin ui.

    I really like the idea to combine these things in one nice administration interface (sofar I was using linbox directory server for the unix/windows accounts)

    I followed the guide as precise as possible. One major deviation is that I did not add the samba schema inclusions in slapd.conf.in but in the real slapd.conf. because there was no slapd.conf.in. I checked wheter the inclusions were still present after reboot and this was indeed the case.
    (4.5 - 5.0 difference?)

    I setup a samba file server in another virtual machine (ubuntu gutsy + samba 3.0.26a) and used the samba.schema from this install on the zimbra machine.

    Then I ran into the same problem as described by antonmb here: http://www.zimbra.com/forums/install...html#post44744

    The sambadomain is not automatically added to the ldap tree.

    here is the result for the net getlocalsid command on the fileserver
    Code:
    root@fileserver:~# net getlocalsid
    [2008/01/21 19:40:05, 0] lib/smbldap_util.c:smbldap_search_domain_info(286)
      smbldap_search_domain_info: Adding domain info for BBDBEHEER.NET failed with NT_STATUS_UNSUCCESSFUL
    SID for domain FILESERVER is: S-1-5-21-1220456624-xxxxxxxxx-xxxxxxxxx
    I checked my samba log file and found the following entries:

    Code:
    tail -n 200 /var/log/samba/log.smbd
    ...
    ...
     Becoming a daemon.
    [2008/01/21 19:40:02, 2] lib/tallocmsg.c:register_msg_pool_usage(105)
      Registered MSG_REQ_POOL_USAGE
    [2008/01/21 19:40:02, 2] lib/dmallocmsg.c:register_dmalloc_msgs(75)
      Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
    [2008/01/21 19:40:02, 2] lib/smbldap_util.c:smbldap_search_domain_info(256)
      smbldap_search_domain_info: Searching for:[(&(objectClass=sambaDomain)(sambaDomainName=BBDBEHEER.NET))]
    [2008/01/21 19:40:02, 2] lib/smbldap.c:smbldap_open_connection(786)
      smbldap_open_connection: connection opened
    [2008/01/21 19:40:02, 3] lib/smbldap.c:smbldap_connect_system(997)
      ldap_connect_system: succesful connection to the LDAP server
    [2008/01/21 19:40:02, 3] lib/smbldap_util.c:smbldap_search_domain_info(278)
      smbldap_search_domain_info: Got no domain info entries for domain
    [2008/01/21 19:40:02, 3] lib/smbldap_util.c:add_new_domain_info(149)
      add_new_domain_info: Adding new domain
    It seems to be able to make contact with the zimbra ldap server, but something goes wrong with adding the sambadomain to the tree.

    Code:
    [2008/01/21 19:40:02, 1] lib/smbldap_util.c:add_new_domain_info(216)
      add_new_domain_info: failed to add domain dn= sambaDomainName=BBDBEHEER.NET,dc=bbdbeheer,dc=net with: Invalid DN syntax
            invalid DN
    [2008/01/21 19:40:02, 0] lib/smbldap_util.c:smbldap_search_domain_info(286)
      smbldap_search_domain_info: Adding domain info for BBDBEHEER.NET failed with NT_STATUS_UNSUCCESSFUL
    [2008/01/21 19:40:02, 2] passdb/pdb_ldap.c:pdb_init_ldapsam(5658)
      pdb_init_ldapsam: WARNING: Could not get domain info, nor add one to the domain
      pdb_init_ldapsam: Continuing on regardless, will be unable to allocate new users/groups, and will risk BDCs having inconsistant SIDs
    ...
    ...
    Trying to add the domain manually in de zimbra administration console is not working either and results in the error observed by antonmb

    Somehow it thinks the DN is invalid.

    I'm struggeling for 2 days now with this problem and I still cannot get the thing to work. I tried several things, including different sambadomain names and changing the ldap passwords, but nothing seems to work.

    I would really appreciate all suggestions or help!
    Last edited by paraiko; 01-23-2008 at 12:28 PM. Reason: corrected typos

  2. #2
    Join Date
    Jan 2008
    Location
    Netherlands
    Posts
    3
    Rep Power
    7

    Default problem solved

    I struggled on and it turns out I made a mistake in editing the slapd.conf after all.

    I was editing the /opt/zimbra/openldap/etc/openldap/slapd.conf file
    instead of the /opt/zimbra/conf/slapd.conf.in file as the wiki guide suggests..

    how stupid can one be.....

    Everything works like a charm now.

Similar Threads

  1. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 04:43 AM
  2. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM
  3. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 12:00 PM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •