Results 1 to 4 of 4

Thread: [SOLVED] Stats "Running" But Not Working- System Failure

  1. #1
    Join Date
    Jan 2008
    Rep Power

    Default [SOLVED] Stats "Running" But Not Working- System Failure

    I have been searching the forums and wiki for several days now, and found similar threads, but nothing that seems to fix what I have going on right now.

    I have installed and deployed Zimbra 5.0 on a SLES10 SP1 server. Install went fine. I have continually had problems with the server status in the admin console. It works until the first log rotate and stops, giving the well-known "Server status data not available. Logger service must be installed" error. Well, searching the forums, it turns out you need to change several scripts because SLES' syslog doesn't respond to -HUP, you need to do a "/sbin/rcsyslog restart". That seemed to do it, as I got several good days of stats.

    I had a hard system lock-up a few nights ago, and upon restore, the error has changed. When I go to the admin console->Server Status, I get a pop-up saying:

    Server Error Encountered.

    Message: system failure: getting service status Error code: service.FAILURE Method: ZmCsfeCommand.prototype.invoke Details: soap:Reciever

    The error pops up every refresh, and it gives the "logger service must be installed" message. Going to Server Statistics produces no errors- but it doesn't appear as if any stats are being collected, since everything after the crash is flat and the graphs are being updated.

    /opt/Zimbra/log/startup.log doesn't show anything unusual on stop/start, every other log (/var/log/zimbra, zmd-backend, others) don't show any obvious error messages. Mail/calendar/etc is all working. zmcontrol status shows all good.

    I'd really like to have the stats working, as it worries me that that is broken and nothing else is. I can post any logs you want or need. Thanks for any help!

  2. #2
    Join Date
    Jan 2008
    Rep Power


    OK, luck of the draw.

    I managed to fix the problem. I had corrupted database tables. This thread, specifically the command "~/libexec/zmlogprocess" helped me discover the problem,

    And the linked to thread in there provided the solution. That was quick- but I was searching a weird tangent.

  3. #3
    Join Date
    Aug 2009
    Denver Colorado
    Rep Power

    Default can't run zmlogprocess

    I am stumped.. I logged in as user using putty.
    sudo bash

    then su zimbra

    i can run zmstatus -v but i can't run zmlogprocess it says command not found..

    if I cd to /opt/zimbra/libexec and do a dir i see the zmlogprocess listed

    if i try to run zmlogprocess still command not found..?

    I am a windows convert and I have not quite figured out all the stuff.. usually if you can't run something you login sudo bash and you can or even su zimbra..

    maybe someone can give me a quick rundown..

    My stats are not working on a clean install and I am trying to figure out why..?


  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    Quote Originally Posted by mshanley View Post
    su zimbra
    You should always ssh to your server as root then:

    su - zimbra
    The hyphen is important to create the environment. The correct command would be:



    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM
  2. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  4. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 11:01 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts