Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: [SOLVED] Fedora7 error zmldapinit line 160

  1. #1
    Join Date
    Jan 2008
    Posts
    9
    Rep Power
    7

    Default [SOLVED] Fedora7 error zmldapinit line 160

    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    IO::Socket::INET: connect: timeout at /opt/zimbra/libexec/zmldapinit line 160.
    failed. (29440)

    what does this mean? I'm running a fresh and dully updated Fedora 7 and ZCS 501 GA

  2. #2
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    It means it couldn't talk to slapd. There is missing requirement in the 5.0.0 and 5.0.1 builds for F7 that will be fixed in 5.0.2. Install the libtool-ltdl package before installing Zimbra, and you should be fine.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  3. #3
    Join Date
    Jan 2008
    Posts
    9
    Rep Power
    7

    Default

    I had already done that, and the sudoers mod too...

    tried uninstalling ./install.sh -u and then reinstalling.

    still not working... what else?

    andy

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Do you have iptables on? SELinux? Also, what does your hosts file look like?

  5. #5
    Join Date
    Jan 2008
    Posts
    9
    Rep Power
    7

    Default

    the firewall is off. SElinux is disabled.

    hosts looks like
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    192.168.0.189 zimbra.mydomainname.co.uk zimbra

    its on a static ip behind a NAT firewall, i'm running myown DNS and it resolves forward and reverse.

  6. #6
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Do you already have something running on port 389?

    netstat -a | grep 389
    or
    lsof | grep TCP | grep 389

  7. #7
    Join Date
    Jan 2008
    Posts
    9
    Rep Power
    7

    Default

    [root@zimbra ~]# netstat -a | grep 389
    unix 15 [ ] DGRAM 3896 /dev/log
    unix 3 [ ] STREAM CONNECTED 6389 /tmp/.font-unix/fs7100

    I don't know what that means.

  8. #8
    Join Date
    Jan 2008
    Posts
    9
    Rep Power
    7

    Default

    lsof | grep TCP | grep 389 returns nothing

  9. #9
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    If you run it manually, what happens?
    /opt/zimbra/libexec/zmldapinit

    Also, can you tell me what's on that line?

  10. #10
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    As root, with zimbra installed, try this:

    Code:
    /opt/zimbra/openldap/libexec/slapd -d -1 -f /opt/zimbra/conf/slapd.conf -u zimbra

    This should give clear output of why slapd fails to start.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Similar Threads

  1. [SOLVED] 5.0 RC1 - mailboxd won't start after a reboot
    By staufj22 in forum Installation
    Replies: 17
    Last Post: 10-22-2007, 09:26 AM
  2. Firewall rules
    By rmvg in forum Installation
    Replies: 16
    Last Post: 09-04-2007, 03:20 PM
  3. Spam training problem...
    By TaskMaster in forum Installation
    Replies: 2
    Last Post: 05-08-2007, 10:49 AM
  4. Replies: 18
    Last Post: 03-20-2006, 02:22 PM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •